none
Substring Search Problem RRS feed

  • Question

  • Hi All,

    I want to enable Substring Search for fuzzy search, so I tried to modify SubstringEnabled property of ManagedProperty "Title". But when I run the PowerShell command below:

    $mp= Get-FASTSearchMetadataManagedProperty -name <ManagedPropertyName>
    $mp.StemmingEnabled=0
    $mp.SubstringEnabled=1
    $mp.update()

    And the following error occurred:

    Every ManagedProperty mapped to the same FullTextIndex must have the same SubstringEnabled setting.

    Does anyone know how to solve this problem? Thanks!!

     

    Saturday, November 20, 2010 12:58 PM

All replies

  • hi,

    As the error msg says, every ManagedProperties connected to the SAME FullTextIndex must have the same SubstringEnabled setting.

    solution:

    - create a new managedproperty or remove the mapping between managedproperty and the fulltextindex

    - set the correct substringenable and stemmingenabled

    - update the managedproperty

    - create a new Fulltextindex

    - set the stemmingenable = 0 for the fulltextindex

    - connect the new mangedproperty to the new fulltextindex.

     

    You can go here for more info: http://64.4.11.252/en-us/library/gg130819.aspx#BKMK_Configure_Combination_Linguistic_And_Substring

     

    //Sebastian

    • Proposed as answer by tuanmn Thursday, March 17, 2011 1:35 PM
    Wednesday, March 16, 2011 9:56 AM