none
Deployed scheduled task 0x80070005 Access is denied, task to reboot server

    Question

  • Hello,

    I am trying to set up a group policy object to deploy a scheduled task to our 2012 R2 servers. I want this task to basically run the command: "shutdown -r -t 300"

    When the group policy refresh occurs, I get error 0x80070005 access is denied.

    I have seen several posts through Google, relating to this error, and suggesting to make sure the tasks is not set to run in current users' security context. I do not have the option to change this.

    I have created the task as domain administrator, and am trying to run as domain administrator. The domain admin account does have log on as batch rights.

    Can anyone else advise what else I can check?

    Cheers, Eds


    Thursday, April 02, 2015 4:08 PM

Answers

  • Hi,

    >>I have created the task as domain administrator, and am trying to run as domain administrator. The domain admin account does have log on as batch rights.

    Based on the description, we can try to run the schedule with system account NT Authority\System and check the option Run with highest privileges to see if it helps.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Eds19891 Monday, April 06, 2015 9:28 AM
    Friday, April 03, 2015 9:01 AM
    Moderator

All replies

  • Hi,

    >>I have created the task as domain administrator, and am trying to run as domain administrator. The domain admin account does have log on as batch rights.

    Based on the description, we can try to run the schedule with system account NT Authority\System and check the option Run with highest privileges to see if it helps.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Eds19891 Monday, April 06, 2015 9:28 AM
    Friday, April 03, 2015 9:01 AM
    Moderator
  • Hi,

    >>I have created the task as domain administrator, and am trying to run as domain administrator. The domain admin account does have log on as batch rights.

    Based on the description, we can try to run the schedule with system account NT Authority\System and check the option Run with highest privileges to see if it helps.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thanks, that has done the trick!!
    Monday, April 06, 2015 9:28 AM