locked
Sequenced App-V Shortcut works on Vista but not Windows 7 RRS feed

  • Question

  • We have recently come across an issue whereby a sequenced in-house application has a peculiar issue. The App-V appliaction effectively just runs a shortcut to a network location: -

    V:\OraForms\BIN\ifrun60.EXE module=strroot.fmx

    This works fine, but one of the functions within the application that opens a link to a network UNC and opens a word document causes a Windows Installer error in the application event viewer logs. I tried lots of Windows Installer fixes without any luck and bizarrely the workaround seems to be taking App-V out of the equation and creating a direct shortcut and it works fine. We just noticed on Windows 7.

    The Windows Installer Error showed the following -

     Detection of product '{90120000-0011-0000-0000-0000000FF1CE}', feature 'ProductFiles', component '{97F81AF1-0E47-DC99-A01F-C8B3B9A1E18E}' failed. The resource '' does not exist.

    Detection of product '{90120000-0011-0000-0000-0000000FF1CE}', feature 'WORDFiles' failed during request for component '{0638C49D-BB8B-4CD1-B191-051E8F325736}'

    Windows Installer proxy information not correctly registered

    Failed to connect to server. Error: 0x80004005

    Any assistance much appreciated

    Sean

     

    Wednesday, July 7, 2010 8:22 AM

Answers

All replies

  • What steps did you do during the monitoring phase during sequencing? Have you sequenced on Windows 7 before deploying to Windows 7?
    Wednesday, July 7, 2010 8:31 AM
    Moderator
  • Hi Aaron,

    Thanks for replying.

    The same sequenced application ( with only the shortcut ) has been working on Vista for the last 2 years or so. It has not been re-sequenced for Windows 7 and only the OST file has been edited to include Win 7 which we have done successfully with other apps. Given it's only a shortcut sequence, its very bizzare?

    Wednesday, July 7, 2010 10:14 AM
  • Aaron,

    Here is the actual OSD file:

    <?xml version="1.0" standalone="no"?>
    <SOFTPKG GUID="1C9ABC8B-603B-4C70-9D71-C44C84D47311" NAME="Straight Through Reporting" VERSION="001">
     <IMPLEMENTATION>
      <CODEBASE HREF="rtsp://Softgridvas:554/Oracle_Forms_Shortcuts_ORA_SCS.001/Oracle_Forms_Shortcuts_ORA_SCS.001.sft" GUID="A56410E4-070E-4D27-9335-5B0D2FE96E5D" PARAMETERS="module=strroot.fmx" FILENAME="V:\OraForms\BIN\ifrun60.EXE" SYSGUARDFILE="ORA_SCS.001\osguard.cp" SIZE="2644303"/>
      <OS VALUE="WinVista"/>
      <OS VALUE="Win2008TS"/>
      <OS VALUE="Win7"/>
      <WORKINGDIR/>
      <VIRTUALENV TERMINATECHILDREN="FALSE">
       <ENVLIST/>
       <POLICIES>
        <LOCAL_INTERACTION_ALLOWED>TRUE</LOCAL_INTERACTION_ALLOWED>
       </POLICIES>
      </VIRTUALENV>
      <VM VALUE="Win32">
       <SUBSYSTEM VALUE="windows"/>
      </VM>
     </IMPLEMENTATION>
     <DEPENDENCY>
      <CLIENTVERSION VERSION="3.1.2.2"/>
     </DEPENDENCY>
     <SUITE NAME="Oracle_Forms_Shortcuts_ORA_SCS.001"/>
     <TITLE>Name</TITLE>
     <ABSTRACT>Windows Vista with IE7 - SoftGrid 4.2 - 22nd Oct 07</ABSTRACT>
     <MGMT_SHORTCUTLIST>
      <SHORTCUT LOCATION="%CSIDL_STARTMENU%" FILENAME="" OVERRIDDEN="TRUE" DISPLAY="Straight Through Reporting" ICON="%SFT_MIME_SOURCE%/Oracle_Forms_Shortcuts_ORA_SCS.001 Icons/Str_Oracle_Forms_Shortcuts_ORA_SCS.001.ico"/>
     </MGMT_SHORTCUTLIST>
     <MGMT_FILEASSOCIATIONS>
      <PROGIDLIST/>
      <FILEEXTENSIONLIST/>
     </MGMT_FILEASSOCIATIONS>
    </SOFTPKG>

    Wednesday, July 7, 2010 10:24 AM
  • The OSD file mentions App-V 4.2, have you tried recreating the shortcut in 4.5 or 4.6, as 4.2 was never supported for Windows 7?
    Wednesday, July 7, 2010 10:56 AM
    Moderator
  • Hello,

    Any difference in what version / service pack for office is deployed to vista / win7?

    /Znack
    Thursday, July 8, 2010 4:30 PM
  • No, they are exectly the same ( Office 2007 SP2). We're going to use group policy to deploy the shortcut instead, but it's very frustrating that a simple shortcut won't work on Win 7?
    Thursday, July 8, 2010 5:21 PM
  • Hello,

    Is there a specific reason for including LOCAL_INTERACTION_ALLOWED in the OSD? Also what does the package contain otherwise, you state it's for the shortcut but surely there's something inside? Additionally, if it's from SG 4.2 era, is there by any chance Windows Installer runtime files included in the VFS?

    /Kalle

    Monday, July 12, 2010 1:54 PM
    Moderator
  • I have a similar issue and it's definately to do with the sequence. I can start up one bubble like this

    • sfttray /exe cmd "APp1"

    And lauch WINWORD.EXE without issue. When  start up a different application bubble and do the same I get this message in the event viewer:

    • Detection of product '{90120000-0011-0000-0000-0000000FF1CE}', feature 'WORDFiles' failed during request for component '{0638C49D-BB8B-4CD1-B191-051E8F325736}'

    And when I get to word it displays this message and then exist when you hiy 'Ok'

    I've tried runnig procmon.exe in the bubble but can't see any clues to whats going on.

    Wednesday, September 26, 2012 3:57 PM
  • Hello,

    See solution #10

    http://support.microsoft.com/kb/931914


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, September 26, 2012 4:06 PM
  • Hello,

    See solution #10

    http://support.microsoft.com/kb/931914


    Nicke Källén | The Knack| Twitter: @Znackattack

    Hi,

    Which resolution did you use exactly and for which issue? Thanks for the post :)

    Wednesday, September 26, 2012 4:17 PM
  • Ehm, #10?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, September 26, 2012 4:18 PM