locked
administrative rights taken away at C: now known as NTSF school lap help! RRS feed

  • Question

  • specs;  win 7 home on a dell lap runnin int 8 exe

    Okay this is  my boys lap top which he uses for school and video games only. Anyway...the other day I notoced a remote connection to ie and there after changes were made settings ect,...i began to notice it was slowing down significantly, after running numerous security checks and anti virus scans I checked out the hard drive properties and noticed the hard drive and noticed "trusted installer" in ownership. I immediately jumped to the conclusion that the pc was being hi jacked and removed the user adding his name to it from the list. Soon enough ther ewere more changes happening. Local sservices were not functioning properly ect,..so I thought in case it crashes I better create another user acct. And so I did. Needless to say services are still shutting down and "access denied" on C: drive which displayed an unusaul letters and numbers looked like a network code or something but in attempts to save his lap top I tried to log in to the other account which btw now has administrator rights now (not sure how that changed) and could not error "account cannot e found or doesnt exist" to ad to all this crap....each time my son attempts to down load work sheets ect,...he cannot error code 0x80070005 engine? I ran a couple diagnotic checks but cannto make them out. My son has pc games stored in it and doesnt want to loose them as I feel his lap top is going to crash if we dont recover to manufaturers state.

    First how can we delete or disable admin rights to regain control from the current standerd acct? I tried command prompt but said "access denied" Although, i may have not typed in the cmd phrase correctly

    Would liek to get hte lap top up and running to its normal state He's has it since 7/2010

    Your help is greatly appreciated!

    Desperado

    Friday, August 31, 2012 8:13 AM

Answers

  • Hi,


    Please check whether there is restore point so that you could perform a system restore before this issue happened.


    Meanwhile, please try the following steps to take ownership:


    1) If you can access cmd, you can reset the security settings in Windows 7 with the following command: "secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose" (no quotes.)

      NOTE: If you can't access cmd when logged in, use this guide System Recovery Options. You can get to the command line when you access the System Recovery Options screen.  

    2) This command seems to give the ownership issue a kick up the backside, even though it seems nothing has changed. Go to Explorer, right click on C: and go to Properties.  

    3) Go to the Security tab and then Advanced.  

    4) Go to the Owner tab. Now you should be able to click Edit.

    5) If you don't have Administrators in the list under where it says "Change owner to:" then go to "Other users or groups". If you do, go straight to step 7.  

    6) On Others users or groups type in "Administrators" (no quotes) in the bottom box. Click Check Name and then OK.  

    7) Click Administrators and then OK. You've now given yourself ownership of C:! (As long as your account is an Administrator, that is.)  

    8) Click OK on the "Advanced Security Settings..." window to get back to the Properties window. You should now have a list of the Permissions and so on where before you only had something about how you couldn't view permissions. Progress, eh?  

    9) You may need to add in the Adminstrators group to edit their permissions. To do this, click "Edit" and then "Add" and type "Administrators" (no quotes) in the bottom box. Then hit Check Name and then OK.  

    10) Click Administrators in the list and tick the box in the Allow column next to "Full control".  

    11) Click Apply, you'll likely get a bunch of error messages about how this can't be applied to some files and folders. Just OK through them all. Once done, you should have access to your C: drive once more!


    Hope this helps.


    Vincent Wang

    TechNet Community Support

    • Marked as answer by Leo Huang Thursday, September 6, 2012 1:33 AM
    Monday, September 3, 2012 9:09 AM

All replies

  • ps. the same has ocurred to my lap top a remote connection was discovered and admin rights were taken away to my hard drive "access denied"  it looks like the same codes numsers s-1-2-5-3 ect,..only this time i didn'tmake any changes to the pc. Son is  using mine for now only I really want him to use his own with his games which he has played and saved since 2010  Again your help is greatly appreciated!

    desperado

    Friday, August 31, 2012 8:19 AM
  • Hi,


    Please check whether there is restore point so that you could perform a system restore before this issue happened.


    Meanwhile, please try the following steps to take ownership:


    1) If you can access cmd, you can reset the security settings in Windows 7 with the following command: "secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose" (no quotes.)

      NOTE: If you can't access cmd when logged in, use this guide System Recovery Options. You can get to the command line when you access the System Recovery Options screen.  

    2) This command seems to give the ownership issue a kick up the backside, even though it seems nothing has changed. Go to Explorer, right click on C: and go to Properties.  

    3) Go to the Security tab and then Advanced.  

    4) Go to the Owner tab. Now you should be able to click Edit.

    5) If you don't have Administrators in the list under where it says "Change owner to:" then go to "Other users or groups". If you do, go straight to step 7.  

    6) On Others users or groups type in "Administrators" (no quotes) in the bottom box. Click Check Name and then OK.  

    7) Click Administrators and then OK. You've now given yourself ownership of C:! (As long as your account is an Administrator, that is.)  

    8) Click OK on the "Advanced Security Settings..." window to get back to the Properties window. You should now have a list of the Permissions and so on where before you only had something about how you couldn't view permissions. Progress, eh?  

    9) You may need to add in the Adminstrators group to edit their permissions. To do this, click "Edit" and then "Add" and type "Administrators" (no quotes) in the bottom box. Then hit Check Name and then OK.  

    10) Click Administrators in the list and tick the box in the Allow column next to "Full control".  

    11) Click Apply, you'll likely get a bunch of error messages about how this can't be applied to some files and folders. Just OK through them all. Once done, you should have access to your C: drive once more!


    Hope this helps.


    Vincent Wang

    TechNet Community Support

    • Marked as answer by Leo Huang Thursday, September 6, 2012 1:33 AM
    Monday, September 3, 2012 9:09 AM