locked
SharePoint & Central Administration RRS feed

  • Question

  • Hi Everybody,

    I installed SharePoint 2010 with Kerberos authentication.

    After "Error-Free" installation, I am not able to access the Central Administration page.

    When I access Central Administration Page through localhost and IP address, its coming but when I tried the same page using http://server name:port number/, it asks for credential and when I put the credentials, it is is not accepting them.

     

    Suggestions are welcome. Please, do suggest a solution.

     

    Thanks & Regards

    Rajdeep

    Wednesday, April 13, 2011 12:08 PM

Answers

  • Hi,

    did you disable the loopback check in registry?

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

    and did you enable kerberos on your central administration in Active Directory?

    run on a AD controller the following command:

    setspn -S http/servername domain\farmaccount

    setspn -S http/servername.domain.com domain\farmaccount

    Regards


    • Marked as answer by Porter Wang Friday, April 22, 2011 3:45 AM
    Wednesday, April 13, 2011 12:36 PM

All replies

  • Hi,

    did you disable the loopback check in registry?

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

    and did you enable kerberos on your central administration in Active Directory?

    run on a AD controller the following command:

    setspn -S http/servername domain\farmaccount

    setspn -S http/servername.domain.com domain\farmaccount

    Regards


    • Marked as answer by Porter Wang Friday, April 22, 2011 3:45 AM
    Wednesday, April 13, 2011 12:36 PM
  • Absolutely correct, this was the first thing I tried on a brand new sharepoint installation and it fixed the error! 
    Monday, June 11, 2012 12:10 PM