none
Fails to install packages in Microsoft Open R RRS feed

  • Question

  • I have installed Microsoft Open R on RHEL 7 with below method and now fails to to install packages .

    Please help me to resolve the issue.

    1.using wget got the rpm 

    2.

    yum install microsoft-r-open-mro-3.4.3.rpm

    yum install microsoft-r-open-mkl-3.4.3.rpm

    yum install microsoft-r-open-foreachiterators-3.4.3.rpm

    3. 

    R

    Microsoft R Open 3.4.3

    The enhanced R distribution from Microsoft

    Microsoft packages Copyright (C) 2017 Microsoft Corporation

    Using the Intel MKL for parallel mathematical computing (using 4 cores).

    Default CRAN mirror snapshot taken on 2018-01-01.


    4. When i try to install packages i am getting below error .

    > install.packages("Boruta")
    Installing package into â/opt/microsoft/rclient/3.4.3/libraries/RServerâ
    (as âlibâ is unspecified)
    curl: (60) SSL certificate problem: unable to get local issuer certificate
    More details here: https://curl.haxx.se/docs/sslcerts.html

    curl failed to verify the legitimacy of the server and therefore could not
    establish a secure connection to it. To learn more about this situation and
    how to fix it, please visit the web page mentioned above.
    curl: (60) SSL certificate problem: unable to get local issuer certificate
    More details here: https://curl.haxx.se/docs/sslcerts.html

    curl failed to verify the legitimacy of the server and therefore could not
    establish a secure connection to it. To learn more about this situation and
    how to fix it, please visit the web page mentioned above.
    curl: (60) SSL certificate problem: unable to get local issuer certificate
    More details here: https://curl.haxx.se/docs/sslcerts.html

    curl failed to verify the legitimacy of the server and therefore could not
    establish a secure connection to it. To learn more about this situation and
    how to fix it, please visit the web page mentioned above.
    Warning: unable to access index for repository https://mran.microsoft.com/snapshot/2018-01-01/src/contrib:
      'curl' call had nonzero exit status
    Warning message:
    package âBorutaâ is not available (for R version 3.4.3)
    >
     

    Friday, February 8, 2019 11:55 AM

All replies

  • looks like some sort of proxy issue.
    Monday, February 11, 2019 7:48 PM
    Owner
  • Can you please explain in detail.

    Thanks

    Tuesday, February 12, 2019 1:19 PM
  • are you using a proxy server to connect to internet?
    Tuesday, February 12, 2019 9:36 PM
    Owner
  • Yes we use proxy server to connect to internet. Do we need to do additional steps to enable SSl communication with microsoft website.
    Wednesday, February 13, 2019 7:34 AM
  • We cannot help with proxy issues. You should not have to do anything special, but have seen proxy issues before.
    Wednesday, February 13, 2019 6:54 PM
    Owner
  • Jeroen is correct stating that we really can't troubleshoot proxy server problems.

    However, I can point you to some basic R information on setting proxy server configuration.

    1).  Take a look at the built-in R help for 'download.file':

    help(download.file)

    That contains quite a bit of information on configuring proxy servers for R.

    I would also take a look at the information posted at this link:

    https://support.rstudio.com/hc/en-us/articles/200488488-Configuring-R-to-Use-an-HTTP-or-HTTPS-Proxy

    Wednesday, February 13, 2019 11:37 PM
  • Due to proxy issue i am not able to install package so i am trying alternative method to install package on microsoft R open.
    As this is micorsoft R open forum can anyone please confirm  will there be any compatibility issue if i install Boruta package on micorsoft R open with 1st method as 2nd method fails with same curl: (60) SSL certificate problem. 

    Can i go ahead and install using 1st method for micorsoft R open? 

    1st method : install.packages("https://cran.rstudio.com/src/contrib/Boruta_6.0.0.tar.gz", repo=NULL, type="source")
    2nd method : install.packages("https://cran.microsoft.com//src/contrib/Boruta_6.0.0.tar.gz", repo=NULL, type="source")

    Thanks,

    Pushpa

    Tuesday, February 19, 2019 9:23 AM
  • That is possible, but it is not quite that easy.

    You need to install the dependent packages 'RcppEigen' and 'ranger' first, and those packages contain C and Fortran source code in them, so you will first need to install 'Rtools' for Windows from the CRAN website:

    1).  Install 'Rtools35.exe' from here:   https://cran.r-project.org/bin/windows/Rtools/

    2).  Restart your R session

    3).  Install the downloaded dependent package 'RcppEigen' from the CRAN website.

    4).  Install the dependent package 'ranger' from the CRAN website.

    5).  Install the Boruta package as mentioned above. 

    Tuesday, February 19, 2019 6:34 PM