none
Shared Windows 10 PC not showing up in Local Network on the same PC

    Question

  • Hi all,

    I have a Windows 10 64bit Pro PC and have shared my local C and D Drives via a Workgroup Lan setup with other Windows 7/8/10 pc's. My local Win 10 pc I have named Liveroom1 . 

    When I go to the Win 10 file manager on my local pc, and click on the (Network) menu, it doesn't show the Local shared computer icon at the top with the other shared network pc's.  The only way I can see that its shared, is via typing in the Network at the top eg \\Liveroom1 and enter. It will then show in the file manager on the left under network.

    I can see all the other Win 7/8/10 pcs on the network and access them ok. If I go to any of the other Win 7/8 pc's I can see my Shared Win 10 pc computer icon and access that ok. However if I go to my other Win 10 pc on the network it cannot see this Win 10 shared pc.

    I have tried changing the Shared Win 10 computer name and Workgroup name and no difference. Its a DHCP Network. I have reset the Modem and switches along the way and same problem.

    I next reset the TCP/IP Stack etc via the following commands below and rebooted, but same problem.

    netsh winsock reset catalog
    netsh int ipv4 reset reset.log
    netsh int ipv6 reset reset.log

    The only unusual thing I notice, is that if I open the File Manager on the local Win 10 PC and click on Network, there is a Computer icon called (Liveroom) without the 1 after it under  (Other Devices) half way down Network which has a different IP Address associated to it but is not the local computers IP address and cannot be deleted. There is no option to delete it either. I have no other pc's on the network with the name Liveroom .

    This problem has only just happened recently. I even tried rolling back the registry but same problem. Wondering if anyone can give me some advise as to where to go next. 

    Thanks in advance.

    Cyberzork

    Wednesday, January 27, 2016 1:04 PM

All replies

  • Hi cyberzork,

    Please check the network Adapter properties under:

    Settings->Network and Internet->Ethernet, or WIFI.

    Then click on the available connections, make sure we turned on the function:

    Besides, check to see if the following thread would help here:

    https://social.technet.microsoft.com/Forums/en-US/e43bdd35-6dc6-4182-b7a4-1b77cb7fc16a/following-upgrade-to-windows-10-nas-unit-does-not-show-under-network?forum=win10itpronetworking

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, January 28, 2016 7:34 AM
    Moderator
  • Hi Michael,
    Thanks for that. I will check the (Devices and Content) setting / thread as you suggested.

    I have also upgraded two other Win 7 pc's today to Windows 10 and both of those are also (not showing) the local shared computer icon in their Network window. All the Win 10 pc's like the Win 7 / 8 pcs are all on the same workgroup and time and date the same.
    I can see all the other (Non Win 10) shared pc's in the Network, so only appears to be a problem with the Win 10 pc's that have been upgraded from Win 7 / 8.
    The Win 7 / 8 pc's can see their shared computer icon in their local Network window. Just an issue with the Win 10 pc's.

    The Liveroom computer looking icon under Other devices ended up being a Google Chrome adapter. I guess Win 10 doesn't know what it is, so just sticks it under Orher Devoces. At least I know what that was now.

    Cyberzork



    • Edited by cyberzork Sunday, January 31, 2016 6:35 PM
    Sunday, January 31, 2016 1:02 PM
  • Hi Michael,

    I have checked Find Devices and Content via my Ethernet Hardwired adapter and its already set to On. Tried turning this Off and On, but same problem.

    I have also checked the above Thread and I have SMB Sharing checked / enabled in the Windows Add/Remove features. Unchecking and Rechecking this option made no difference.

    Also made sure there were no ## Entries in the Registry Mountpoints2 as per the Thread suggestions.

    I am beginning to suspect some sort of Windows 10 workgroup sharing issue as its happening on all of my Windows 10 pc's since upgrading to Win 10 from Win 7/8. 

    Cyberzork

    Monday, February 1, 2016 4:16 AM
  • Still unable to see any Win 10 shared network drives in the Network window and all my 4 Win 10 PC's are build 1511 which Googling around seems to be an issue with this build on many different website forums. 

    Currently due to the above problem i have had to now Map drives on the boot for all Win 10 pc's.

    Wondering if there is a Fix or new Build on the way anytime soon.

    Cyberzork

    Wednesday, February 10, 2016 11:13 PM
  • Question
    You cannot vote on your own post
    0
    Since updating to Win 10 build 1607 on all my pc's i can now see all the shared network drives locally in the Network window, and on all my other networked computers. I no longer have to type the\\pcname\x etc . So was  some sort of problem with the earlier Win 10 builds for me anyways.
    Sunday, January 29, 2017 11:14 PM
  • I had a similar issue where 1/3 of the PCs on my home network did not show up in the network browser (all Win10). I was able to map and access the shared drives on that system but it was driving me crazy that I could not see it in the browser. Also if I turned on media streaming it would show up as a device in the browser. I tried every kind of troubleshooting and checked that network discovery etc. etc. was all on. The only thing that fixed it was doing a network reset, last option under Network & Internet settings, status tab. Hope that helps someone, I searched all over and didn't find anything else that worked.
    • Proposed as answer by Cycliste1961 Wednesday, October 18, 2017 9:56 AM
    Saturday, June 17, 2017 4:11 PM
  • Network reset worked here, as well. I wonder what weirdo setting was "hiding" the icon. Everything else worked like mapped drives, manually typing \\computername etc. Thanks for the tip. It was too easy.
    Monday, August 14, 2017 2:35 AM
  • ...and then I restarted the system, and it really worked, thanks for the help bro!!!
    Saturday, October 14, 2017 10:56 PM
  • That was the trick for me, thanks cybezork
    Wednesday, October 18, 2017 9:57 AM
  • This "network reset" worked for me also, got this problem when updating to Fall Creator's Update.  Its the only "home premium" Win10 system, all the others with Win10 Pro worked fine after the "Fall Creator's Update"
    Thursday, October 26, 2017 7:15 AM
  • I tried doing the network reset on both machines, rebooted both and it still doesn't work.

    On MJM, I see SRV under the network tab of Win Explorer. I can access drives on SRV, use remote desktop, etc. I don't see MJM as a network device.

    On SRV, I also see SRV but not MJM under the network tab. If I click on the network tab and enter \\MJM, that PC appears on the network tab and can be accesses. If I close WEx I have to repeat the process.

    Both machines are running Win 10 x64 release 1703.

    I checked all the above comments with no Joy.

    Mike

    Thursday, November 9, 2017 4:28 PM
  • Just to add to comments here, "network reset" also worked for me. Immediately after reboot, the PC is discoverable for other PC's on network
    Sunday, November 12, 2017 7:13 PM
  • This "network reset" worked for me too, thanks
    Thursday, November 16, 2017 3:32 PM
  • Yes, I've been using netwotk reset since I first installed windows 10, and it does work.

    Unfortunately, the problem reappears after the first restart, and nothing - other than another network reset - will make the PC show up on the network.

    All PCs are windows 10 and have static IPs but the problem only happens with the same two wired (ethernet) units, never happens with any of the other six (wired and wireless).

    It's really frustrating to have to network reset, then reboot those 2 computers every time they're switched on or restarted.


    Wednesday, November 22, 2017 1:54 PM
  • THANKS A LOT!  This seemed to be the ONLY thing that worked.  Doing the network troubleshooting did not fix this.  I had this problem on a Windows 10 HOME system with ALL the latest updates installed.

    I had another PC which was also connected via Ethernet with Windows 10 Home  (may wife's PC) and this problem did not occur for it.   Maybe it is related to my OLD Ethernet card in my OLD Dell XPS?

    Sunday, November 26, 2017 4:06 AM
  • This will most likely remedy your issue as it did for me. If not I wish you all the best.

    1) Open "Control Panel"

    2) Open "Network and Internet"

    3( Open "Network and Sharing Center"

    4) Open "Advanced sharing settings"

    In your current network "profile" look for "Turn On Automatic Setup Of Network Connected Devices" and REMOVE the check from it.

    5) Save the change and disable the network adapter and re-enable it.

    Look for the change in File Manager.

    This is what worked for me.
    • Edited by GH_ST Sunday, December 3, 2017 5:06 PM save added
    • Proposed as answer by mattnews22 Monday, January 14, 2019 5:05 PM
    Sunday, December 3, 2017 4:51 PM
  • This is trick I learned through trial and error.  I have spent months doing all the things that I could find on the net and nothing worked.  I have seven windows 10 computers on a home network and this has worked for me great. Follow these steps.

    1.  Shut down all computers on the network.

    2.  Bring up any one, just one, your choice.  That one will be the Master Browser and will show all the computers.

    3.  Then bring all the other computers up online.

    4. Go back to the first one that shows all the computers.  Do a right mouse button on them one at a time and create a shortcut on your desktop.

    5.  Create a folder and copy all the shortcuts into that folder, name it what you like.

    6.  Copy that folder to each one of your network computers.  Then click on the computer you want and map whichever drive you want.  Any mapped drive will always be in File Explorer.  Or just go to the folder and click on the computer you want access.

    Hope this helps any other almost bald person who has been pulling out their hair.




    • Edited by ch37 Wednesday, December 6, 2017 3:31 AM
    Wednesday, December 6, 2017 3:25 AM
  • Clearing the checkbox "Turn On Automatic Setup Of Network Connected Devices"  and next do the "network reset" worked for me.

    Also got this problem after updating to Fall Creator's Update.

    Saturday, December 16, 2017 1:49 PM
  • I have had the same problem for several months.  I did a network reset and reboot and it works fine now.  The Ipv6 is activated.  I also noticed that when I rebooted the VPN software I use (ExpressVPN) wasn't running.  When I started the ExpressVPN, the Ipv6 turned off and I couldn't connect to my other computer.  So maybe it is more related to using a VPN network than resetting the network settings?
    Thursday, December 21, 2017 2:14 AM
  • I just switched from ExpressVPN to NordVPN and the problem went away.  My Ipv6 stays connected and I can access files from the other computer now with the VPN actuated.
    Friday, December 22, 2017 3:31 AM
  • Hi Cyberzork,

    Do you run HyperV? If yes uninstall it.


    Momominta

    Saturday, December 23, 2017 5:55 AM
  • I just remembered that I had recently (before this very same problem occurred for me) had my router assign a static IP to my local machine. This caused Windows Explorer to not be able to "see" the local machine under the Network tab. I removed the static IP assignment and rebooted the router. Voila, works like it did yesterday.

    I did not troubleshoot the ip address beyond that. I have no need for a static IP for this machine, so I did not look any further into a solution. I'm just glad it's working for me now.


    • Edited by fk27bob Thursday, December 28, 2017 9:22 PM Grammar
    Thursday, December 28, 2017 9:21 PM
  • Windows 10 is garbage.  All those touting how great it is are brainwashed.  This network compatibility issues is just ONE example of the BS customers have to go through without ANY acknowledgement from Microsoft... I am SO sorry to have left Windows 7.
    Friday, February 9, 2018 3:49 PM
  • Hi cyberzork,

    You can try a fix from windows 10 settings > update & security > troubleshoot > below Find and fix other problems > Scroll until you see Shred Folders click on it then follow the process


    Momominta

    Friday, February 9, 2018 5:19 PM
  • Hi cyberzork,

    If you still face with the issue

    Symptoms in general 
    Assume that you try to turn on Network Discovery on a computer that is running Windows. To do this, you change the Advanced sharing settings in Network and Sharing Center. However, the changes are not saved. Therefore, you cannot turn on Network Discovery, and you experience the following issues:
    You cannot browse or find any network share.
    You cannot view shared folders on a local network.
    Cause
    This issue occurs for one of the following reasons:
    The dependency services for Network Discovery are not running. 
    The Windows firewall or other firewalls do not allow Network Discovery. 
    Resolution
    To resolve the issue, follow these steps:
    Make sure that the following dependency services are started:
    DNS Client
    Function Discovery Resource Publication
    SSDP Discovery
    UPnP Device Host
    Configure the Windows firewall to allow Network Discovery. To do this, follow these steps:
    Open Control Panel, click System and Security, and then click Windows Firewall.
    In the left pane, click Allow an app or feature through Windows Firewall if you are running Windows 10 or Server 2012. Or, click Allow a program or feature through Windows Firewall if you are running Windows Server 2008 or Windows Server 2008 R2.
    Click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    Select Network discovery, and then click OK.
    Configure other firewalls in the network to allow Network Discovery.
    Turn on Network Discovery in Network and Sharing Center.

    Momominta


    Monday, February 12, 2018 3:55 AM
  • This worked for me too!  

    I have been searching and trying just about every tip I could find on the internet.  Who knew this simple little reset would fix it for me.

    Thanks to the OP!!

    Wednesday, February 21, 2018 7:06 PM
  • THIS and only this was the solution for me. Once I started all 4 of these services and set to automatic ALL is well in the kingdom again!!! YES!!!

    Saturday, March 3, 2018 8:39 PM
  • After hours of web searching and trying multiple different setting options i came across this website

    How to Set Up Limited User Accounts in Windows 10

    https://www.laptopmag.com/articles/limited-user-accounts-windows-10

    I followed the 11 steps and created an limited user account in windows 10. Signed into the new account,
    then immediately signed back into my account and wallah all my network computers plus my 2 synology servers reappeared.

    Thanks,

    Steve
    Monday, March 5, 2018 11:30 PM
  • Same problem as others after Creators update - Windows 10 PC would not show up on any network via Explorer or on other PC's, although the media share did appear - but not the PC or shared folders or drives.  I checked the Dependency Services suggested above (found in Services under Administrative Tools for those needing help on where to look) and found Function Discovery Resource Publication was set to Manual and not activated.  Changed the setting to Automatic and rebooted after going through the rest of the checklist which was otherwise okay.

    Rebooted the Windows 10 PC and it finally appeared again on the network via Windows Explorer.  

    However, even though all the drives and folders are set up properly as shares, the Windows 10 PC is still blocking access to those shares, even with the firewalls turned off.  

    Same old Microsoft makes simple networking an enterprise-level insanity that's been going on for 20 years - every time there's a new update of consequence to an OS, networking is what most often breaks, apparently because no one on the update teams ever bothers to run it in a non-Enterprise environment.  Maddening.  


    • Edited by TVCCS Saturday, April 7, 2018 5:26 PM
    Saturday, April 7, 2018 2:37 PM
  • Perfect, this worked for me.  It wanted to make computer discoverable so Win 10 update apparently did something to this setting.  Worked on both my PCs.
    Friday, April 13, 2018 3:41 AM
  • I'm hoping you, or some other users, will be able to assist me expeditiously on this. I have an HP laptop and an HP all-in-one desktop PC, both running the latest build (as at the date of this posting) of Windows 10 version 1709. My desktop PC can "see" my laptop PC on the network, but cannot copy/modify/write files in Windows/File Explorer. It's also mapped the laptop PC as a network drive Z:. On my HP laptop PC, I can now "see" itself in Windows/File Explorer having now started UPnP service and set it to automatically start, but not the HP desktop PC.

    I've also tried running the HomeGroup troubleshooter and doing a network reset as described. I didn't see the setting in the original screenshot, but when into the adapter's "properties," and I believe there was one for TCP/IP or network adapter, and had a similar setting under the "sharing" tab, which I checked.

    I'd appreciate if someone can help me both:

    (a) Allow me HP desktop PC to show up in Windows/File Explorer on my HP laptop PC; and,

    (b) Help me with fixing the write/modify permissions for the HP laptop PC so that HP desktop PC can copy files. In HP laptop PC, I've given "full control" and "read/write/modify" to "everyone," but the HP desktop PC displays it differently (i.e., "Home Users"), which doesn't have write/modify/full control. I can find nowhere on HP laptop PC where to add those settings.

    Microsoft and HP Support were unhelpful - or wanted an arm and a leg to assist me, despite it being a fairly new computer.

    Cheers,
    Doug
    Monday, April 16, 2018 8:38 PM
  • I can't find network reset! Microsoft keeps changing Windows. Windows 10 Pro is one of the worst Windows Microsoft has ever created! I'm constantly having problems with it! Microsoft needs to go back to Windows 7. It works well.
    Wednesday, April 25, 2018 3:26 PM
  • *** SOLUTION INCOMING ***

    I have this problem ever since I use Windows machines, even on Win7 already, and now also on the latest Win10 after the April update. I tried everything here in the thread, including Network Reset, multiple times setting all kinds of network settings, disabling/enabling network adapter --> NO DICE.

    This issue with a PC in the network list not showing, yet the "invisible" PC definitely being there in the network (since you can access it with network file paths like \\Otherpc\ ) is strange and I suspect it being a timing issue, or an issue with the order how PCs in the network are switched on. It appears randomly and defies any logic, means a PC that yesterday was shown in the list all of a sudden doesn't despite no network settings having been changed.

    SOLUTION:

    Go into Control Panel --> Administrative Tools --> Services

    And look for the two services

    "Function Discovery Provider Host" &

    "Function Discovery Resource Publication

    Set both services to "Automatic (Delayed Start")

    Now right click each of these two services, and start them.

    BINGO <-- Your PC will show up.

    I have no idea why these 2 services on my PC had been set to manual, and I have no idea why they were not even running. (I did not change these services since I just installed Win10 on this PC two weeks ago and didn't change them. A few days ago I installed the April update as well. SOMETHING must have changed these services)

    Anyway, do what I described above...and the problem should be gone!



    • Edited by GeorgRa Tuesday, May 8, 2018 5:06 PM
    • Proposed as answer by ChrisW69 Wednesday, May 9, 2018 2:43 AM
    Tuesday, May 8, 2018 10:26 AM
  • Thanks a lot, I did not have much hair to start with and you saved what is left. I am on Build 17661
    Tuesday, May 8, 2018 11:16 PM
  • This was definitely the problem. Thanks so much!
    Wednesday, May 9, 2018 2:43 AM
  • Problem solved. this worked

    I next reset the TCP/IP Stack etc via the following commands below and rebooted, but same problem.

    netsh winsock reset catalog
    netsh int ipv4 reset reset.log

    Thursday, May 10, 2018 10:06 PM
  • YES!  This (*** SOLUTION INCOMING ***) worked when nothing else did!  THANK YOU!!!
    Friday, May 18, 2018 3:25 PM
  • And now it's not working... 
    Sunday, May 20, 2018 3:12 PM
  • Of cours, this is from January 2016 so it is completly out of date

    because Microsoft loves so much to change evrything all the time

    So, it does not work. What shoudl I do. I am really tiored to have new update that regularly destroy my network

    and impose to me to spend some of my time and my life to work on so stupid problem

    Please give me a good answer.

    Thursday, May 24, 2018 8:03 PM
  • Could this have something to do with the limited home networking features of Windows 10 Home?
    Sunday, May 27, 2018 7:32 PM
  • I did the network reset. I did not see my PC in the Network folder browser.

    However, I did connect to the shared folders by editing the top address and typing "\\COMPUTERNAME"

    I don't know if this worked due to the reset or just because I didn't try it before. I don't know why my machines are not showing up, but by creating a shortcut to a shared folder after I access \\COMPUTERNAME, I no longer care. Hope this helps.

    Sunday, June 3, 2018 4:54 AM
  • \\COMPUTERNAME worked! I've tried about 6~7 different things described here and somewhere else and restarted the computer and the other computers several times, nothing worked, but after typing the name of the computer I was trying to access on the same workgroup, the computer showed up. Thanks!
    Saturday, June 9, 2018 6:23 AM
  • open control panel > Administrative tools >Services or just type Services in the search bar and select it with the mouse.

    First find Function Discovery Provider Host, Double click it and change start up to Automatic (Delayed Start). If it is not already running click start in the left window highlighted in Blue

    Now find Function Discovery Resource Publication, which is directly below it , Double click it and change start up to Automatic (Delayed Start) again. If it is not already running click start in the left window highlighted in Blue

    Now restart the PC. All your Computers will now be visible. If any are not, do this on any PC's that do not show up in your network and then they will Appear. This only has to be set once per PC.

    Saturday, June 9, 2018 6:13 PM
  • This worked. Nothing did else, at least not reliably. I did a network reset on one system before trying this and noted that clicking the box to make the computer discoverable started the first service but not the second. It also did not set either service to Automatic start. Bug in the command, I guess.
    Monday, June 18, 2018 1:43 PM
  • On bended knee I thank you for this fix.  :)  What a torment this has been.
    Thursday, June 28, 2018 2:46 PM
  • THANKS GeorgRa !!!! I wasted so much time and this did it. Appreciate the post. :)
    Sunday, July 1, 2018 7:08 PM
  • Yes, I've been using netwotk reset since I first installed windows 10, and it does work.

    Unfortunately, the problem reappears after the first restart, and nothing - other than another network reset - will make the PC show up on the network.

    All PCs are windows 10 and have static IPs but the problem only happens with the same two wired (ethernet) units, never happens with any of the other six (wired and wireless).

    It's really frustrating to have to network reset, then reboot those 2 computers every time they're switched on or restarted.


    Welcome to windows10  the forced alpha release.  This, and many other aggravations, has plagued us all since people started bringing me their units with (what used to be) elementary issues...now a headache.  makes me want to go back to using a stone and a chisel!  At least it works!  M$ needs to apologize for releasing - forcing on people - such a half finished product. 
    Tuesday, July 3, 2018 4:45 PM
  • *** SOLUTION INCOMING ***

    I have this problem ever since I use Windows machines, even on Win7 already, and now also on the latest Win10 after the April update. I tried everything here in the thread, including Network Reset, multiple times setting all kinds of network settings, disabling/enabling network adapter --> NO DICE.

    This issue with a PC in the network list not showing, yet the "invisible" PC definitely being there in the network (since you can access it with network file paths like \\Otherpc\ ) is strange and I suspect it being a timing issue, or an issue with the order how PCs in the network are switched on. It appears randomly and defies any logic, means a PC that yesterday was shown in the list all of a sudden doesn't despite no network settings having been changed.

    SOLUTION:

    Go into Control Panel --> Administrative Tools --> Services

    And look for the two services

    "Function Discovery Provider Host" &

    "Function Discovery Resource Publication

    Set both services to "Automatic (Delayed Start")

    Now right click each of these two services, and start them.

    BINGO <-- Your PC will show up.

    I have no idea why these 2 services on my PC had been set to manual, and I have no idea why they were not even running. (I did not change these services since I just installed Win10 on this PC two weeks ago and didn't change them. A few days ago I installed the April update as well. SOMETHING must have changed these services)

    Anyway, do what I described above...and the problem should be gone!



           This worked for me.  Thanks a lot .
    Thursday, July 5, 2018 3:09 PM
  • Fantastic.  Now all 3 laptops/pc can be seen across the network and sharing finally works consistently
    Thursday, July 5, 2018 4:33 PM
  • Computer appears but is inaccessible. 

    Never had any problems with this before some recent update about a month ago.  Microsoft has royally messed up their Windows networking systems. There are other even more disastrous issues that I won't bring up here that have completely hampered my work flow.

    I can no longer access files over wifi from my laptop and have resorted to 1970s technology of flash drive data transfer.

    • Edited by ojaiguy Tuesday, July 10, 2018 6:57 AM
    Tuesday, July 10, 2018 6:54 AM
  •   If you are running version 1803, that is a different problem and is discussed in a different thread.

       This solved the problem I was having.

    https://social.technet.microsoft.com/Forums/en-US/6abc2b4e-00c3-47af-b412-4cd3b6b9668e/windows-10-ver-1803-intermittent-network-issue?forum=win10itpronetworking


    Bill

    Tuesday, July 10, 2018 7:24 AM
  • Many thanks GergeRa. This fixed the problem for me after wasting several hours trying to get the network back running again after the latest W10 update.
    Thursday, July 12, 2018 1:29 PM
  • Many, many thanks.  This worked.

    Monday, July 30, 2018 2:11 PM
  • Maybe can try some of the solution here for the network computer issue...

    http://www.techworked.com/solve-network-computers-not-showing-in-windows-10/
    Monday, July 30, 2018 4:14 PM
  • You legend, the only solution that works.

    Thanks so much.

    Sunday, August 5, 2018 2:30 PM
  • thank u a lot. I watsed a lot of time to fix this. Wish that I saw this suggestion sooner :( 
    Sunday, August 12, 2018 8:09 PM
  • This fixed it for me too.  I could see other machines on the LAN, but not the same win 10 machine.  Starting the services above solved the problem...no reset or restart needed.  Many thanks!!

    Monday, August 13, 2018 9:31 PM
  • Your solution was what worked for me.  Specifically it was turning on the "Function Discovery Resource Publication" Service that fixed my issue.  My Windows 10 PC's were not showing up under Network, but I could manually connect to them using their IP address, so I knew it wasn't a firewall issue.  Thanks to you I have fixed this issue on three Windows 10 PC's that have been bothering me for months.  :)

    Wednesday, August 15, 2018 9:05 PM
  • First, let me thank you for the suggestion: it worked immediately. But, I want to have a word for Microsoft. Maybe I am the dumbest user, but look at the absurd: in order to have benefit of the "automatic set up of network connected devices" I need to turn it off, because if I turn it on it will remain off!!! Try to sell a car which will stop if you push the accelerator and will accelerate if you step on the gas pedal!!!

    Another absurdity: the check had been on for a long time and everything worked fine. Now I need to turn the check off!!1

    If I had more time, I would set up a website named: "Life through the Windows of Paradise"

    Sunday, August 26, 2018 10:24 PM
  • Thanks so much for solving this Microsoft-created bug which had been over me for so many months now ! Spent hours reading forums with unhelpful Microsoft-written proposals but to no avail. Now, the problem is gone and I can share what I want over all my computers in the same network !
    Saturday, October 27, 2018 3:40 PM
  • Much appreciated GH_ST.  That did the trick quickly.
    Monday, November 26, 2018 1:40 AM
  • Thank you; it saved my day.
    Saturday, December 1, 2018 5:46 AM
  • GeorgRa, Thank you, this has worked for me...at least this one time.  Now wait to see if it still works tomorrow. 
    Saturday, December 22, 2018 10:55 PM
  • Someone noted that NetBios was the local computer discovery method. The network computers discovery method was WSD.

    I simply disabled the "local adapter" NetBios and bingo it showed in the network map. (the discovery method became WSD after the NetBios was disabled.

    As usual, this may work for me and not others as I had made other changes months ago and gave up.

    Jack

    

    Tuesday, December 25, 2018 7:56 AM
  • This worked for me!
    Saturday, January 5, 2019 9:00 PM
  • worked for me! thank you!
    Friday, January 11, 2019 10:01 PM
  • This will most likely remedy your issue as it did for me. If not I wish you all the best.

    1) Open "Control Panel"

    2) Open "Network and Internet"

    3( Open "Network and Sharing Center"

    4) Open "Advanced sharing settings"

    In your current network "profile" look for "Turn On Automatic Setup Of Network Connected Devices" and REMOVE the check from it.

    5) Save the change and disable the network adapter and re-enable it.

    Look for the change in File Manager.

    This is what worked for me.
    This worked for me. And on a Domain this setting will be under the 'Private' profile, but it still solves the problem.
    Monday, January 14, 2019 5:06 PM
  • As of 24/1 2019 this is still an issue with the services set to manual. Someone should've gotten fired by now I think...
    Thursday, January 24, 2019 2:31 PM
  • @Arvillian,

    \\computername probably always would have worked. This thread is mostly about not being able to see a computer on your lan in windows explorer under "network" while typing \\computername would work.

    • Edited by K Kruck Sunday, February 24, 2019 9:19 PM
    Sunday, February 24, 2019 9:17 PM
  • @Bill Grant, All,

    I have build 1803 and GeorgRa's solution worked for me. I just turned on function discovery resource publication service as mentioned by @Derek Bentley below and it began working. Not to say the suggestions in the thread won't either, but. ..

    Sunday, February 24, 2019 9:27 PM
  • Thank you GeorgRa. That worked perfectly and it was a straight to the point answer.
    Tuesday, April 30, 2019 8:39 AM