disable the option "view in windows explorer" RRS feed

  • Question

  •  How can i disable the option "view in a windows explorer" from a particular form library?
    Friday, December 5, 2008 8:00 AM


All replies

  • Hi,

    you can't OOTB.

    But you can SecurityTrimm that functionality so that "contributers" or with the correct permision is the only ones that could use the feature.

    There's a file called DefaultTeamplate.ascx located in "Hive12"\ControlTemplates that has a section callled <SharePoint:MenuItemTemplate with an attribute called ID="OpenInExplorer". What you need to do is to securitytrimm the PermissionString attribute to something else than "UseClientIntegration" (ex. ManageWeb), save and then run IISReset.

    Be sure to make a backup of the file before editing the file!

    Daniel Bugday

    Web: SharePoint Forum Blog: Daniel Bugday's SharePoint Blog

    Friday, December 5, 2008 12:42 PM
  • Moving to the customization forum (Design/Customization) as this isn't possible by using the UI.

    Friday, December 5, 2008 2:03 PM
  • You could also consider taking a look at the Toolbar Manager feature that is on codeplex.  http://www.codeplex.com/features
    ~Jennifer Mason My Blog
    Friday, December 5, 2008 2:30 PM



    There is a out-of-the-box method to make "view in a windows explorer" option disappear. Go to Central Administration > Application Management > Authentication Providers > Edit Authentication, then select “no” for enable client integration. After click save, you’ll not see the “view in a windows explorer” option.


    But, it is applied for all web application rather than a single library. And it also sacrifices many other features, you can balance to use this method or not.


    If you want to hide only one item in action menu, take reference from this link:



    Hope it can help you,


    Xing-Bing Yu
    Monday, December 8, 2008 6:10 AM
  • thanks guys, i managed to get this done with toolbnar manager
    Monday, December 15, 2008 6:44 AM