locked
Migration jobs failing with Couldn't find the specified instance RRS feed

  • Question

  • I'm struggling to work out why I cannot migrate packages. A sample of the error is:

    ERROR: [Worker]:                 Entity Unknown with path SMS_Package.PackageID='EX100210' failed with: Microsoft.ConfigurationManagement.SoftwareLibrary.ObjectSerialization.LibraryException: Couldn't find the specified instance SMS_Package.PackageID='EX100210'

    I have given the a/c used all possible rights that I can. It seems to have enough rights to collect data about objects on the source CM2007 server.

    But it cannot find the object it knows about.

    Any suggestions are welcome.

    Tuesday, October 23, 2012 4:23 PM

All replies

  • Is the package EX100210 existing on the CM07 site?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, October 24, 2012 7:56 AM
  • Yes. And other packages fail in the same way. (EX1 is the site code of the CM2007 site)
    Wednesday, October 24, 2012 8:17 AM
  • Looks like SQL rights issue.

    Try adding the Migration user to SQL rights : Sys admin. 


    Nicolai

    Wednesday, October 24, 2012 4:30 PM
  • I have already ticked every box for the migration user account including sys admin. A SQL Server guru cannot spot anything wrong with the rights on the CM2007 box.

    Wednesday, October 24, 2012 6:03 PM
  • Thanks for the response. I had seen this thread and had given the migration user all possible rights including db_datareader without it fixing the problem.

    As an experiment, I have just took away all permissions except db_datareader and the job failed with the same error.

    Still puzzled....

    Friday, October 26, 2012 9:33 AM
  • Is the SCCM 2007 With Service Pack 2?

    Have you looked at this:http://technet.microsoft.com/en-us/library/gg712313.aspx

    Have you checked all Site logs for errors on 2007 site.


    Nicolai

    Sunday, October 28, 2012 7:41 PM
  • Thanks for you interest. I'm still stuck.

    Version number of SCCM 2007 site is 4.00.6487.2000 with R3 build number 6487

    I cannot see anything in the article that has not been done.

    Cannot see any errors in the 2007 site logs. Do you have one in mind that might be most useful?

    Neil

    Friday, November 2, 2012 3:54 PM