locked
"i am following" webpart deleted RRS feed

  • Question

  • Hello,

    I deleted the Webpart "I am following" on the Newsfeedpage by mistace. Now, i can't include this part again. It's not shown in the Webpart list.

    What's the matter here?

    Note: I didn't delete the Webpart as itself, i deleted the part on the site content.

    Hopefully regards --> Dario

    Monday, September 15, 2014 9:59 AM

Answers

  • Hi Dario,

    Sorry, I understood the requirement differently in first go.

    “I’m following” web part resides on Default page of my site host. 

    From 15 hive I checked the My Site Host site definition(\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\SiteTemplates\SPSMSITEHOST\onet.xml) and found the web part definition there. 

     In the following definition you could add Title property and save it as "Followed Counts.dwp", upload it gallery and hopefully we can use it.

    <WebPart xmlns="http://schemas.microsoft.com/WebPart/v2"> 

      <Assembly>Microsoft.SharePoint.Portal, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c</Assembly>                        <TypeName>Microsoft.SharePoint.Portal.WebControls.FollowedCountsWebPart</TypeName>                        <Title>$Resources:spscore,FollowedCounts_WebPart_Title</Title>                       

    <Description>$Resources:spscore,FollowedCounts_WebPart_Description</Description>                       

    <PartOrder>1</PartOrder>                       

    <FrameType>None</FrameType>                       

    <AllowMinimize>true</AllowMinimize>                       

    <AllowRemove>false</AllowRemove>                       

    <IsVisible>true</IsVisible>                   

    </WebPart>



    Thanks! Best Regards, Prasham Sabadra http://prashamsabadra.blogspot.in

    • Marked as answer by Solidario Monday, September 22, 2014 6:43 AM
    Tuesday, September 16, 2014 9:37 AM

All replies

  • I assume you have disabled a feature which has caused this issue.

    Try to compare your mysite feature with someone else's feature and enable the missing feature


    If this helped you resolve your issue, please mark it Answered

    Monday, September 15, 2014 10:04 AM
  • Hi,

    You need to add "Social" app. Since these following entries are stored in "Social" library.

    just for reference : http://prashamsabadra.blogspot.fi/2012/08/small-finding-related-to-social.html 

    Please let me know if more details are required.


    Thanks! Best Regards, Prasham Sabadra http://prashamsabadra.blogspot.in

    Monday, September 15, 2014 10:06 AM
  • Hi,

    As I understand, you would like to add “I’m following ” web part which is Followed Counts web part.

    Please access another user my site without issue via SharePoint Designer, then click All Files > default.aspx > Locate FollowedCountsWebPart, put your cursor to among it, then web part tools will appear. Then save the web part to site gallery. Now go to page, insert web part under Miscellaneous group.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Tuesday, September 16, 2014 3:30 AM
  • Hello everyone,

    Thanks for your Support!

    @Rebecca & Inderjeet: I've tried this solution, but every user (also new generated user) have the same settings like me. So i can't restore the Followed Counts web part from someone else...

    @Prasham: In my app Library is the app "Social", with the following lists. But in mysite, when i would include a webpart, there aren't some social parts. I can't find the settings for that problem..

    Hopefully regards --> Dario


    Tuesday, September 16, 2014 6:36 AM
  • Hi Dario,

    Sorry, I understood the requirement differently in first go.

    “I’m following” web part resides on Default page of my site host. 

    From 15 hive I checked the My Site Host site definition(\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\SiteTemplates\SPSMSITEHOST\onet.xml) and found the web part definition there. 

     In the following definition you could add Title property and save it as "Followed Counts.dwp", upload it gallery and hopefully we can use it.

    <WebPart xmlns="http://schemas.microsoft.com/WebPart/v2"> 

      <Assembly>Microsoft.SharePoint.Portal, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c</Assembly>                        <TypeName>Microsoft.SharePoint.Portal.WebControls.FollowedCountsWebPart</TypeName>                        <Title>$Resources:spscore,FollowedCounts_WebPart_Title</Title>                       

    <Description>$Resources:spscore,FollowedCounts_WebPart_Description</Description>                       

    <PartOrder>1</PartOrder>                       

    <FrameType>None</FrameType>                       

    <AllowMinimize>true</AllowMinimize>                       

    <AllowRemove>false</AllowRemove>                       

    <IsVisible>true</IsVisible>                   

    </WebPart>



    Thanks! Best Regards, Prasham Sabadra http://prashamsabadra.blogspot.in

    • Marked as answer by Solidario Monday, September 22, 2014 6:43 AM
    Tuesday, September 16, 2014 9:37 AM
  • Thanks a lot!! That's the solution :)
    Monday, September 22, 2014 6:43 AM