locked
SharePoint 2010 MP, error when running configure task after adding new discovery settings to SharePointMP.config RRS feed

  • Question

  • In the documentation it says that I need to add several lines of code to the SharePointMP.config file in order to discover SharePoint 2010 Products. So I've added the code and when I run the 'Configure SharePoint Management Pack' task I get the following error:

    Exception calling "Load" with "1" argument(s): "'pack' is an unexpected token. The expected token is '='. Line 47, position 157."
    Failed to load configuration file SharePointMP.Config 

    The line it is referring to is:
    <Workflow Id="MOSSInstallation.Discovery;WACInstallation.Discovery;SearchExpressInstallation.Discovery;SearchStandardInstallation.Discovery" management pack="Microsoft.SharePoint.Server.2010" Type="Discovery" Times="1" /> 

    It matches the line in the documentation perfectly. What gives?

    Friday, January 20, 2012 5:36 PM

Answers

  • Try this

    <Workflow Id="MOSSInstallation.Discovery;WACInstallation.Discovery;SearchExpressInstallation.Discovery;SearchStandardInstallation.Discovery" MP="Microsoft.SharePoint.Server.2010" Type="Discovery" Times="1" />


    http://OpsMgr.ru/
    • Marked as answer by tpullins Tuesday, January 24, 2012 7:44 PM
    Sunday, January 22, 2012 4:55 PM

All replies

  • Try this

    <Workflow Id="MOSSInstallation.Discovery;WACInstallation.Discovery;SearchExpressInstallation.Discovery;SearchStandardInstallation.Discovery" MP="Microsoft.SharePoint.Server.2010" Type="Discovery" Times="1" />


    http://OpsMgr.ru/
    • Marked as answer by tpullins Tuesday, January 24, 2012 7:44 PM
    Sunday, January 22, 2012 4:55 PM
  • That worked, thank you!
    Tuesday, January 24, 2012 5:09 PM