locked
one workflow getting configuration error on auto email RRS feed

  • Question

  • I am using MOSS 2007. I've got a custom workflow that sends an auto email under a specific condition.  That workflow quit sending emails and is now throwing the usual "The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly"  error message.  The odd thing is that I created a NEW workflow on the same list for testing purposes.  All this workflow does is send me an email to see if email is working.  This works fine.  So this doesn't make sense to me that the server may not be configured correctly.  Other sites in the collection with custom workflows that send emails are working fine.  Can anyone advise me what to look for please.

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Friday, November 16, 2012 6:16 PM

Answers

  • Hi run4it,

    Here is another possible reason for the issue(I encountered it last week). The email was blocked as SPAM in the mail server. This can be confirmed from the ULS log.

    To verify it, we can change the email body, and have a testing again. If it works now, then assumption should be right.

    Thanks,
    Jinchun Chen


    Jinchun Chen(JC)
    TechNet Community Support

    Monday, November 26, 2012 9:01 AM
    Moderator

All replies

  • Is that a .Net workflow?

    Are you running the workflow from system account?  Please let me know...

    Friday, November 16, 2012 6:52 PM
  • The workflow was created in SPD. Yes, the User ID on the workflow history shows System Account.

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Friday, November 16, 2012 6:55 PM
  • Could you please login as contributor account (or) remove yourself from Site Collection administrator and then try...

    Hope this helps!

    Friday, November 16, 2012 7:03 PM
  • This error happens with other users who are not administrators.  A review of workflow history reviewed the error started a couple of weeks ago, but the lack of emails was just brought to my attention.  I did try adding an additional action to the end of the workflow that just sends me an email.  That email works.  Ugh.  I am happy to try to post my SPD workflow logic if that might help pinpoint the issue.

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Friday, November 16, 2012 11:26 PM
  • Hi,

    I understand that the send email action in one of your workflow doesn’t work. How do you specify the user to send the email to?

    I have seen similar cases that caused by pause action in the workflow. Or because the user in the To field for the email action is not properly selected. Also check the event viewer for more error message to see whether any software on your server prevent these emails.

    You can refer to these sites for more detailed information:

    The error message in workflow history: The e-mail message cannot be sent: http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomizationlegacy/thread/6e848a25-019d-4220-aff6-c535da933e0f

    create a workflow in sharepoint designer to send an email to the email address located in the form: http://www.infopathdev.com/forums/t/21496.aspx

    Workflow History : The email message cannot be sent. Make sure the outgoing email settings for the server are configured properly: http://techsuite.wordpress.com/2008/12/08/workflow-history-the-email-message-cannot-be-sent-make-sure-the-outgoing-email-settings-for-the-server-are-configured-properly/

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming

    TechNet Community Support

    Monday, November 19, 2012 6:32 AM
    Moderator
  • Entan, I read the links you provided.  Thank you.  One of them suggested hardcoding in the email address instead of using the Assigned To workflow variable in the To: field.  I tried this and I received the email!  I then put back in the Assigned To variable in the To field and it worked!  Other than testing that - nothing had changed that should have made this start working again.  Any ideas why it started working again?


    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Monday, November 19, 2012 7:51 PM
  • The workflow email quit again.  Ugh.

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.


    • Edited by run4it Monday, November 19, 2012 10:20 PM
    Monday, November 19, 2012 10:19 PM
  • Hi,

    Thank you for your question. I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience. Thank you for your understanding and support.

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming

    TechNet Community Support

    Tuesday, November 20, 2012 10:41 AM
    Moderator
  • Hi,

    You may want to turn up logging to verbose in Central Admin.   Set the following to verbose:

    E-Mail

    Workflow Infrastructure

    Reproduce the issue and post the actual error message form the ULS here.  We should be able clue into what is happening.  It might be something with the SPD workflow itself.


    Regards, Savoeurn Va Microsoft Online Community Support

    Wednesday, November 21, 2012 1:26 AM
  • Hi run4it,

    Here is another possible reason for the issue(I encountered it last week). The email was blocked as SPAM in the mail server. This can be confirmed from the ULS log.

    To verify it, we can change the email body, and have a testing again. If it works now, then assumption should be right.

    Thanks,
    Jinchun Chen


    Jinchun Chen(JC)
    TechNet Community Support

    Monday, November 26, 2012 9:01 AM
    Moderator