locked
Excel file save error: Someone else is working in <file> right now. Please try again later. RRS feed

  • Question

  • When trying to save a modified Excel file, which has been opened from a network share, our users are receiving the following message:

    Someone else is working in "\\domain.com\users\username\Document.xls" right now. Please try again later.

    The clients that have been affected are Windows 7 clients, and the DFS share is being served from a Windows 2012 server. I have already confirmed that DFS replication has not been enabled, so it isn't trying to lock files for replication. I have also disabled any real-time scanning that is occurring on the client to make sure that the AV software wasn't locking the files. I did notice when viewing the list of Open Files from the server's Computer Management console that when a users experiences this issue the file appears to be opened 4 times. Three times it shows that it was opened in Read mode and the 4th instance shows an Open Mode of Write. Typically, a file which is working correctly should just show one instance with the Open Mode of Read+Write. None of these open instances are temporary files preceded with a ~.

    Any thoughts?


    • Edited by EnVenAS Monday, June 30, 2014 3:35 PM
    Monday, June 30, 2014 2:15 PM

Answers

  • Hi,

    Does the issue occur in other operation system? Which Office version are you using? Have you ever tried to test with word document, PPT file or txt file?

    Based on your description, the issue may be caused by the same file open multiple time in computer management on SQL server. The user probably has User Access Control (UAC) enabled on the machine and it is not letting him overwrite the existing copy of the file because she does not have it open in administrator mode. UAC will block overwriting (saving) the existing file without Administrative privileges and it will automatically open the save as dialog so you can save with a different name and if you click save without changing the name at the point, it tries to save as a new file over the existing file and it can't because the file is open.

    I recommend you check the user's permission (Which showed in Computer Management console) and end the Excel file instance in the task manager of the user's client.

    Also, we may try the workaround: Save it to local drive(like drive c:) and then copy it to DFS.

    Thanks

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"

    • Marked as answer by George123345 Tuesday, July 8, 2014 1:16 AM
    Tuesday, July 1, 2014 2:28 AM

All replies

  • Hi,

    Does the issue occur in other operation system? Which Office version are you using? Have you ever tried to test with word document, PPT file or txt file?

    Based on your description, the issue may be caused by the same file open multiple time in computer management on SQL server. The user probably has User Access Control (UAC) enabled on the machine and it is not letting him overwrite the existing copy of the file because she does not have it open in administrator mode. UAC will block overwriting (saving) the existing file without Administrative privileges and it will automatically open the save as dialog so you can save with a different name and if you click save without changing the name at the point, it tries to save as a new file over the existing file and it can't because the file is open.

    I recommend you check the user's permission (Which showed in Computer Management console) and end the Excel file instance in the task manager of the user's client.

    Also, we may try the workaround: Save it to local drive(like drive c:) and then copy it to DFS.

    Thanks

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"

    • Marked as answer by George123345 Tuesday, July 8, 2014 1:16 AM
    Tuesday, July 1, 2014 2:28 AM
  • Here is some tips on how to troubleshoot errors when you save Excel files.

    http://www.repair-corrupt-files.blogspot.in/2014/06/how-to-fix-issues-with-excel-file-save.html

    • Marked as answer by George123345 Tuesday, July 8, 2014 1:16 AM
    • Unmarked as answer by EnVenAS Wednesday, July 9, 2014 1:33 PM
    Wednesday, July 2, 2014 9:36 AM

  • Hi,
    I'm marking the reply as answer as there has been no update for a couple of days.
    If you come back to find it doesn't work for you, please reply to us and unmark the answer.

    Thanks

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"

    Tuesday, July 8, 2014 1:16 AM
  • The issue only occurs when opening the Excel file from the network. It does not happen when opening the file from a local drive. All of the users have Modify permissions on the network files which are experiencing the issue. We are running Office 2013 with the latest updates. As stated above, I have only noticed this on Windows 7 clients so far.

    Based on your description, the issue may be caused by the same file open multiple time in computer management on SQL server.

    I'm not sure where a SQL comes into the equation, this is a file server and is not running SQL at all.

    Wednesday, July 9, 2014 1:33 PM
  • Did you ever fix this problem....I am having the same problem except my users have full permissions this only occurs on a network drive
    Tuesday, October 28, 2014 9:50 PM
  • I am having the same issue. Seems to be files over 50MB. 
    Monday, March 23, 2015 3:57 PM
  • Hi,

    Does the issue occur in other operation system? Which Office version are you using? Have you ever tried to test with word document, PPT file or txt file?

    Based on your description, the issue may be caused by the same file open multiple time in computer management on SQL server. The user probably has User Access Control (UAC) enabled on the machine and it is not letting him overwrite the existing copy of the file because she does not have it open in administrator mode. UAC will block overwriting (saving) the existing file without Administrative privileges and it will automatically open the save as dialog so you can save with a different name and if you click save without changing the name at the point, it tries to save as a new file over the existing file and it can't because the file is open.

    I recommend you check the user's permission (Which showed in Computer Management console) and end the Excel file instance in the task manager of the user's client.

    Also, we may try the workaround: Save it to local drive(like drive c:) and then copy it to DFS.

    Thanks

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"

    This is the least helpful advise.  I wasn't even going to comment on this initially but the way you answered this was ridiculous.  

    Clearly the original poster stating the user has the files saved on a network share because it is a corporate environment and you suggest for the file to be saved locally which does not resolve the issue at hand.

    How the hell do you even have a job?

    Friday, May 13, 2016 6:13 PM
  • Because they are copy and paste responses issued in a robotic fashion.
    Thursday, June 2, 2016 1:02 PM
  • Having this same problem with the same symptoms. File shows up in the Open Files console with 4 instances; 3 in Read Mode and 1 Read+Write.
    Thursday, July 28, 2016 5:56 PM
  • I have the same problem. One 2008 R2 and one 2012 R2 using DFS. User has full permissions to share and can even "Save As..." to the same share. Noticed that it was open a bunch of times in File Management as well. Spreadsheet is about 32MBs.  Has anybody else been able to resolve this?
    Wednesday, September 14, 2016 2:12 PM
  • Having the same issue with a 2012 DFS server and a client on Windows 10 and Office 2016.  All latest technologies with all pertinent updates.  Microsoft, fix your apps!  This problem has been around since Office 2010.

    Jim

    Monday, December 5, 2016 10:54 PM
  • George, 

    Please remove this reply as an "Answer."  We are all in agreement that this is not solved and yours is no answer.  It is misleading and cause for time wasted on the part of anyone searching for a solution as am I. 

    • Proposed as answer by Ravi this side Wednesday, June 26, 2019 9:38 AM
    Thursday, February 9, 2017 6:10 PM
  • Just to let everyone know,  

    We have an open case with Microsoft and they provided a client side registry key that has resolved our errors.  They have also stated however this key has known issues of causing delays in opening files.  Since I think delays are better than error message or corrupt files, I'm sharing it with you.  I don't know if it will work in your situation, but it has helped ours.  The case is still open and they are looking for a permanent fix, so this is considered a workaround at this point.

    On the client device, add the following key and reboot.

    [HKEY_CURRENT_USER\Software\Microsoft\Office\<Version>\Excel\Options] 
    “DisableRobustifiedUNC” = dword:00000001

    Hope it helps you!

    Jim




    Thursday, February 9, 2017 6:56 PM
  • This is a huge lifesaver.  This became an issue after DFS was put in place, but is still an issue when bypassing the DFS namespace and connecting directly to the server file share.

    Also, this is not an NTFS or permissions issue; it is isolated to Excel only, and appears to only happen when saving changes to an existing file, not creating one.

    Bypassing the app, the user can add/modify/delete in the same folder and share all day long.

    Anyway, this registry tweak helped--still would like to find a better solution.  FYI, this was observed in our case on Excel 2010 and confirmed as an issue on Excel 2016 also.

    Thursday, April 27, 2017 12:40 PM
  • Ultimately the issue was determined to be the WebRoot virus protection on the client device.  Removing this from the PC and removing the registry key resolved the issue for the client.

    Hope this helps,

    Jim

    Thursday, April 27, 2017 3:38 PM
  • Jim, would you mind giving simple advice to someone who's working at home, running a small business?  I don't understand all the jargon but I read the thread and you seem to talk the most sense.  And answered the question!  The Microsoft support site suggests coming here.  Because it also doesn't answer the question . . . .

    Thank you

    Wednesday, May 31, 2017 2:35 PM
  • I just contacted Microsoft for assistance with this same issue and they claim that the problem is outside of the scope of their support because the file is across a local network. Incredible. 

    I am left wondering if Excel is meant for use in a Windows network?

    Does anyone have an update on this? Is this registry key mod still the way to go?

    Thursday, June 29, 2017 9:01 PM
  • We are having the same issue in both Excel and Word, Office 2013 and 2016, Win 7 and Win 10.

    We tried the DisableRobustifiedUNC registry key and it does fix this issue, unfortunately in our environment it causes two other issues.

    1. Saving to their network home drive (H:\) works fine, but as we have folder redirection enabled for the local user profile Documents folder, which points to the UNC path of their H: drive (standard practice), it causes an issue when saving via "Libraries > Documents". Due to folder redirection using a UNC path the Libraries > Documents folder also uses the UNC path (instead of H:\Documents) and with DisableRobustifiedUNC enabled it gives a similar error of the file being in use by someone else. Basically DisableRobustifiedUNC breaks saving to UNC paths in Office.

    2. In our environment we also use Offline files for the users H: drive. When the user is Offline and trying to save to the offline H: drive via Office apps (with DisableRobustifiedUNC enabled) they get the error 'Cannot complete the save due to a file permission error'. Not every time, but at least more than 50% of the time they get this error.

    Neither of the above 2 errors occur when you delete DisableRobustifiedUNC from the registry. 1 problem solved, 2 created... both which caused much more impact on our users than the original issue.

    I've searched for any other potential fixes but can't find anything. Are there any other suggestions? If other people are experiencing this issue then please post here to raise visibility of this issue!

    Thursday, October 26, 2017 9:41 AM
  • This really helped!!! Thank you. 
    Friday, December 1, 2017 3:53 PM
  • Ultimately the issue was determined to be the WebRoot virus protection on the client device.  Removing this from the PC and removing the registry key resolved the issue for the client.

    Hope this helps,

    Jim

    Hi Jim was this confirmed by Webroot? We have Webroot also but its not a option to remove it?! Do you have a case number or information on how you determined it was Webroot?

    Kind Regards

    NortonWay

    Wednesday, June 27, 2018 12:30 PM
  • We worked with Microsoft and they identified the driver causing the issue as Webroot.

    Jim

    Wednesday, June 27, 2018 3:31 PM
  • This fix actually worked. We had two companies experiencing same issue. Great job.
    Thursday, September 20, 2018 1:25 PM
  • Hi ,

    Can you please explain how did you resolve the issue

    Thursday, October 25, 2018 11:37 AM
  • Hi Jim,

    Your solution is pretty well... after following above steps my problem has been resolve.

    Thanks...

    Wednesday, June 26, 2019 9:33 AM
  • Hi Jim

    This was lifesave solution , thanks

    Monday, March 23, 2020 2:23 PM
  • George's solution worked for me. Not all of it, as I don't understand most of it. But I couldn't save an Excel file that I know I was the only one working in (same error as original post). I saved it to my local drive then I was able to copy it to the shared drive successfully. This was after multiple failed attempts to save the 95MB file directly to the shared directory and restarting my computer to ensure something wasn't running in the background. Did you not read the "then copy it to DFS"?

    Thanks, George.

    Thursday, May 28, 2020 1:52 AM