locked
Orchestrator 2012 with IP for Operations Manager 2007 R2 RRS feed

  • Question

  • Hi,

    I try to create an alert with Orchestrator in Operations Manager 2007 R2.

    I have installed the Operations Manager 2007 R2 console where the Runbook Server and Runbook designer is.

    I can see that the management pack in SCOM is installed: "Microsoft System Center Orchestrator Integration Library"

    I get one error message in Event log every time i try to use "Create Alert".

    Error Message:

    C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Runbook Server\PolicyModule.exe

    2824

    Microsoft.EnterpriseManagement.OperationsManager, Version=6.0.4900.0, Culture=neutral, PublicKeyToken=32bf3856ad364e35

    System.BadImageFormatException: An Attempt was made to load a program with an incorrect format.(Exception from hresult: 0x8007000B)

    at Bid.internalInitialize()

    Any Ideas what i'm doing wrong?

    Best Regards,

    Stian

    Monday, August 13, 2012 2:42 PM

All replies

  • Hu,

    I have seen that with Opalis when mixing 32bit and 64bit. Do you run the latest version of the Integration Pack for Orchestrator, see http://technet.microsoft.com/en-us/library/hh295851.aspx . Are you running a updated 2007 R2 environment?


    Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se

    Tuesday, August 14, 2012 5:52 AM
    Answerer
  • Hi,

    I'm using version 7.0.1298.0 integration Pack.

    No, I don't think that the OPsMgr is updated for a while.

    Stian

    Tuesday, August 14, 2012 7:30 AM
  • Hi,

    Look at http://thoughtsonopsmgr.blogspot.se/2009/05/opsmgr-versions.html , there is a list of Ops Mgr versions and how you can verify your version. Also make sure you are running X64 version of the console on a X64 server.


    Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se

    Tuesday, August 14, 2012 7:43 AM
    Answerer
  • Could it be differrent versions in DB and the About in the Console?

    The Console is showing version 6.1.7221.0 .

    The installed Console is x64, I tried with x86 but it wouldn't install.

    One thing I see is that in Registry:

    HKLM\Software\Microsoft\Powershell\1\PowershellSnapIns\Microsoft.EnterpriseManagement.OperationsManager.Client

    \AssemblyName: ... Version=6.0.4990.0

    But the Version of the file is 6.1.7221.0

    Best Regards,

    Stian

    Tuesday, August 14, 2012 7:51 AM
  • Hi,

    has this ever been solved?

    In one environment I experience the same ...

    Regards,

    Stefan


    German Orchestrator Portal , My blog in English

    Wednesday, March 6, 2013 4:39 PM
    Answerer
  • Hi,

    has this ever been solved?

    In one environment I experience the same ...

    Regards,

    Stefan


    German Orchestrator Portal , My blog in English

    Wednesday, March 6, 2013 4:40 PM
    Answerer
  • Hi,

    we just updated the SCOM Console on the Runbook Server to (CU6) but the error stays the same:

    Log Name:      Application
    Source:        Bid
    Date:          3/7/2013 10:33:17 AM
    Event ID:      2
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      SCORunbookServer.ms-privatecloud.eu
    Description:
    C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Runbook Server\PolicyModule.exe
    4160

    Microsoft.EnterpriseManagement.OperationsManager, Version=6.0.4900.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

    System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
       at Bid.internalInitialize()

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Bid" />
        <EventID Qualifiers="0">2</EventID>
        <Level>3</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-03-07T09:33:17.000000000Z" />
        <EventRecordID>39950</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SCORunbookServer.ms-privatecloud.eu</Computer>
        <Security />
      </System>
      <EventData>
        <Data>C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Runbook Server\PolicyModule.exe
    4160

    Microsoft.EnterpriseManagement.OperationsManager, Version=6.0.4900.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

    System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
       at Bid.internalInitialize()
    </Data>
      </EventData>
    </Event>

    Regards,

    Stefan


    German Orchestrator Portal , My blog in English

    Thursday, March 7, 2013 10:09 AM
    Answerer
  • Hi,

    on the Runbook Server install the Operations Manager 2012 SP1 console.

    The binaries included wiht Operations Manager 2012 SP1 should be capable to connect to a Operation Manager 2007 R2 Management Group.

    Regards

    Stefan

    Friday, March 8, 2013 10:18 AM
  • Hi Stefan,

    thanks for the suggestion.

    I'm not able to connect to Operation Manager 2007 R2 RMS with Operations Manager 2012 SP1 Console. I'm getting the in SCOM 2012 SP1 Console this  error:

    The Connect from SCOM2007R2 Console to the RMS works at the same time.

    Is there something to change that you can connect with SCOM 2012 SP1 Console to SCOM 2007 R2 RMS?

    In Orchestrator when executing the Runbook I receive a similar error:

    Regards,

    Stefan


    German Orchestrator Portal , My blog in English

    Sunday, March 10, 2013 11:46 AM
    Answerer
  • Hi,

    you are right. Administrating and connecting to a 2007 R2 Management Group with the Operations Manager 2012 SP1 console does not work and is not intended.

    However, connecting from Orchestrator 2012 SP1 to a Operations Manager 2007 R2 Management Group with the binaries from the Operations Manager 2012 Console should work.

    Are you able to connect tor the 2007 R2 Management Group within the Options in the Runbook Designer?

    Thanks

    Stefan

    Monday, March 11, 2013 11:22 AM
  • Hi Stefan,

    no and "Get Alert" will fail.

    Regards,

    Stefan


    German Orchestrator Portal , My blog in English

    Monday, March 11, 2013 12:35 PM
    Answerer
  • Hi Stefan,

    based on your Screen shot it seems that you are using the IP to connect to Operations Manager 2012 and not to Operations Manager 2007 R2.

    Please try the Operation Manager 2007 R2 Connection.

    Thanks

    Stefan

    Tuesday, March 12, 2013 8:33 AM
  • Hello Stefan,

    I uninstalled SCOM2007R2 Console and installed SCOM2012SP1 Console in Orchestrator-Test-Environment now and use the IP for SCOM 2007R2.

    In my test environment working although the Connect with SCOM2012SP1 Console to SCOM2007R2 RMS fails ...

    Connection Test SCOM2007R2 with OM Console 2012


    Thanks a lot Stefan, we will try in the customer environment now ...

    Regards,

    Stefan




    German Orchestrator Portal , My blog in English

    Tuesday, March 12, 2013 9:38 AM
    Answerer
  • Hi Stefan,

    one addition; administrating or managing a 2007 R2 Management Group with the Operations Manager 2012 Console does not work.

    We just do need the 2012 Operations Manager Console binaries to get the Orchestrator Integration Pack to work and to be able to connect to Operations Manager 2007 R2 out of Orchestrator.

    Thanks

    Stefan

    Wednesday, March 13, 2013 11:16 AM