locked
Help with a BSOD error "BUGCODE_USB_DRIVER" Stop 0xFE RRS feed

  • Question

  • I'm having problems with a randomly generated BSOD that happens during normal computer use, randomly throughout the day, and ruins my work, setting me back. It's been happening for over a month now.
    I only use one USB device, a mouse. Sometimes a use a cooling van underneath the laptop that powers through the USB drive but the error happens with or without the fan plugged in. And the mouse for that matter. I don't suspect that that's the culprit but it is an error of USB origin.

    BUGCODE_USB_DRIVER

    ...

    It says: STOP: 0x000000FE (0x0000000000000006, 0xFFFFFA801F3827F0, 0x0000000048766544, 0x0000000000000000)

    ...

    Anyone know how to fix this?

    Wednesday, April 15, 2015 11:49 PM

All replies

  •  
    We do need the actual log files (called a DMP files) as they contain the only record of the sequence of events leading up to the crash, what drivers were loaded, and what was responsible.  


    Please follow our instructions for finding and uploading the files we need to help you fix your computer. They can be found here
    If you have any questions about the procedure please ask


    Wanikiya and Dyami--Team Zigzag

    Thursday, April 16, 2015 12:31 AM
  • To help you little better, this is what i found from Patrick Barker 

    In order to assist you, we will need the .DMP files to analyze what exactly occurred at the time of the crash, etc.

    If you don't know where .DMP files are located, here's how to get to them:

    1. Navigate to the %systemroot%\Minidump folder.

    2. Copy any and all DMP files in the Minidump folder to your Desktop and then zip up these files.

    3. Upload the zip containing the .DMP files to Onedrive or a hosting site of your choice and paste in your reply. Prefered sites: Onedrive, Mediafire, Dropbox, etc. Nothing with wait-timers.

    4 (optional): The type of .DMP files located in the Minidump folder are known as Small Memory Dumps. In %systemroot% there will be what is known as a Kernel-Dump (if your system is set to generate). It is labeled MEMORY.DMP. The difference between Small Memory Dumps and Kernel-Dumps in the simplest definition is a Kernel-Dump contains much more information at the time of the crash, therefore allowing further debugging of your issue. If your upload speed permits it, and you aren't going against any strict bandwidth and/or usage caps, etc, the Kernel-Dump is the best choice. Do note that Kernel-Dumps are much larger in size due to containing much more info, which is why I mentioned upload speed, etc.

    If you are going to use Onedrive but don't know how to upload to it, please visit the following:

    Upload photos and files to Onedrive.

    Please note that any "cleaner" programs such as TuneUp Utilities, CCleaner, etc, by default will delete .DMP files upon use.

    If your computer is not generating .DMP files, please do the following:

    1. Start > type %systemroot% which should show the Windows folder, click on it. Once inside that folder, ensure there is a Minidump folder created. If not, CTRL-SHIFT-N to make a New Folder and name it Minidump.

    2. Windows key + Pause key. This should bring up System. Click Advanced System Settings on the left > Advanced > Performance > Settings > Advanced > Ensure there's a check-mark for 'Automatically manage paging file size for all drives'.

    3. Windows key + Pause key. This should bring up System. Click Advanced System Settings on the left > Advanced > Startup and Recovery > Settings > System Failure > ensure there is a check mark next to 'Write an event to the system log'.

    Ensure Small Memory Dump is selected and ensure the path is %systemroot%\Minidump.

    4. Double check that the WERS is ENABLED:

    Start > Search > type services.msc > Under the name tab, find Windows Error Reporting Service > If the status of the service is not Started then right click it and select Start. Also ensure that under Startup Type it is set to Automatic rather than Manual. You can do this by right clicking it, selecting properties, and under General selecting startup type to 'Automatic', and then click Apply.

    If you cannot get into normal mode to do any of this, please do this via Safe Mode.

    Thursday, April 16, 2015 12:51 AM
  • Here's a temporary link using Dropbox of my DMP file:

    https://dl.dropboxusercontent.com/u/47399476/031515-35786-01.dmp

    Thursday, April 16, 2015 2:48 AM
  • CH


    This was related to WinUSB.sys (an OS USB driver).  Dependent on location this could also be malware so I would run a Malwarebytes scan and a system file check

    Please download the free version of Malwarebytes.
    Update it immediately.
    Do a full system scan
    Let us know the results at the end.

    http://www.malwarebytes.org/products


    Please run a system file check (SFC) & DISM if you are on win 8 or higher

    All instructions are in our Wiki article below...
    Should you have any questions please ask us.



    Microsoft (R) Windows Debugger Version 6.3.9600.17298 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    
    
    Loading Dump File [C:\Users\zigza\Desktop\031515-35786-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available
    
    
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*D:\Symbols*http://msdl.microsoft.com/download/symbols
    Symbol search path is: SRV*D:\Symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is: 
    Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 7601.18741.amd64fre.win7sp1_gdr.150202-1526
    Machine Name:
    Kernel base = 0xfffff800`03202000 PsLoadedModuleList = 0xfffff800`03446890
    Debug session time: Sun Mar 15 21:58:09.938 2015 (UTC - 4:00)
    System Uptime: 0 days 19:28:41.812
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ................................................................
    
    Loading User Symbols
    Loading unloaded module list
    ..................................................
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck FE, {6, fffffa801b05a010, 48766544, 0}
    
    Probably caused by : WinUSB.sys ( WinUSB!WinUSB_PrepareHardware+157 )
    
    Followup: MachineOwner
    ---------
    
    1: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    BUGCODE_USB_DRIVER (fe)
    USB Driver bugcheck, first parameter is USB bugcheck code.
    Arguments:
    Arg1: 0000000000000006, USBBUGCODE_BAD_SIGNATURE An Internal data structure (object)
    	has been corrupted.
    Arg2: fffffa801b05a010, Object address
    Arg3: 0000000048766544, Signature that was expected
    Arg4: 0000000000000000
    
    Debugging Details:
    ------------------
    
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT
    
    BUGCHECK_STR:  0xFE
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    ANALYSIS_VERSION: 6.3.9600.17298 (debuggers(dbg).141024-1500) amd64fre
    
    LAST_CONTROL_TRANSFER:  from fffff8800562d311 to fffff80003276ec0
    
    STACK_TEXT:  
    fffff880`03915f98 fffff880`0562d311 : 00000000`000000fe 00000000`00000006 fffffa80`1b05a010 00000000`48766544 : nt!KeBugCheckEx
    fffff880`03915fa0 fffff880`05628362 : fffffa80`1b05a010 00000000`00000048 fffffa80`0a25d1a0 00000000`00000000 : USBPORT!USBPORT_AssertSig+0x25
    fffff880`03915fe0 fffff880`0560ab8e : fffffa80`1afffcd0 fffffa80`1b05a010 fffffa80`1afffcd0 fffffa80`1afffd18 : USBPORT!USBPORT_NeoReferenceDeviceHandle+0x6e
    fffff880`03916020 fffff880`0560d0d2 : fffffa80`1b05a010 fffffa80`0a728050 00000000`00000001 fffffa80`1b0e5db8 : USBPORT!USBPORT_GetBusContext+0x12a
    fffff880`03916080 fffff880`0560ae71 : fffffa80`0a728050 00000000`00000000 fffffa80`1b0e5db8 fffffa80`0a25d050 : USBPORT!USBPORT_GetBusInterfaceUSBDI+0xee
    fffff880`039160e0 fffff880`05619ff7 : 00000000`00000001 fffffa80`0a728050 fffffa80`0a7281a0 00000000`00000801 : USBPORT!USBPORT_GetBusInterface+0x85
    fffff880`03916120 fffff880`05604911 : fffffa80`0a434e40 fffffa80`1b0e5af0 fffffa80`1b0e5af0 fffffa80`1b0e5af0 : USBPORT!USBPORT_PdoPnP+0x5a7
    fffff880`039161e0 fffff880`00eff7a7 : fffffa80`1b0e5af0 fffff880`0560c0b7 fffffa80`1b0e5db8 fffffa80`1b0e5db8 : USBPORT!USBPORT_DispatchPnP+0x2d
    fffff880`03916210 fffff880`00effa8f : fffff880`00f304b0 fffffa80`0a434e40 fffffa80`07089360 fffffa80`1b0e5af0 : ACPI!ACPIDispatchForwardIrp+0x37
    fffff880`03916240 fffff880`05033887 : fffffa80`1b0e5af0 fffffa80`33666971 fffffa80`1b0e5af0 fffffa80`1b0f2060 : ACPI!ACPIDispatchIrp+0x17b
    fffff880`039162c0 fffff880`05025a1b : fffffa80`1b0e5db8 fffffa80`0a434e40 fffffa80`1ac15570 fffffa80`1b0f2060 : usbhub!UsbhPdoPnp_QueryInterface+0x49f
    fffff880`03916340 fffff880`05001fb7 : fffffa80`1b0e5af0 fffffa80`1afc0010 00000000`00000001 fffffa80`1b0e5af0 : usbhub!UsbhPdoPnp+0x9b
    fffff880`03916370 fffff880`00eff7a7 : fffffa80`1b0e5af0 fffff800`0327e90f 00000000`00000000 fffffa80`1b0e5db8 : usbhub!UsbhGenDispatch+0x57
    fffff880`039163a0 fffff880`00effa8f : fffff880`00f304b0 fffffa80`1ac15570 fffffa80`1afc0010 fffffa80`1b0e5af0 : ACPI!ACPIDispatchForwardIrp+0x37
    fffff880`039163d0 fffff880`00e2b617 : 00000000`00000000 00000000`00000000 fffff880`00ebad20 fffff880`039164c0 : ACPI!ACPIDispatchIrp+0x17b
    fffff880`03916450 fffff880`00e7a4c9 : fffffa80`1b0018e0 fffff880`00000000 00000000`c00000bb fffffa80`1b0018e0 : Wdf01000!FxIoTarget::SubmitSync+0x24b
    fffff880`03916500 fffff880`00e7277b : fffffa80`183065b0 00000000`00000000 00000000`00000000 00000000`00001030 : Wdf01000!FxUsbDevice::InitDevice+0x4f5
    fffff880`039167c0 fffff880`00e7290d : fffffa80`1aff94c0 fffffa80`1aff9770 0000057f`e5006b38 00000000`00001030 : Wdf01000!FxUsbTargetDeviceCreate+0x13b
    fffff880`03916820 fffff880`0ac37b27 : fffffa80`1aff94c0 0000057f`e5006b38 fffffa80`1aff9770 fffff880`0ac3f168 : Wdf01000!imp_WdfUsbTargetDeviceCreate+0x10d
    fffff880`03916880 fffff880`00e4de8b : fffffa80`1b0f7020 00000000`00000000 fffff880`03916940 fffffa80`1b0f7020 : WinUSB!WinUSB_PrepareHardware+0x157
    fffff880`039168b0 fffff880`00e4dce4 : fffff880`039169b0 fffffa80`1b112040 fffff880`039169b0 00000000`00000000 : Wdf01000!FxPkgPnp::PnpPrepareHardware+0x117
    fffff880`03916900 fffff880`00e4cdf5 : 00000000`00000101 00000000`00000108 00000000`00000108 fffffa80`1b0f7020 : Wdf01000!FxPkgPnp::PnpEventHardwareAvailable+0x9c
    fffff880`03916940 fffff880`00e4cac6 : fffff880`03916ad0 fffff880`03565180 fffffa80`1b0f7020 fffffa80`1b0f7020 : Wdf01000!FxPkgPnp::PnpEnterNewState+0x1a1
    fffff880`039169e0 fffff880`00e4d584 : fffffa80`1b0f7148 fffff880`03916af0 fffff880`03916ad0 fffffa80`1b0f7020 : Wdf01000!FxPkgPnp::PnpProcessEventInner+0x122
    fffff880`03916a50 fffff880`00e452c7 : fffffa80`1b0f7130 fffffa80`1b0f7140 fffffa80`1b0f7020 fffffa80`1b0f7130 : Wdf01000!FxPkgPnp::_PnpProcessEventInner+0x60
    fffff880`03916a90 fffff880`00e4d6f6 : fffffa80`0fa9ec00 fffffa80`183065b0 fffffa80`066d5040 00000000`00000000 : Wdf01000!FxEventQueue::EventQueueWorker+0x83
    fffff880`03916b10 fffff800`0356fb43 : fffffa80`0666ee70 00000000`00000001 00000000`00000000 fffffa80`066d5040 : Wdf01000!FxWorkItemEventQueue::_WorkItemCallback+0x22
    fffff880`03916b40 fffff800`03280a95 : fffff800`0337a700 fffff800`0356fb01 fffffa80`066d5000 fffffa80`066d5040 : nt!IopProcessWorkItem+0x23
    fffff880`03916b70 fffff800`03515b8a : 00000000`00000000 fffffa80`066d5040 00000000`00000080 fffffa80`066549e0 : nt!ExpWorkerThread+0x111
    fffff880`03916c00 fffff800`032688e6 : fffff880`035d7180 fffffa80`066d5040 fffff880`035e1fc0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
    fffff880`03916c40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_IP: 
    WinUSB!WinUSB_PrepareHardware+157
    fffff880`0ac37b27 8bd8            mov     ebx,eax
    
    SYMBOL_STACK_INDEX:  13
    
    SYMBOL_NAME:  WinUSB!WinUSB_PrepareHardware+157
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: WinUSB
    
    IMAGE_NAME:  WinUSB.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  4ce7a66c
    
    IMAGE_VERSION:  6.1.7601.17514
    
    FAILURE_BUCKET_ID:  X64_0xFE_BAD_SIGNATURE_WinUSB!WinUSB_PrepareHardware+157
    
    BUCKET_ID:  X64_0xFE_BAD_SIGNATURE_WinUSB!WinUSB_PrepareHardware+157
    
    ANALYSIS_SOURCE:  KM
    
    FAILURE_ID_HASH_STRING:  km:x64_0xfe_bad_signature_winusb!winusb_preparehardware+157
    
    FAILURE_ID_HASH:  {8d37b901-02f2-a627-9d53-7a17f951a674}
    
    Followup: MachineOwner
    ---------
    
    1: kd> lmvm WinUSB
    start             end                 module name
    fffff880`0ac36000 fffff880`0ac47000   WinUSB     (pdb symbols)          d:\symbols\winusb.pdb\64A45FF3D62740D0A3FBC9567D9DFA2B1\winusb.pdb
        Loaded symbol image file: WinUSB.sys
        Mapped memory image file: d:\symbols\WinUSB.sys\4CE7A66C11000\WinUSB.sys
        Image path: \SystemRoot\system32\DRIVERS\WinUSB.sys
        Image name: WinUSB.sys
        Timestamp:        Sat Nov 20 05:43:56 2010 (4CE7A66C)
        CheckSum:         00017662
        ImageSize:        00011000
        File version:     6.1.7601.17514
        Product version:  6.1.7601.17514
        File flags:       0 (Mask 3F)
        File OS:          40004 NT Win32
        File type:        2.0 Dll
        File date:        00000000.00000000
        Translations:     0409.04b0
        CompanyName:      Microsoft Corporation
        ProductName:      Microsoft® Windows® Operating System
        InternalName:     winusb.sys
        OriginalFilename: winusb.sys
        ProductVersion:   6.1.7601.17514
        FileVersion:      6.1.7601.17514 (win7sp1_rtm.101119-1850)
        FileDescription:  Windows USB Class Driver BETA
        LegalCopyright:   © Microsoft Corporation. All rights reserved.
    


    Wanikiya and Dyami--Team Zigzag

    Thursday, April 16, 2015 11:42 AM
  • Here's another temporary Dropbox file that has the Kernal Dump and also a sysdata.xml file following something else I read online:https://dl.dropboxusercontent.com/u/47399476/Dump.zip

    I ran a Malware scan with the software suggested, which I already had on the same computer, without it finding any cause for concern, just 2 suspicious cookies from a website. Nothing more. The issue still occurs.

    I will run the system file check and get back with you.

    Sunday, April 19, 2015 7:35 PM
  • The scan is now running. While that is scanning, here is a link to the Memory.dmp, Kernel-based. Temporary Dropbox link: https://dl.dropboxusercontent.com/u/47399476/Dump.zip

    Sunday, April 19, 2015 7:38 PM
  • I have Windows 7.

    "Windows Resource Protection did not find any integrity violations."

    What else would you recommend?

    Sunday, April 19, 2015 7:47 PM
  • Here's what another program I used output:

    Problem signature:
      Problem Event Name: BlueScreen
      OS Version: 6.1.7601.2.1.0.256.48
      Locale ID: 1033

    Additional information about the problem:
      BCCode: fe
      BCP1: 0000000000000006
      BCP2: FFFFFA801B05A010
      BCP3: 0000000048766544
      BCP4: 0000000000000000
      OS Version: 6_1_7601
      Service Pack: 1_0
      Product: 256_1

    Files that help describe the problem:
      C:\Windows\Minidump\031515-35786-01.dmp
      C:\Users\XXXX\AppData\Local\Temp\WER-176187-0.sysdata.xml

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt

    Sunday, April 19, 2015 9:36 PM
  • Ch

    Stil related to WinUSB.sys.  What devices do you have on USB?


    Wanikiya and Dyami--Team Zigzag

    Sunday, April 19, 2015 11:17 PM
  • All I have is a mouse. That's it. There's no reason why it should behave this way. :-/ I tried uninstalling all of the USB drives and allowing it to reinstall them on a restart. It didn't work. I still get the BSOD.
    Monday, April 27, 2015 4:00 AM
  • So is there nothing you can help me to do to fix it?
    Monday, April 27, 2015 4:00 AM
  • Hi,

    Looking at the "raw stack" of one of the errors shows two Avast drivers, the aswSnx.sys and aswStm.sys that may be involved the crash:

    ffff880`0390d5d8  fffff880`041e729c aswStm+0xb29c
    fffff880`0390d5e0  fffffa80`19731598
    fffff880`0390d5e8  0001c4e3`f769295d
    fffff880`0390d5f0  00000000`00000000
    fffff880`0390d5f8  fffffa80`06dc3300
    fffff880`0390d600  fffff880`0390d690
    fffff880`0390d608  fffff880`045ad408 tunnel!TeredoWfpDereferenceFlowContextImp+0x2ac
    fffff880`0390d610  fffff880`0390d680
    fffff880`0390d618  fffff880`0390dec0
    fffff880`0390d620  00000000`00000000
    fffff880`0390d628  fffff880`078affdc*** ERROR: Module load completed but symbols could not be loaded for Netwsw00.sys
     Netwsw00+0x29fdc
    fffff880`0390d630  00000002`00000034
    fffff880`0390d638  fffff880`078affdc Netwsw00+0x29fdc
    fffff880`0390d640  fffffa80`0d327700
    fffff880`0390d648  fffff880`04aacd61 aswSnx+0x4fd61

    As Avast appears to have been recently updated consider uninstalling, at least temporarily, Avast and see if the errors resolve.

    Consider alternative security software such as Microsoft Security Essentials.

    Also, update the Intel wireless driver (Netwsw00.sys) if possible.

    Tuesday, April 28, 2015 12:06 AM
  • Hello Charnon300,

    Any updates?

    Is this issue resolved?

    Best regards,

    Fangzhou CHEN


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 29, 2015 6:55 AM