locked
SCONFIG "The IP address could not be changed" RRS feed

  • Question

  • We just enabled on a second NIC and it's working on DHCP.  We are trying to change it to static and it fails every time with just a generic message of "The IP address could not be changed"
    I cannot find any more descriptive error anywhere.
    Are there some special requirements for setting the IP address on the second NIC?
    Tuesday, August 25, 2009 10:40 PM

Answers

  • netsh int ip set add "Local area connection" 10.54.1.220 255.255.255.128 10.54.1.254
    netsh int ip set add "Local area connection 2" 10.54.1.221 255.255.255.128

    It became a typo in the syntax as I missed to include the keyword static when retyping instead of copy/paste.

    netsh int ip set add "Local area connection" static 10.54.1.220 255.255.255.128 10.54.1.254
    netsh int ip set add "Local area connection 2" static 10.54.1.221 255.255.255.128
    We left it blank (empty). With that method, it fails everytime and gives an autoconfiguration 169.x address.
    I remember I got an APIPA 169.254.x.y once when using sconfig, but just repeated the config step gave the correct value.
    Friday, August 28, 2009 8:48 PM

All replies

  • Hi,

     

    I can reproduced your issue.

     

    Please see the following screen shot. After you input the IP address, you have to input the Subnet Mask. The system will give you an option to use the default subnet just use "blank" instead of inputting your own Subnet Mask. In my first time, I click “blank space” key to input a “Blank” and then press Enter without any errors. After I input the Default Gateway, an error occurred said that “The IP address could not be changed”. I suspect you did the same process as me. So, if you want to use the default subnet mask, please don’t input any “Blank”, just press Enter key to continue, Blank = input nothing here, now you will be able to set the static IP address.

    08

     

     

    Best Regards,

    Vincent Hu

     

    Wednesday, August 26, 2009 6:31 AM
  • We do not use the default subnet mask, so we can't leave it blank.  We must enter the subnet mask 255.255.255.128 manually since the default is not correct for our network.
    We can do a workaround of setting the IP address we want with a DHCP reservation and that works, but static is supposed to work.  We need to set it as static IP.
    The static settings worked fine on the first NIC, so I don't know why it won't work for the second card.  We are following the same steps to configure the second NIC than using a different IP address for the second NIC.
    Wednesday, August 26, 2009 2:03 PM
  • Are you trying to set a default gateway on the second NIC, that is the same as the default gateway of the first NIC?
    Wednesday, August 26, 2009 6:30 PM
  • Yes, and that's how it gets set when we use DHCP and it works.  There are on the same network, so they have the same default gateway.
    Wednesday, August 26, 2009 10:41 PM
  • On a Full installation when you try this, it would also error out and the Default Gateway would not be set on the second NIC.
    If you want to avoid the error, set a default gateway only once per network. (the second NIC would not need a Default Gateway)
    Thursday, August 27, 2009 6:57 AM
  • This is still not the solution.  Even when leaving the default gateway blank on the second nic, it still fails.  It will only work through DHCP.

    Now neither connection will accept a static. We were only able to set a static IP when there was only one NIC connected.
    We are now stuck with DHCP on both NICs.
    Thursday, August 27, 2009 4:47 PM
  • What happens if you use netsh like below instead of sconfig?

    netsh int ip set add "local area connection" static 10.0.0.1 255.255.255.0 10.0.0.254

    Thursday, August 27, 2009 8:29 PM
  • I was eventually able to set it with netsh.  There is a problem SCONFIG.
    There was even a problem with netsh because it would only work if gateway was added to both network connections and people say it should be the oposite.
    It is now set with two static IPs, but both have the gateway configured.  The addresses are on the same subnet.
    Thursday, August 27, 2009 10:50 PM
  • Hi,

    Yes, I am able to set it with netsh too. However, you can configure the same Default Gateway on the second NIC doesn't mean that it will works properly. As Sander mentioned, if you did this with GUI tool on a full installation computer, you will receive a warning .

    Best Regards,

    Vincent Hu

     

    What other choice is there? 
    Netsh failed to set the IP address with the gateway blank.  There was no other option available.  The only way to complete the configuration was to set the gateway on both adapters.

    Friday, August 28, 2009 1:53 PM
  • I just added an additional NIC to a VM running 2008R2core and it works as expected to set a static IP with /25 on both NICs and leave GW blank on one of them.

    netsh int ip set add "Local area connection" 10.54.1.220 255.255.255.128 10.54.1.254
    netsh int ip set add "Local area connection 2" 10.54.1.221 255.255.255.128

    The same shall work with sconfig, just press enter when asked for GW on the second NIC. As Vincent said, do not input the word blank.

    Friday, August 28, 2009 4:23 PM
  • We did not input the word blank.  We left it blank (empty).  With that method, it fails everytime and gives an autoconfiguration 169.x address.
    The only way it works for our server is to use netsh and input the gateway address on both network connections.
    DHCP wqorks, but it continues to have problems with static IPs.
    Maybe there is a hardware incompatibility problem Server 2008 R2 with the Broadcom nics we use, but it just will not work with the steps suggested.
    Friday, August 28, 2009 5:43 PM
  • netsh int ip set add "Local area connection" 10.54.1.220 255.255.255.128 10.54.1.254
    netsh int ip set add "Local area connection 2" 10.54.1.221 255.255.255.128

    It became a typo in the syntax as I missed to include the keyword static when retyping instead of copy/paste.

    netsh int ip set add "Local area connection" static 10.54.1.220 255.255.255.128 10.54.1.254
    netsh int ip set add "Local area connection 2" static 10.54.1.221 255.255.255.128
    We left it blank (empty). With that method, it fails everytime and gives an autoconfiguration 169.x address.
    I remember I got an APIPA 169.254.x.y once when using sconfig, but just repeated the config step gave the correct value.
    Friday, August 28, 2009 8:48 PM
  • The manual command above works.  SCONFIG still doen't work to do the same thing. 
    There seems to be major issues and bugs with SCONFIG. 
    Friday, September 4, 2009 8:16 PM