locked
Cant get my custom msiexec to install and my setup.exe just disappears! RRS feed

  • Question

  • So grateful for any help here, I am rather new at this type of deployment and I'm having a real issue pushing a custom Acrobat Setup.exe. First the custom executable installs with all the options that I selected locally on any PC as long as I kick it off on the local machine. My issue is this: First I copy the install file with the MSI and MST and all the files needed to the users local c:, I then use psexec to execute the setup.exe remotely from CMD. I have connected remotely and viewed the task manager on the remote PC while I am calling setup.exe from my machine. Some times it will install just as it was designed to, which it amazing but mostly I see the Setup32.exe come in, it calls the msiexec on several processes and then it just disappears. The windows logs show a 1935 error which in my experience is due to something else already installing in the background (updates, security patches from the network team, etc) and the install fails. I tried using the taskkill /IM misexec.exe and then call setup.exe but it does not change anything. To avoid this I tried going another direction and calling on the msi via CMD pointing to the mst. Again, using psexec i can kick it off and watch the msiexec start up and then it just sits and sits for hours, never changes the memory. So how can I either make my misexec have a higher priority, or can anyone be so kind as to provide the syntax they would use to push a msiexec for acrobat XI silently?
    Saturday, July 19, 2014 12:46 PM

Answers

All replies

  • This is not a scripting issue.  It is an issue for Adobe.

    Please contact Adobe for the instructions and tools needed to install Adobe remotely. Adbe has a distribution program and supplies a custom MSI and toolkit for remote installation of Adobe products.

    Again.  PsExec and Adobe are not scripts and this is not a scripting  issue.


    ¯\_(ツ)_/¯

    Saturday, July 19, 2014 1:07 PM
  • This isn't an Adobe deployment support forum or a psexec support forum.

    I searched for "adobe deployment forum" and found this:

    https://forums.adobe.com/community/acrobat/acrobat_enterprise_install

    I would start there before trying to use psexec.


    -- Bill Stewart [Bill_Stewart]

    • Proposed as answer by Bill_Stewart Thursday, July 24, 2014 4:04 PM
    • Marked as answer by IamMred Friday, August 1, 2014 8:06 PM
    Saturday, July 19, 2014 1:10 PM