none
Windows 2008 R2 SNMP Version issue RRS feed

  • Question

  • We are deploying our first Windows 2008 R2 servers and we are running into a problem with SNMP monitoring on these servers. For some reason, when our monitoring tool (Ipswitch What's Up Gold) sends an SNMP request in SNMP version 2, the Windows 2008 R2 servers respond with an SNMP version 1 packet. We have captured the packets in Wireshark and confirmed that this is the issue. If we send version 1 requests, everything works fine. However, we've been using SNMP version 2 exclusively on all of our Windows 2003 and Windows 2008 R1 servers with no problems. Ipswitch has told us that they use SNMP version 2 on their Windows 2008 R2 servers in their lab with no problems (Their lab servers respond with v2 packets). We've tried uninstalling the SNMP feature and reinstalling it, but that has not changed the behavior.

    Can anyone tell me if there is a way to configure Windows 2008 R2 to use a specific SNMP version or why it would respond with a different version that the request it receives? Any help you can offer would be appreciated. Thanks everyone!

    (Both of our new R2 servers are running SP1.)

    Monday, July 18, 2011 5:54 PM

All replies

  • Today I tried using the Paessler SNMP Tester just to confirm that the issue is with Windows 2008 and not with our monitoring tool. The results are the same. Paessler allows me to switch SNMP versions easily. SNMPv1 works just fine. When I use SNMPv2 it fails. By using Wireshark I was able to confirm that the Windows 2008 server responds with an SNMPv1 packet when it receives an SNMPv2 request.

    Thanks again!

    Tuesday, July 19, 2011 2:35 PM
  • Please try updating the SNMP component using the below hotfix and see if it helps.

    2555958 SNMP services returns no attributes for a PID when you monitor services by using SNMP services on a computer that is running Windows 7 or Windows Server 2008 R2

     


    Sumesh P - Microsoft Online Community Support
    Wednesday, July 20, 2011 4:52 PM
    Moderator
  • Strange, the KB article indicates that the hotfix is for Windows 2008 R2 with SP1, but when I run the hotfix on the server, I get the message, "This update is not applicable to your computer."

    Any ideas?

    Wednesday, July 20, 2011 9:04 PM
  • Not sure, unless you have a later version of snmp.exe or the OS or SP level is incorrect, the error should not be thrown.

     


    Sumesh P - Microsoft Online Community Support
    Monday, July 25, 2011 5:38 PM
    Moderator
  • Were you able to check the snmp version/sp level and get the hotfix installed?
    Sumesh P - Microsoft Online Community Support
    Wednesday, August 3, 2011 10:43 AM
    Moderator