Virtual Machine Generation 2 Boot Issue!!! (Windows Repair Bootloop! ) Hyper-V 2012 R2 RRS feed

  • Question

  • Hello people, I'm having the following with the GEN 2 in Hyper-V 2012 R2.

    Issue: After bouncing my GEN2  Hyper-V VM I get this.

    Then I get the Windows Repair and nothing happens after this point!  

    Does someone have experience this issue ?

    The bad thing with it is as it's production there's no checkpoints and I cannot recover it!

    Note: this doesn't happens with GEN1 VM's.

    Any help will be really appreciated

    • Edited by David Acvd Monday, May 12, 2014 7:26 PM Images Updated
    Monday, May 12, 2014 7:23 PM

All replies

  • Unfortunately the images you have posted do not appear. Can you describe the error or include some of the error text?



    Monday, May 12, 2014 7:25 PM
  • There you go

    The bad thing is that there's no error message and the VM doesn't Boot

    Monday, May 12, 2014 7:27 PM
  • Hi, thanks for the quick response. Now the images are appearing... oh well...

    Quite familiar to me this one.  I have a couple of, or more, remedies;

    1: increase the available memory to at least 4096 - just whilst installing you can alter it later.

    2: make sure the enhanced session switches (both in Server and User) in the hyper-v manager are not enabled - you can re-enable them later

    3: Disable "Enable Secure Boot" in the VM settings - Firmware - you can enable it after the install

    4:  make sure Heartbeat is enabled in the VM's settings - Integration Services

    5: Last, but not least, make sure the Smart Paging File Location is the same as the VM's location. Eg: VM: <D:\VMS\Machines> Smart Paging Location: <D:\VMS\Machines>

    One or more of these has "always" worked for me in the past.  I don't offer any warranty with these "solutions", but by disabling or enabling the various options I have nearly always been able to get the VM started. 

    Is the ISO you are utilizing good?  One client of mine assured me he had never touched the ISO saved in that 'special place'.  A quick peer at the files inside the ISO revealed that he had been at the files and changed a minor file and then changed it back to what he thought it had said...



    Monday, May 12, 2014 7:45 PM
  • Still having the Boot loop, I disabled the Secure Boot and everything else was as you listed and it didn't work.

    The  VM was a SQL Server and it was working properly last week, after it was rebooted over the weekend I get this issue.

    Also I re-created and duplicated the VM to see if it boot with a new build but it didn't work.

    I'm thinking it could be something with the ( bootmgfw.efi), now in the GEN 2 that is on the Firmware as the first boot option as a file.


    Any ideas?

    Monday, May 12, 2014 8:05 PM
  • Apologies for not getting back to you sooner.  The cops came about an car accident I witnessed weeks ago and all of a sudden it's "urgent"?

    I have replicated the problem and think you are on the right lines with your analysis.  Here's an blog post by John Howard about changing an ISO from Gen1 to Gen2:


    I'll have a look at other options over the next couple of hours and see what I can come up with; if I find anything I'll let you know. 

    Sorry couldn't have been more help here



    Monday, May 12, 2014 10:45 PM
  • Right, I think I've got a truly terrible, old rusty blunderbuss solution.

    First install Windows Server 2012  or 2012 R2 without a vNIC - no network at all.  Disable "Enable Secure Boot" in the VM Settings.  Configure memory as dynamic, minimum should no lower than 1024, higher - the more the better.  Startup should be almost maximum available.  You can change these when all this is done.  Do not join it ot a domain - well, you can't because there isn't a network attached.

    Stop the VM, install and external vNIC.  Start up and ensure the server is fully up to date.  install the .NET framework, (3.5 and 4.5), and open up ports 1443 and 2383, at the very least as inbound only, using the TCP protocols. 

    Now, ensure network discovery is enabled and copy the SQL Server ISO to the VM's hard drive (VHDX or VHD).  From here you can mount the ISO and set about installing SQL Server.

    Once everything is installed and running properly you can put everything back to the way it should be and pretend that this never happened...

    Apologies, I actually feel 'embarrassed' about this kludge, but this one got me irritated because it really shouldn't be.  If anyone out there in InterwebLand knows of a better solution - surely there is one[?], please do shout it out!



    Tuesday, May 13, 2014 12:03 AM
  • Was the VM installed as a Generation 2 VM?  Or was it an existing VHD that is being deployed as Generation 2?

    The OS in the VM is acting as if the bootloader has changed and sometimes this points to how the VM was created in the first place.

    What else can you tell us about this particular VM.

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, May 13, 2014 3:07 PM
  • It was a functional Generation 2 VM, it also was working last week but after the reboot over the weekend now it doesn't start and it still on the Recovery Boot loop!.

    I'm not trying to deploy a new VM or any ISO changes or migrate from GEN 1 to GEN 2.

    What I'm trying to do is make this GEN 2 VM server work as it was last week. Now, it seems as is a new technology Microsoft has internal issues with the new Generation 2. The bad part of the problem it's that there's not error message and trying to troubleshoot with cmd doesn't even show if there's any issue with the OS.

    The VM Configuration didn't change it could probably be something with the BOOTFILE *.efi 

    I opened a MS case because now I have two GEN2 critical systems with the very same issue.

    Thanks Andrew and Brian

    Tuesday, May 13, 2014 3:22 PM
  • Hi David,

    Did you try to press F8 after you start your VM to see the boot options ?

    If you can see the boot options , try to choose "start windows normally " .

    Best Regards

    Elton Ji

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Monday, May 19, 2014 7:59 AM
  • Yes, it doesn't give you that option and when you try to repair with CMD you just get stock on the boot loop as shows on the Image above. I have been waiting for Microsoft one week + now and there's no responses yet. They didn't have idea of what was happening and they will escalate with the developers.

    Now I have 3 GEN 2 VM's with the same issue.

    I did ton of research and it seems to be a patch that affect the Generation 2 VM's with the "BootFile.efi"

    Here's what I found


    Monday, May 19, 2014 3:11 PM
  • I have been getting the same error. I disabled the repair "bcdedit /set {default} recoveryenabled No".

    There seems to be a lot of server 2012 loop repair problems searching through google but no fix.

    Monday, May 19, 2014 4:44 PM
  • Same here now I Have 4 systems with the same issue, Microsoft Engineers are working on it but don't have idea of what could it be.

    Tuesday, May 20, 2014 3:20 PM
  • Has anyone looked at this: http://support.microsoft.com/kb/2962824

    I have also heard KB2920189 mentioned: http://support.microsoft.com/kb/2920189

    I just heard this:

    There is another way to fix the problem:

    1. Stop the virtual machine

    2. Disable the Secure Boot option in the VM Settings

    3. Start the VM and install the patch

    4. Stop the VM and Enable the Secure Boot option

    5. Start again the VM

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, May 20, 2014 3:39 PM
  • Hi *,

    Well, this is an old thread, however, unfortunately with no solution. I have the same Problem. I rebooted my Server and it got into that repair Loop. The #3 in the post above does not work, because the machine does not boot, thats the Initial Problem.

    So is there any way to boot a gen.2 vm normally? Anything like fixmbr/fixboot we had before?


    Wednesday, February 24, 2016 9:05 AM
  • Hello everyone, 

    This thread is pretty old. Anyway, I would bump in here. Had anyone found a resolution? I have tried multiple ways. 

    1. Tried to disable Secure Boot. 

    2. Tried fixboot and fixmbr. 

    3. Tried to map VHDX to a new VM and started it. Still the same. 

    We had to restore VM from a backup. Maybe someone has a resolution. 


    Tuesday, November 1, 2016 4:39 PM
  • Choose Troubleshoot>Advanced Options>StartUp Settings>Restart.

    The server will restart and choose Disable early launch Anti-Malware Driver from the Repair menu.  This worked for me.

    • Edited by FrancoCruz Thursday, February 23, 2017 6:34 AM
    Thursday, February 23, 2017 6:31 AM
  • I don't think this is exactly the same issue, but your post was the first I found when researching a similar issue. I thought I would post it here in case it helps saves them the many hours I just burned. 

    If you migrate a VM to a 2019 Hyper-V host and then upgrade the Configuration Version (to 9.0), it will go into the same reboot loop--but only after booting successfully once. This does suggest a GPO issue, even though the applicable GPOs have not changed. (Unfortunately, even though I did test GPOs first, some timing issues led me initially to conclude GPOs weren't the culprit... ugh.) Another helpful bit of info is Event ID 18560 ("<VM>" was reset because an unrecoverable error occurred on a virtual processor that caused a triple fault.)

    Ultimately in our case, we found the culprit to be the Secure Launch Configuration in the Microsoft Security Baseline Credential Guard GPO (under Computer Configuration > Policies > Administrative Templates > System > Device Guard: Turn On Virtualization Based Security). If your problem is the same as ours, change this to Disabled, boot your VM to apply the GPO, then shut it down, re-enable Secure Boot, and it should be good to go. 

    This article implies Coffeelake, Whiskeylake, or later silicon is necessary. This article also may be useful info.

    Hope this helps someone else!


    Tuesday, August 4, 2020 11:36 PM