none
RD Connection Broker Fails to install on Windows 2012 R2, fresh install RRS feed

  • Question

  • I have been fighting this for a week

    Trying to install RD connection broker service on a Server 2012 R2.  I've had multiple errors, ranging from the "Server pending reboot" issue, to the install just hanging for 15-20 minutes and then failing.  This is NOT on a DC, and I've tried it on a fresh 2012 R2 server, and a fully updated Server 2012 R2.  It has to be something on the domain I'm joined too, as I can install it with no problem on test servers/domains at my office.

    Monday, March 23, 2015 6:56 PM

All replies

  • Hi CitadelTCS,

    Some folk meet this issue because the server is DC, in your case could you try to run SFC /SCANNOW then monitor this issue again.

    The related KB:

    Use the System File Checker tool to repair missing or corrupted system files

    https://support.microsoft.com/en-us/kb/929833?wa=wsignin1.0

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Thursday, March 26, 2015 3:12 AM
    Moderator
  • I know this thread is a bit old but I found the answer in case others encounter the same problem.

    CitadelTCS you are correct that is likely due to your domain. It was probably a 2003 or an SBS domain originally.

    Here is the answer:

    https://www.smallbusinesstech.net/more-complicated-instructions/windows/fixing-windows-internal-database-installation-error-on-windows-server-2012

    The installation is failing due to the Windows Internal Database is not able to start. The RD Connection Broker relies on that service.

    From the referenced article:

    "This is caused because there are several accounts that need access to Log on as a service that in previous versions of Windows either did not exist or did not require this access.  Once again, you would think that dcpromo would update these settings automatically.  But sadly, it does not, instead leaving it to us lowly IT peons to perform the task manually.

    To edit this setting, open Group Policy Management and edit the Default Domain Policy.  Navigate to Computer Configuration, Policies, Windows Settings, Security Settings, Local Policies, User Rights Assignments.  Edit Log on as a service and add the following groups:

    IIS_WPG
    NETWORK
    NETWORK SERVICE
    SERVICE

    You may also need to add these groups to the Default Domain Controller Policy.

    Run gpupdate /force on the server in question and then reboot.  The installation should now succeed"

    Wednesday, June 22, 2016 8:56 PM