locked
Sharepoint 2010 Workflow Timer Job Definition? RRS feed

  • Question

  • hi there

    We are having issues with "Workflow" Timer Job running all the time. As per Microsoft article this timer job: Processes workflow events that are in the scheduled items table, such as delays. 

    Timer Job has been disabled temporarily and everything is back to normal. Can anyone let me know what this timer job will actually do and also how to fix it from running all the time, My dev evnr has same version of SP and this does not happen on it. 

    We have project server installed but no service Application created for it and the Project service application service is stopped. Anything else that can cause this issue?

    Logs do not say anything being wrong.? please help!!!

    Tuesday, May 15, 2012 2:19 AM

All replies

  • I have seen SharePoint Designer workflows appear to continuously retry email notifications and reminders.  If you are using such actions in your workflow, including the approval action which has them built in, and you do not have your outgoing email set up, you may experience a high load on your server.  If this is the case, either cancel all such workflows or enable outgoing email.

    AndyGett Blog | @AndyGett Twitter

    Tuesday, May 15, 2012 3:18 AM
  • hi there 

    The workflows are all sequencial and no email is sent using workflow actions. The same applies to Dev evnrment where everything is normal as we speak.

    Out going emails are set up and without it no emails will be sent to anyone right? well emails are working fine and users have no complaint that they did not

    get an email. Any ideas?

    Tuesday, May 15, 2012 4:51 AM
  • Hi Sullair,

    This may be related with the number of current running workflows, when a workflow starts, the number of currently active workflows is checked, if it exceeds the throttle number, the workflow is not started and instead, a timer job is created to try running the workflow later.

    You can check the current throttle setting by running the following command:

    stsadm -o getproperty -pn workflow-eventdelivery-throttle

    You can change the throttle setting by running the following command, in which you can replace 25 with the new value:

    stsadm -o setproperty -pn workflow-eventdelivery-throttle -pv "25"

    more information:
    http://msdn.microsoft.com/en-us/library/ie/dd441390(v=office.12).aspx

    Thanks,
    Qiao


    Qiao Wei

    TechNet Community Support

    Thursday, May 17, 2012 3:26 AM
  • hi Wei   I dont think the workflow engine is overloaded, we are a small company with 100 employees. there is no way we would have 15 or more workflows starting per second. Do you think this bug was ever raised due to SP bug? I am running 14.0.6106.5009 update at the moment. i will be copying my live evrn to DEV to shed some light.  please help!
    Friday, May 18, 2012 5:32 AM
  • Hi Sullair,

    As your development version is the same as production, and workflow timer job works well in development, it would not be a version issue.

    Have you tried the command in my previous post, and it doesn’t work? It doesn’t mean you start 15 more workflows at the same time, when you have that number of workflows running, it may cause this issue happen.

    If it isn’t the issue, please feel free to let me know.

    Thanks,
    Qiao


    Qiao Wei

    TechNet Community Support

    Monday, May 21, 2012 1:45 AM
  • Hi Wei

    Yes I did modify the throttle to 25, 50 and even 75 and nothing changed for 30 minutes. so i put it back to 15. Seems to have not done the job. The most used website workflows only have WorkfowInvoked method and no delay or any activities. Do you know how we can explore database to see which workflows are runnings and where the delayed workflow activities are stored?

    Thanks

    Monday, May 21, 2012 1:54 AM
  • You might check the workflow logic and make sure you workflows have a clear ending path.  We've seen cases where clients would have a large number of running workflows.  The companies were small but the logic was flawed thus preventing the workflows from completing.

    Dennis Bottjer | Follow Me: @dbottjer | Blog: Dennis Bottjer.com

    Thursday, July 18, 2013 7:22 PM