DW Extract jobs failing RRS feed

  • Question

  • I have just install SCSM 2010 and the DW management servers on seperate VM's.  The Databases are stored on our SAN and accessed via mount points and multiple instances of SQL server 2008R2.

    I have successfully registered the DW with the SM server, and the MPSyncJob is seemingly stuck in a Running state and both the Extract and the Extract_DW jobs have failed. In the DW server error logs i have numerous error messages saying:

    An error countered while attempting to execute ETL Module:
     ETL process type: Extract
     Batch ID: 856
     Module name: Extract_Microsoft.SystemCenter.ResourceAccessLayer.SrsResourceStore_DW_<management group>
     Message: Object reference not set to an instance of an object.

     Stack:    at Microsoft.SystemCenter.Etl.ETLModule.GetExtractInstanceWrapper(WorkItem etlWI)
       at Microsoft.SystemCenter.Etl.ETLModule.GetModule(WorkItem etlWI)
       at Microsoft.SystemCenter.Etl.ETLModule.OnDataItem(DataItemBase dataItem, DataItemAcknowledgementCallback acknowledgedCallback, Object acknowledgedState, DataItemProcessingCompleteCallback completionCallback, Object completionState)

    the message is repeated with different module names - I assume this is because there are a number of MP's still classed as Pending Association.

    Everything else appears to be working as expected just these 2 failed jobs.

    Any ideas?


    Monday, March 5, 2012 3:53 PM


All replies

  • Maybe this troubleshooting guide is helpful:

    Troubleshooting the Data Warehouse: An overview

    Andreas Baumgarten | H&D International Group

    • Marked as answer by darryl681 Tuesday, March 6, 2012 9:14 AM
    Monday, March 5, 2012 7:28 PM
  • You can also try the following on the DW server.

    Restart the Health Service

    And then you can try to restart the following jobs



    and then each of the extract jobs

    As long as you learn something new every day, the day is not wasted.

    Tuesday, March 6, 2012 6:19 AM
  • I'd seen that guide before and thought i run through it before posting, but tried it again and it's now working.

    Thank you


    Tuesday, March 6, 2012 9:16 AM