locked
server 2012 r2 live migration fails with hardware error RRS feed

  • Question

  • Hello all, we just upgraded one of our hyper v hosts from server 2012 to server 2012 r2; previously we had live replication setup between it and another box on the network which was also running server 2012. After installing server 2012 r2 when a live migration is attempted we get the message:

    "The virtual machine cannot be moved to the destination computer. The hardware on the destination computer is not compatible with the hardware requirements of this virtual machine. Virtual machine migration failed at migration source."

    The servers in question are both dell, currently we have a poweredge r910 running server 2012 and a poweredge r900 running server 2012 r2. The section under processor for "migrate to a physical computer using a different processor" is already checked and this same vm was successfully being live replicated before the upgrade to server 2012 r2. What would have changed around hardware requirements?


    EDIT: I should say that we are migrating from server 2012 on the poweredge r910 to server 2012 r2 on the poweredge r900. Also When I say this was an upgrade, we did a full reinstall and wiped out the installation of server 2012 and installed server 2012 r2, this was not an upgrade installation.
    • Edited by Theantioch Tuesday, October 22, 2013 5:57 PM
    Tuesday, October 22, 2013 5:42 PM

All replies

  • I'm getting the same message, when attempting to move a guest from a server 2012 host to a 2012 R2 Host.

    Both servers are HP BL460 G1 servers.  Shutting down the guest, and attempting to move results in same error.

    Exporting the Guest and then importing on the 2012 R2 server works without an error.

    Tuesday, October 22, 2013 5:51 PM
  • Were you doing live migration successfully before? Its the same issue either way but I ask for interests sake.
    Tuesday, October 22, 2013 5:55 PM
  • Live migrations (shared nothing) were working successfully with 2012 to 2012. (I thought.)
    If I shutdown the guest in question, and check the box under Processor>Compatibility>Migrate to a phycical computer with a different processor version.  And then start up the guest, the live move will work at this point.

    I attemped the move from powershell and it gave more information as to what was happening.

    The host servers have different CPUs - one has E5430 Xeons @ 2.66 and the other is e5530 Xeons @ 2.40.

    The 5430 CPU doesn't include TurboBoost, Hyperthreading, or VT-x with Extended page tables:

    http://ark.intel.com/products/33081/

    • Edited by KJohnsonCDA Tuesday, October 22, 2013 7:39 PM
    Tuesday, October 22, 2013 5:57 PM
  • For the vm in question I already have that box checked and its not working.
    Tuesday, October 22, 2013 10:00 PM