locked
Portal - Date Format RRS feed

  • Question

  • Is there an easy way to change the date format in the Portal to DD/MM/YYYY instead of MM/DD/YYYY? The regional settings on the servers and the SharePoint site are set to DD/MM/YYYY.

    Tuesday, May 1, 2012 11:32 AM

Answers

  • Hi Steve

    Ignore my previous response - you can change this.

    Go to Site Actions, Site Settings, Regional Settings and change the locale for the site.

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    • Marked as answer by Steve-Green Thursday, May 10, 2012 1:50 PM
    Tuesday, May 1, 2012 12:03 PM
  • I never did find out what was causing the problem. But since moving the SCSM Portal from our lab servers to our production servers the issue seems to be resolved.

    Just changed the regional settings in SharePoint and it worked first time. Bit of a strange one but at least it's working

    • Marked as answer by Steve-Green Thursday, May 10, 2012 1:50 PM
    Thursday, May 10, 2012 1:49 PM

All replies

  • Edit!

    Go to Site Actions, Site Settings, Regional Settings and change the locale for the site.

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/


    • Edited by Graham Davies Tuesday, May 1, 2012 11:57 AM change response
    Tuesday, May 1, 2012 11:52 AM
  • Hi Steve

    Ignore my previous response - you can change this.

    Go to Site Actions, Site Settings, Regional Settings and change the locale for the site.

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    • Marked as answer by Steve-Green Thursday, May 10, 2012 1:50 PM
    Tuesday, May 1, 2012 12:03 PM
  • Thanks for your reply Graham. I have already done this and changed the Locale to English (United Kingdom). The dates within SharePoint itself have the correct format of DD/MM/YYYY but the Silverlight web part itself does not. See screenshot below:

    Tuesday, May 1, 2012 12:19 PM
  • When I changed the setting the date format changed immediately (without any need for restarting IIS \ SharePoint) so it suggests that your environment has another setting set to US locale.

    If you go to Control Panel, Clock, Language and Region, and Change Location. Double check:

    - the format is set to English (United Kingdom) dd/MM/yyyy

    - the location is set to UNited Kingdom

    - Administration tab - check here that the locales are set to United Kingdom (changing this will probably require a reboot)

    Hope it helps

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Tuesday, May 1, 2012 1:08 PM
  • I have checked on the servers and they all use the UK settings for date format, location and the locale. Not sure what else could be causing it.

    I currently have the service manager content app on one server and the sharepoint site on another. Both have the correct regional settings.

    Tuesday, May 1, 2012 2:30 PM
  • I never did find out what was causing the problem. But since moving the SCSM Portal from our lab servers to our production servers the issue seems to be resolved.

    Just changed the regional settings in SharePoint and it worked first time. Bit of a strange one but at least it's working

    • Marked as answer by Steve-Green Thursday, May 10, 2012 1:50 PM
    Thursday, May 10, 2012 1:49 PM
  • I had a similar issue a while back, noticed on 2nd client machine the date format was fine... ended up clearing my IE cache and temporary files and that fixed the issue for me.  Simple/basic things like this a rather frustrating! :)

    Thursday, May 24, 2012 7:52 AM