none
How to avoid duplicate incoming mails

    Question

  • Hello,

    I am having a very common issue:

    Some users in Exchange are receiving duplicated mails because they belong to a distribution group. When a user sends an email to this distribution group in the FROM field and to their email address in the CC field, the destination users receive the mail twice.

    Is it possible to create an Exchange rule to avoid emails to duplicate in destination mailbox?

    Thank you

    Tuesday, May 10, 2016 8:46 AM

Answers

  • Hi!

    Sorry for the delay! I have found out the problem. Before taking any action, I have done two easy tests:

    1- Create a test mailbox in Exchange 2010 database. Add this mailbox in a test distribution group. When I send a mail to the mailbox and to the group at the same time, the mail only arrives one time.

    2- Create a test mailbox in Exchange 2013 database. Add this mailbox in test distribution group. When I send a maol to the mailbox and to the group at the same time, the mail only arrives one time.

    Then, I analyze the sender of the problematic duplicate mail. It is an script made by third party company. That was the problem! We don't know exactly why, but the only duplicated incoming mails are coming from that script.

    Thank you so much for your help!

    • Marked as answer by Albert Beired Thursday, May 19, 2016 7:49 AM
    Thursday, May 19, 2016 7:48 AM

All replies

  • Adding more information to my scenario:

    We are migrating Exchange 2010 to Exchange 2013. Now all mailboxes still are in Exchange 2010 but all incoming mails are going through Exchange 2013 to Exchange 2010 successfully.

    Thank you

    Tuesday, May 10, 2016 2:47 PM
  • Follow the below link

    Get-ReceiveConnector -Identity  “Relay-Connector-Name” | Set-ReceiveConnector -MaxAcknowledgementDelay 00:00:00

    http://msexchangeguru.com/2013/04/22/transport/

    Tuesday, May 10, 2016 7:40 PM
  •  

    Hi Albert, 

    Welcome to our forum.

    Did this issue occur when user receive emails using OWA?

    If this issue also occur on OWA, please refer to the following steps on Exchange 2010 and Exchange 2013 to have a try:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry key:
        HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/MSExchangeIS/ParametersPrivate
        If the ParametersPrivate registry subkey does not exist, follow these steps:
        a.On the Edit menu, point to New, and then click Key.
        b.Type ParametersPrivate, and then press ENTER.
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type Disable All Duplicate Detection, and then press ENTER.
    5. On the Edit menu, click Modify.
    6. Type 1, and then click OK.
    7. Locate and then click the following registry key:
        HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/MSExchangeIS/ParametersPublic
        If the ParametersPublic registry subkey does not exist, follow these steps:
        a.On the Edit menu, point to New, and then click Key.
        b.Type ParametersPublic, and then press ENTER.
    8. On the Edit menu, point to New, and then click DWORD Value.
    9. Type Disable All Duplicate Detection, and then press ENTER.
    10. On the Edit menu, click Modify.
    11. Type 1, and then click OK.
    12. Exit Registry Editor.


    If this issue just occur on outlook, for example outlook 2010, please refer to the following link:

    https://support.microsoft.com/en-us/kb/2685726 

    Best Regard,

    Jim Xu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Wednesday, May 11, 2016 2:13 AM
    Moderator
  • Hi Albert, 

    Is there any update for this thread?

    If the above suggestions are helpful to you, please mark it as answer so that someone who has similar issue could find this thread as soon as possible.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Thursday, May 12, 2016 9:21 AM
    Moderator
  • Hi!

    Sorry for the delay! I have found out the problem. Before taking any action, I have done two easy tests:

    1- Create a test mailbox in Exchange 2010 database. Add this mailbox in a test distribution group. When I send a mail to the mailbox and to the group at the same time, the mail only arrives one time.

    2- Create a test mailbox in Exchange 2013 database. Add this mailbox in test distribution group. When I send a maol to the mailbox and to the group at the same time, the mail only arrives one time.

    Then, I analyze the sender of the problematic duplicate mail. It is an script made by third party company. That was the problem! We don't know exactly why, but the only duplicated incoming mails are coming from that script.

    Thank you so much for your help!

    • Marked as answer by Albert Beired Thursday, May 19, 2016 7:49 AM
    Thursday, May 19, 2016 7:48 AM