locked
Trouble on admin sharing RRS feed

  • Question

  • hi....

    Im new here, please help my trouble on win server 2008 x64.

    I Have a server 2008 as DNS, DC + backup data user. Local IP 172.21.1.2.

    Why can I access \\172.21.1.2\d$ from user PC which login as user without prompt username and password admin. 

    I have tried to search solution, still no result.

    Please help me.

    Regards,

    Anton

    Thursday, July 21, 2016 2:45 AM

All replies

  • Hi Antoniusd,

    >Why can I access \\172.21.1.2\d$ from user PC which login as user without prompt username and password admin. 

    I tested it in my lab, if you have ever used Admin account to access the admin share, then the next time we visit the resource, it will not prompt the credential authentication. Since the Admin account has been cached.

    We need to use command net use * /d to clear the cache, then the next time we login using user account to access Admin share, it will prompt to enter credential.

    Best Regards 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, July 21, 2016 5:50 AM
  • Hi Anne He,

    Thank you for reply :)

    I already use net use command, still no password need. Tried on some PC user, same result.

    Dont you thing its on server side?

    Thanks,

    Anton

    Thursday, July 21, 2016 7:48 AM
  • Hi Antoniusd,

    After using the command, logoff the current user, then login again, you'll get the prompt.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, July 21, 2016 7:55 AM
  • Hi Anne He,

    Sure, I'll try it tomorrow. Already leave office.

    Thanks again advice.

    Thanks,

    Anton

    Thursday, July 21, 2016 11:40 AM
  • Hi Anne He,

    Already logoff and restart user PC then login as user, same result. 

    \\172.21.1.2\d$ either c$ opened without username pass :(

    Thanks

    Anton

    Friday, July 22, 2016 4:21 AM
    1.        Launch Control Panel, type admin… in the search box, and then click Administrative Tools.
    2.        Open the Local Security Policy application.
    3.        Navigate to Local Policies > Security Options.
    4.        Enable the policy User Account Control: Run all administrators in Admin Approval Mode.

    Above steps need to be done on the  172.21.1.2 server.

    This will enable the local admin account for the local share. 



    Friday, July 22, 2016 4:33 AM
  • Hi Soundarraj Ramasamy,

    Thank you for reply. I had checked your suggest, and my policy already in enable position. Tonight (because it says need to restart), Ill make disable first, then restart, then enable again and restart. Then Ill test admin share again.

    Thanks,

    Anton

    Friday, July 22, 2016 8:17 AM
  • Anyone please? :(
    Monday, July 25, 2016 1:41 AM
  • For Windows Server 2008 R2 users

    ・Sharing the Public folder

    1. On the [Start] menu, select [Control Panel] to open [Control Panel] window.

    2. Click [View network status and tasks] to open the [Network and Sharing Center] window.

    3. Click [Change advanced sharing settings] in the [Network and Sharing Center] window.

    4. In the [Advanced sharing settings] window, under [Public folder sharing], select [Turn on sharing so anyone with network access can read and write files in the Public folders].

    5. Under [Password protected sharing], select [Turn on password protected sharing], and then click [Save changes].
    Monday, July 25, 2016 4:37 AM
  • Hi Soundarraj Ramasamy,

    Thanks again for reply.

    I Have done 1-4. But where I find [password protected sharing] ? 

    On my menu there are 3 items: Network Discovery, File and Printer Sharing, Public folder sharing. Sorry, cannot attach image :(

    Thanks,

    Anton

    Monday, July 25, 2016 8:46 AM
  • For Windows Server 2008 users

    1. On the [Start] menu, select [Control Panel] to open [Control Panel] window.

    2. Click [Set up file sharing] to open the [Network and Sharing Center] window.

    3. In the [Network and Sharing Center] window, click the downwards arrow next to [Public folder sharing].

    4. Select [Turn on sharing so anyone with network access can open, change, and create files], and then click [Apply].

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact soundarrajmca@gmail.com

    Monday, July 25, 2016 11:21 AM
  • Hi Soundarraj Ramasamy,

    Thanks again for reply.

    Opening Network and sharing center, but I cant find [Public Folder Sharing]. I'm using server 2008 R2 std.

    Thanks,

    Anton

    Wednesday, July 27, 2016 2:27 AM
  • Server is in domain? Did you have install the file share in roles & features option?

    Where you are trying to access the share folder (Client OS )

    Wednesday, July 27, 2016 5:14 AM
  • Hi Soundarraj Ramasamy,

    Server on domain. How I check the file share in roles & features option that has ben installed?

    I'm trying to access folder share \\ip\d$ from win 10 and win 7, both same result (without user n pass prompt)

    Thanks for reply,

    Anton

    Wednesday, July 27, 2016 6:31 AM
  • By default when you access some computer's share (typing \\hostname in Windows Explorer) Windows passes credential of my current user. It prompts for credentials only when current user's credentials are incorrect.

    I hope user name & password is same for both server & client..!

    Try to take a share from normal user account. To isolate the issue create one local user in the client and try to take share with that account.


    Wednesday, July 27, 2016 8:10 AM
  • Hi Soundarraj Ramasamy,

    I login as domain user from PC1 then access \\PC2\sharefolder (everyone full access) . Both, PC1 and PC2 joining same domain. no need password to sharefolder, all normal.

    Then, from PC1 again, access \\PC2\D$. prompt username and password. Input user and pass admin domain, success access-ing PC2\d$. all normal.

    Then, from PC1, access \\serverdomain\d$. Viola....openned.... No need input user and pass :( hiks....

    Thanks,

    Anton

    Thursday, July 28, 2016 9:19 AM
  • Try to change the Network Group. 

    Friday, July 29, 2016 1:18 AM
  • Hi, 

    Sorry for quite long absence, I've been working on site.

    As your suggestion, I tried access \\172.21.1.2\d$ from workgroup PC as user today. And miracle happened, Its prompt for user n pass... yey....

    unfortunately, I input standart user domain (not domain administrator) then that d$ opened. 

    So, I guess, problem in my sharing permission. Right? Where I can change permission sharing for D$?

    Thanks,

    Anton

    Thursday, August 4, 2016 2:36 AM
  • Hi Antoniusd,

    We may disable Admin sharing, while it's not recommended to do so.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 9, 2016 9:55 AM
  • Hi Anne,

    Some times ago, I already disabled them. 

    but I still need that admin share. why? cause its ease me to access some restricted folder on user login, cause that is pop up ask for user n pass. I was try to share that folder manually and add admin only that can access that, but its need to login as admin to access that folder. Save current work, logoff current user, login as admin, then I can access restricted folder. It is need many effort.

    Please help anyone :(

    Thanks,

    Anton

    Wednesday, August 10, 2016 2:31 AM
  • test.... 
    Friday, August 26, 2016 3:38 AM