locked
Task Bar On Top, Start Menu is Always Full Screen Height RRS feed

  • Question

  • I prefer my Task Bar across the top of the screen, rather than at the bottom.  I also like it to autohide.  This is my preference.

    This seems to work okay but for one thing...  When I click the Start button the start menu expands to the full height of the screen, making the thing I'm most likely to want to click on ("All Programs") as far away from my mouse as is possible!



    I've been told by various fanboys not to crave the Classic start menu any more, as clearly I am a dinosaur for wanting that.  Fair enough, I'm trying to use what's given to me by Windows 7.

    Is there a setting or trick that will allow my Start menu to be only as high as it needs to be?  Even if it's only half the height of the screen that will be a relief. 

    And don't say I should move my Task Bar to the bottom, that's not gonna happen.

    -Noel
    Saturday, October 3, 2009 5:12 PM

Answers

  • Let's test following steps.

     

    1. Right click on Start, choose Properties.

    2. In Start Menu tab, click  Customize.

    3. Change the both number under "Start menu size" to 10 or less.

    4. Click OK and OK again to apply the change.

     

    Let me know if issue still exists.

    Thursday, October 8, 2009 7:26 AM
  • Ok I have figured this out for anyone still suffering. You must enable "Store and display recently opened programs in the start menu" THEN change the value down from 10. Apply these settings THEN you can turn off "Store and display recently opened programs in the start menu" again and your menu will stay small! :)

    Otherwise the value does not seem to take effect.

      Brian

    • Proposed as answer by briantonkinson Sunday, April 4, 2010 9:57 AM
    • Marked as answer by Noel Carboni Tuesday, April 6, 2010 1:12 AM
    Sunday, April 4, 2010 9:57 AM

All replies

  • The height is decided based on how many slots are reserved for frequently used programs.  Head to your start menu properties and turn it down a bit, maybe only 8 items or so.  You can also reduce the height by removing things on the right that you don't need (direct links to Music, for example) or telling it to use Small Icons instead of giant ones.
    Saturday, October 3, 2009 10:41 PM
  • Doesn't happen for me, Win 7 RC1:

    Sunday, October 4, 2009 1:52 AM
  • No repro here either, Running Windows 7 RTM, set to auto hide and at the top of the screen, and getting the normal size I previously set. I believe that Shawn likely has proposed the solution, please try that and let us know if it works.

    -Anthony
    Sunday, October 4, 2009 3:13 AM

  • Wouldn't be complete without adding  Move your Task Bar to the bottom.


    Heh heh heh....   Tell you what, as a compromise, why don't we both move our Task Bars to the side.  :)

    Changing the number of recent programs to display and removing things from the right side make no difference.  This may be something they fixed in the RTM.  I'm still running the RC 7100 build, awaiting the public release.  Or perhaps it is because I am running Win 7 with Aero off.

    Thanks, everyone, for your replies, and especially for verifying it can work properly in the RTM.

    -Noel

    Sunday, October 4, 2009 9:40 AM
  • Interestingly, I did try moving the task bar briefly to the bottom.  The Start menu is STILL the full height of the screen.  Clearly some metric is wrong as provided by the VMWare video driver, or something about this particular installation is a bit wacky (though it works PERFECTLY otherwise; never a fault, never a crash, no errors logged).

    -Noel
    Monday, October 5, 2009 1:27 PM
  • Ahh, that might be your answer right there! What version of vmware are you running and does it support a Windows 7 guest (officially)? If not then you might just have to wait for them to put out an update. (Though I haven't heard of anyone else experiencing this problem on vmware, but then again, I haven't been paying that much attention.)
    Monday, October 5, 2009 8:28 PM
  • Let's test following steps.

     

    1. Right click on Start, choose Properties.

    2. In Start Menu tab, click  Customize.

    3. Change the both number under "Start menu size" to 10 or less.

    4. Click OK and OK again to apply the change.

     

    Let me know if issue still exists.

    Thursday, October 8, 2009 7:26 AM
  • I don't know why this has been marked as the anwer when it clearly doesn't work. I am using the full retail version of Win7 and I have two massive blank spaces below both the left and right hand side of the menu despite setting both the above values to zero.
    Sunday, April 4, 2010 9:43 AM
  • Ok I have figured this out for anyone still suffering. You must enable "Store and display recently opened programs in the start menu" THEN change the value down from 10. Apply these settings THEN you can turn off "Store and display recently opened programs in the start menu" again and your menu will stay small! :)

    Otherwise the value does not seem to take effect.

      Brian

    • Proposed as answer by briantonkinson Sunday, April 4, 2010 9:57 AM
    • Marked as answer by Noel Carboni Tuesday, April 6, 2010 1:12 AM
    Sunday, April 4, 2010 9:57 AM
  • Thank you.  Apparently way back then in the RC I had set the size of the list very large before I had decided to disable the feature entirely.

    It does solve a long-standing minor irritation I've felt occasionally, in that the default height of the menu sometimes seems a little too SHORT.  I was just able to lengthen the box a bit by checking Store and display recently opened programs, increasing the count, then unchecking same.

    I suppose this connection should have been obvious, but somehow back when I asked the question originally I never put 2 + 2 together on this UI element, and I've never put much thought into it since.  So thanks again for the "better late than never" response!

    -Noel

    Tuesday, April 6, 2010 1:14 AM