locked
RDP (Remote Desktop) to Windows 10 without passwords not possible anymore. Bug or feature? RRS feed

  • Question

  • After upgrading two of my machines to Windows 10 (Education N clean install and Pro N upgrade from Win8.1), I was not able to set up Remote Desktop as I was used to since Windows 7 (maybe this was possible before, too).

    I am used to configure Windows to allow RDP connections as a user without password (home usage only). Apparently this is not working anymore after upgrading to Windows 10. (I have enabled this by modifying secpol.msc 's security policies. Further informations provided if needed).

    With the "no password" setup i get immediatly disconnected by the local machine which seems to auto login by itself after connecting via RDP. The only solution I managed to find so far was to set up a password. 

    Is this a bug or a feature?

    Cheers

    Thursday, August 27, 2015 7:16 PM

All replies

  • Hi,

    I have tested to use a user account which has blank password to RDP to Windows 10, and got the error message below:

    This behavior is caused by security restriction configured in Group Policy, more specifically, which is:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Limit local account use of blank passwords to console logon only.

    This policy setting is enabled by default on other Windows Systems, too, except that the error message is displayed right after clicked Enter in RDC.

    Here is a related KB article below for you:

    Error Message: Unable to Log You on Because of an Account Restriction

    https://support.microsoft.com/en-us/kb/303846

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Gianluca80 Sunday, September 3, 2017 1:41 PM
    Tuesday, September 1, 2015 9:42 AM
  • Hi, 

    thanks for your answer.

    Hi,

    I have tested to use a user account which has blank password to RDP to Windows 10, and got the error message below:

    I'm not sure if we are talking about the same situation. Both of my machines have only 1 user with blank password. Let's say pc1 has user1 and pc2 has user2. The "Limit local account use of blank passwords to console logon only" option is disabled on both machines. The important part here is not about connecting from a Win10 machine, it's about connecting to a Win10 machine . Doesn't matter if both are Win10.

    This behavior is caused by security restriction configured in Group Policy, more specifically, which is:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Limit local account use of blank passwords to console logon only.

    This policy setting is enabled by default on other Windows Systems, too, except that the error message is displayed right after clicked Enter in RDC.

    That's what I meant when I mentioned the following:

    I am used to configure Windows to allow RDP connections as a user without password (home usage only). Apparently this is not working anymore after upgrading to Windows 10. (I have enabled this by modifying secpol.msc 's security policies. Further informations provided if needed).


    • Edited by .sobrino Tuesday, September 1, 2015 10:10 AM
    Tuesday, September 1, 2015 10:10 AM
  • Hi,

    My apologies for the misunderstanding.

    The important part here is not about connecting from a Win10 machine, it's about connecting to a Win10 machine.

    Yes, I have tested this, more specifically, remotely connect to a Windows 10 machine from a Windows 8.1 machine.

    With the "no password" setup i get immediatly disconnected by the local machine which seems to auto login by itself after connecting via RDP.

    Would you please clarify the part “which seems to auto login by itself”?

    I don’t get disconnected after using a blank password account to remotely connect to Windows 10, the connection is pretty stable.

    Please check whether session limits group policy was configured, you may run GPresult.exe on the Windows 10 machine to get a complete view of group policy settings configured and applied.

    You may also check session limits registry, which is under

    HKEY_Local_Machine\ SOFTWARE \ Policies \ Microsoft \ Windows NT \ Terminal Services.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 2, 2015 2:57 AM
  • Hi,

    My apologies for the misunderstanding.

    No need to apologize. I guess the misunderstanding could also be due to my english skills cause it's not my native language.

    Yes, I have tested this, more specifically, remotely connect to a Windows 10 machine from a Windows 8.1 machine.

    Just to be sure again -> To reproduce the problem there has to be just one user account on the Windows 10 machine. And this user must have no password set. Let's say the username on the Win10 machine is win10user. It doesn't matter how many accounts are on the Windows 8 machine, but let's say you are logged in local on the Win8 machine with user win8localuser. U have to connect from Win8 to Win10 and when asked for login details you have to enter win10user with no password. If you get the error message you posted above saying "A user account restriction is preventing ...", then u need to disable "Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Limit local account use of blank passwords to console logon only".

    Would you please clarify the part “which seems to auto login by itself”?

    Sure, I will try to be as detailed as possible. At the beginning, I am logged on on the Win10 machine localy and i can see my desktop. With the setup mentioned above, I connect from my laptop (let's pretend it's Win8) to my Win10 machine, which has exactly one user account with no password set. The RDP session opens successfully and I can see the desktop of the remote Win10 machine on my Win8 machine through the RDP session (as it should be). Sidenote: I can see the physical screen / monitor from where i connect, cause i'm sitting right next to it with my laptop when connecting. The moment i succesfully connect via RDP, the "local session" on the Win10 machine is getting disconnected -> still everything how it should be.

    Now begins the weird and what i believe buggy part: 
    About one second after the local session of the Win10 machine got disconnected, it starts relogging by itself. The Win10 machine is "getting back its session" and I'm getting disconnected from my RDP session with an (error) message telling me that another user has logged in (which was the Win10 machine somehow doing an auto login).

    I hope I have been detailed enough and the english is well enough to understand what I'm trying to say. If not, just let me know and I try do be even more detailed and attach some screenshots.

    Please check whether session limits group policy was configured, you may run GPresult.exe on the Windows 10 machine to get a complete view of group policy settings configured and applied.

    You may also check session limits registry, which is under

    HKEY_Local_Machine\ SOFTWARE \ Policies \ Microsoft \ Windows NT \ Terminal Services.

    I have checked group policies and couldn't find anything which may cause the issue.
    The registry path you described doesn't provide any information about session limits.

    One thing to add -> I tried setting a password to my win10user and then connect via RDP again -> this works without any problem. But as soon as I remove the password again and open an RDP session, I get disconnected after a second again.

    Thanks a lot for taking the time to help me in this case.


    • Edited by .sobrino Wednesday, September 2, 2015 4:43 PM Correcting spelling mistakes and maybe adding a few others :)
    • Proposed as answer by Lobelito Tuesday, April 9, 2019 10:35 AM
    Wednesday, September 2, 2015 4:40 PM
  • I can verify this bug. Win 10 PCs without password on local account and disabled "Limit local account use of blank passwords to console logon only", within a second or so I get disconnected by the local machine which seems to auto login by itself when I connect with remote desktop.

    Is there any fix yet?


    • Edited by raffe1234 Sunday, September 20, 2015 8:12 AM
    Sunday, September 20, 2015 8:03 AM
  • Sadly I haven't heard about a fix yet. I'll let u know once i know about how to fix this or if i find a workaround.

    • Proposed as answer by Kyle.Hov Tuesday, October 6, 2015 11:59 PM
    • Unproposed as answer by Kyle.Hov Wednesday, October 7, 2015 12:00 AM
    Sunday, September 20, 2015 1:17 PM
  • I am also able to verify this problem, trying to RDP from XP Pro into a Windows 10 Pro machine with a user with a blank password set, and with the policy changed to allow it (which worked in previous versions of windows).  If I try to connect with the Windows 10 machine's name, I get kicked out after a second or two.  However, if I try to connect with the machine's IP address, I am able to stay connected for about 25 seconds or so.  I am even able to stay longer if I open something like Task Manager and leave it open.  But, when I try to do something, such as view event logs, I will eventually get kicked off.  

    Try using the the machine's IP address, and see if you get different results.

    Wednesday, October 7, 2015 1:56 AM
  • Hi,

    I have the same issue with a RDP from Windows 10 to an another Windows 10 without password, i'm disconnected immediately both with a connection to local IP adress and DNS name.
    For the moment, my only pseudo-solution is to add a password and force auto login at startup to avoid typing the password.

    Hope that's bug will be fixed soon

    • Proposed as answer by Sergey Mir Wednesday, January 13, 2016 12:25 PM
    Monday, November 9, 2015 12:31 PM
  • I have the same issue, do you get any workaround?

    Saturday, November 14, 2015 8:55 PM
  • I have the same issue in case when trying to connect to Win10 PC from my Mac.
    Friday, January 8, 2016 11:06 AM
  • After upgrading two of my machines to Windows 10 (Education N clean install and Pro N upgrade from Win8.1), I was not able to set up Remote Desktop as I was used to since Windows 7 (maybe this was possible before, too).

    I am used to configure Windows to allow RDP connections as a user without password (home usage only). Apparently this is not working anymore after upgrading to Windows 10. (I have enabled this by modifying secpol.msc 's security policies. Further informations provided if needed).

    With the "no password" setup i get immediatly disconnected by the local machine which seems to auto login by itself after connecting via RDP. The only solution I managed to find so far was to set up a password. 

    Is this a bug or a feature?

    Cheers

    could this be the reason? https://technet.microsoft.com/library/security/MS16-007

    except that it came out later than your post. that makes me think it was possible then.

    did you find any workaround meanwhile?
    Thursday, March 17, 2016 8:23 PM
  • Hello,

    I want to unearth this topic, I didn't find any other resources linked to this issue, except https://social.technet.microsoft.com/Forums/en-US/ec91757f-66ad-4a0f-b22a-3d2da9ccf6a6/remote-desktop-connection-pc-will-restart-in-one-minute?forum=winRDc, solution was to set a password for the user, but it's not satisfactory for me, I want a blank password to this user.

    It's not a definitive observation, but I solved my issue with Windows 10 Pro, I got the issue when Education version was installed, subject to Windows updates not done, but I launched them yesterday and it works for now, and I noticed my surface under 10 doesn't have the issue too, same reservation related to Windows updates, but right after Education install rdp crashed the computer.

    Any thought ? It's possible this is a KB and only need to remove or not install it ?

    Friday, June 17, 2016 3:14 PM
  • Ok after one little week, the issue doesn't not reappears, my computer is up to date, and no disconnection with rdp, so Professionnial solve, i mean really solve it.
    Saturday, June 25, 2016 1:10 AM
  • I have two Windows 10 Professional x64 machines, one of which is freshly set up and has an empty-password admin account. Remote connections with empty password are enables in security policy. Both machihes are fully updated.

    Trying to connect through Remote Desktop to the freshly set up machine from another Windows 10 Professional x64 machine results in "Windows ... will restart automatically in one minute" message in the client machine followed by a restart.

    Friday, July 22, 2016 4:37 PM
  • The Windows 10 Anniversary Update seems to have fixed this for me.
    Tuesday, December 13, 2016 2:55 AM