locked
How to disable foldername translations? RRS feed

  • Question

  • Windows as of XP has this "feature" that it will "translate" directorynames in explorer to make it easier for non computer savy people. But it is driving me crazy sometimes. In XP it was just the rename of something simple as D&S\Bonno\My Documents into "D&S\Bonno\Documents of Bonno". However, now that I am using Windows 7 it is getting worse. For instance, in Outlook my data is stored in C:\Users\Bonno\AppData\Local\Microsoft\Outlook. In Explorer the C:\Users directory does not exist. there is a C:\Gebruikers directory and NO that is not a link like the C:\D&S directory which points to the C:\Users directory.

    Is there a way to disable these translations of directorynames in Explorer?
    Every time I copy a dir path from Explorer into a batch file I have to check whether that is realy the "real" dir path which I can use in my batchfile. Because, for instance, dir C:\Gebruikers does NOT work on the commandline. :-(

     

    Wednesday, January 26, 2011 8:53 AM

Answers

  • So I wanted to change that. I open a cmd box (not as administrator) and a simple dir des* /a shows the file present.

    Enable the option to see hidden and system files in the Explorer options. Now you can see the ini files.

    I like Windows 7 for a lot of reasons but some things I can definitely do without. This is one of them. (The other is the disabling of existing network mappings in an administrative cmd box.) :-(((((

    activate EnableLinkedConnections :

    http://support.microsoft.com/kb/937624

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Marked as answer by Nicholas Li Tuesday, February 1, 2011 7:13 AM
    Friday, January 28, 2011 2:34 PM

All replies

  • The Explorer uses the Desktop.ini inside the folders to display the new foldername (LocalizedResourceName).

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, January 26, 2011 1:42 PM
  • So I wanted to change that. I open a cmd box (not as administrator) and a simple dir des* /a shows the file present. Attrib des* shows it hidden,system. Unfortunatly I cannot change it using attrib from a normal cmd box, I need an cmd box with Administrative priviliges.

    So I open a second cmd box as such a guess what? Suddenly the file Desktop.ini does not exist and therefore cannot be edited. :-(

    I like Windows 7 for a lot of reasons but some things I can definitely do without. This is one of them. (The other is the disabling of existing network mappings in an administrative cmd box.) :-(((((

     

    Friday, January 28, 2011 8:16 AM
  • Hi Bonno,

     

    In Windows 7, C:\Documents and settings is not a real folder. It is called a junction point and is used for legacy program interface. Your data will be in C:\USERS\Bonno\Appdata. Please understand the junction point is by fault in Windows. Generally, you don't have permission to access the folder even with Administartor.

     

    In addition, I notice Gebruikers is Afrikaans. C:\Gebruikers is equal to C:\Users. That's why you cannot find C:\Users directory. Please check if you have installed any language software.

     

    Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Nicholas Li Tuesday, February 1, 2011 7:13 AM
    • Unmarked as answer by Bonno Bloksma Monday, February 7, 2011 11:20 AM
    Friday, January 28, 2011 9:10 AM
  • So I wanted to change that. I open a cmd box (not as administrator) and a simple dir des* /a shows the file present.

    Enable the option to see hidden and system files in the Explorer options. Now you can see the ini files.

    I like Windows 7 for a lot of reasons but some things I can definitely do without. This is one of them. (The other is the disabling of existing network mappings in an administrative cmd box.) :-(((((

    activate EnableLinkedConnections :

    http://support.microsoft.com/kb/937624

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Marked as answer by Nicholas Li Tuesday, February 1, 2011 7:13 AM
    Friday, January 28, 2011 2:34 PM
  • I know I can see hidden and system files in Explorer. That is how I finaly was able to remove this option but I was surprised that a cmd box opened with administrative options does NOT show the desktop.ini file that a simple cmd box does.

    About the "activate EnableLinkedConnections :"... Thanks, that is what I need.

    It may be considered a security issue by some but not by me. What is the difference in security by blocking access to maped drive S: to \\server.domain.com\Share but allowing acces to UNC path \\server.domain.com\Share ? I don't see why blocking the first makes it more secure.

     

    Thursday, February 3, 2011 4:17 PM
  • Hi Niki,

    The problem is not in C:\Doc&Settings being a junction point. I was refering to the "real" directory C:\Users that got translated in the Explorer screen. It got even stranger when a "regular" user was able to see the Desktop.ini file using a Dir /a command but in an administrative command box the file was missing.

    p.s. C:\Gebruikers is Dutch, the language Afrikaans was derived from.

    Monday, February 7, 2011 11:25 AM