none
How do I disable the "Protected mode is currently turned off for the Internet zone" message? RRS feed

  • Question

  • The message is a waste of my screen real estate. Yes, Protected mode is turned off. Sure it is, I turned it off myself, and it will stay off. Now how do I disable this annoying nag message?

    Also the messages about File Downloads. Never once in my life I clicked a download link by mistake. Yes, I'm clicking that dang URL, because I wan't to download that dang file, now get out my way, annoying warning message. How do I disable this one too? Thank you in advance

    Saturday, June 11, 2011 9:02 PM

Answers

  • Hi,

    Based on my research, this is by design. You cannot disable the warning when you open a new IE windows.

    If you find have any inconveniences or suggestions, please submit your feedback to our Product Feedback Team : http://mymfe.microsoft.com/Windows%20%207/Feedback.aspx?formID=195

    Thanks for understanding.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, June 14, 2011 9:15 AM
    Moderator

All replies

  • Hi,

    Based on my research, this is by design. You cannot disable the warning when you open a new IE windows.

    If you find have any inconveniences or suggestions, please submit your feedback to our Product Feedback Team : http://mymfe.microsoft.com/Windows%20%207/Feedback.aspx?formID=195

    Thanks for understanding.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, June 14, 2011 9:15 AM
    Moderator
  • That is all well "by design" but even if disabled by group policy and you disable also the warning messages policy it still nags about this setting. Protected mode has problems with redirected favorites to unc path (you can't add any new ones...)  even if I play with the setintegrity command.

    Tuesday, June 28, 2011 12:17 PM
  • Hello, i don't know if you found out how to disable the "protected mode is currently turned off" message, but it is funny looking at these replys. It is obvious they tried nothing before posting. Hehe. So I had the same problem, that is how I foudn this post. But after not being sattisfied with the "Thats by design" bullshit (you have to learn how to smell bullshit!!! you must!) anyway, i tryed right clicking on the damn message and right there, it says "Don't show this again" lmao!! right? isnt that funny? well this was like 4 months ago so maybe you already figured it out, but i found it funny.

    Hey, do me a favor - if you actually get this message, reply back to max8987@gmail.com or IM me (AIM) at Maxinator8987 to let me know if this helpled you lol. Im just curious and i wanna know if this forum will send you this message.

    -Max Z (random forum guy)

    • Proposed as answer by maplemale Monday, January 30, 2012 8:16 PM
    Tuesday, August 16, 2011 8:32 AM
  • Ok so after facing this myself I determined "By Design" wasn't acceptable.  So I traced down the registry file that gets rid of this message for everyone.  This is especially useful for RDS (Remote Desktop Services Servers) and IE9 with Roaming profiles and Redirected folders.  I have the full write up here:

    JJStellato.BlogSpot.com

    But basically the key is

    HKCU - Software - Microsoft - Internet Explorer - Main

    New DWORD
    NoProtectedModeBanner
    Decimal value of 1
    • Proposed as answer by Tapio Peltonen Tuesday, December 13, 2011 9:26 AM
    Tuesday, September 13, 2011 7:14 PM
  • Thank you so much. This saved us a lot of time.
    Tuesday, December 13, 2011 9:26 AM
  • Likewise, thank you very much for posting the info, IcedOutCat. You saved me the research time.
    Thursday, July 5, 2012 4:53 PM
  • This works with IE10 on server 2008 R2 w/remote desktop.

    Thanks!

    Thursday, July 11, 2013 3:22 PM
  • It also works with Server 2012 and RDS.

    Thanks!

    Thursday, September 12, 2013 1:23 PM
  • Thanks IcedOutCat.
    I hate the typical 'this is by design' BS that MS take for things like this.

    Your research has helped me out too :-)

    Tuesday, October 8, 2013 1:19 PM
  • How does one implement this on a server so that each user who logs in gets this?  (e.g. A Terminal Server)  This key is specific to HKCU and not the default user group.  Is this the same yellow banner you get at the top of your window in IE8 that states "Protected mode is currently turned off for the Internet zone"?
    Tuesday, November 5, 2013 8:26 PM
  • If it's only one server, the easiest thing to do is create a batch file to silently merge the respective registry keys into the HKCU hive then modify the local group policy (gpedit.msc) of the Terminal Server to run that script at logon. If you have many Terminal Servers to manage, use a domain group policy.
    Wednesday, November 6, 2013 11:10 AM
  • Thank you IcedOutCat!  

    I don't know about others but I consult forums to solve issues.  Moderator, please refrain from posting ill informed opinions if you have nothing of value to offer. To state this is "by design" is misleading and wastes people's time.

    Saturday, December 7, 2013 9:16 PM
  • Thanks, IcedOutCat! It works perfect!
    Friday, January 17, 2014 10:05 AM
  • Awesome!  thanks for posting the registry key to kill this problem

    For those asking how to roll this out to a terminal server, use Group Policy.  In GPP it's super easy to add a registry entry for every user who logs onto it.

    Monday, April 7, 2014 9:49 PM
  • Thank you! It helps me, to help the user help themselfes ;)
    Wednesday, May 21, 2014 2:05 PM
  • HKCU - Software - Microsoft - Internet Explorer - Main

    New DWORD
    NoProtectedModeBanner
    Decimal value of 1

    Thanks a lot! :)
    • Proposed as answer by JeffLe73 Saturday, June 29, 2019 6:46 PM
    • Unproposed as answer by JeffLe73 Saturday, June 29, 2019 6:46 PM
    Tuesday, March 22, 2016 9:45 AM
  • <3 Workin
    Thursday, April 28, 2016 11:50 AM
  • So I cannot get this solution to work.  My system is Win7 with IE11.  My account has local administrator privileges for the registry.  I create the DWORD change the hex and move to a different key then go back and the DWORD I created is gone.  Please help this darn banner is extremely annoying.  Selecting the "Do not show this message again" only works for that tab.  If you open a new tab you get it again.
    Friday, August 5, 2016 1:44 PM
  • I am getting same result. create key and then key goes away after clicking on another key then going back. I am in a corporate domain environment. not sure if that matters. 
    Wednesday, August 31, 2016 3:57 PM