none
FIM 2010 R2 Lotus Domino MA error RRS feed

  • Question

  • Hi,

    I'm currently setting up a lab environment with the following configuration:

    • a FIM 2010 R2 single server (with FIM Sync and FIM service)
    • a Lotus Domino 8.5 server with customized LDAP schema
    • Installed Domino Lotus 8.x connector to FIM (http://www.microsoft.com/en-hk/download/details.aspx?id=29038) in FIM server
    • Installed Lotus Domino Client 8.5 FP3

    I have tried to create a Management Agent (step 2 Connectivity) to Lotus Domino and I got the following error on event log:
     "Microsoft.MetadirectoryServices.ExtensibleExtensionException ---> System.NullReferenceException: Object reference not set to an instance of an object. 
       at Microsoft.IdentityManagement.MA.LotusDomino.NotesClientWrapper.DominoConfig.GetOrganizationalUnit(KeyedCollection`2 configParameters) 
       at Microsoft.IdentityManagement.MA.LotusDomino.Common.DominoConfigParam.GetConfigParameters(KeyedCollection`2 configParameters, ConfigParameterPage page) 
       at Microsoft.IdentityManagement.MA.LotusDomino.LotusDominoMA.Microsoft.MetadirectoryServices.IMAExtensible2GetParameters.GetConfigParameters(KeyedCollection`2 configParameters, ConfigParameterPage page) 
       --- End of inner exception stack trace --- 
       at Microsoft.IdentityManagement.MA.LotusDomino.LotusDominoMA.Microsoft.MetadirectoryServices.IMAExtensible2GetParameters.GetConfigParameters(KeyedCollection`2 configParameters, ConfigParameterPage page) 
    Forefront Identity Manager 4.1.3419.0" 

    I would like to know if there is any problem during I create the Management Agent?

    Regards,
    Tonny


    Tonny

    Tuesday, August 12, 2014 4:15 AM

All replies

  • I'm seeing this as well.  Initially was on Notes 8.5.2 FP4 and upgraded to 9.0.1 no FP.  Going to 9.0.1 FP7 seemed to resolve the issue on FIM v4.1.3671.0.  Repeated process on different server for MIM GA 4.3.1935.0, but issue still persists every time a delta import is started.  Both OS Server 2012 R2.

    Connector version 1.1.117 from here - microsoft.com/en-us/download/details.aspx?id=51495

    Monday, November 21, 2016 5:16 PM