locked
Indexing Offline Files causes Slow Saving of documents RRS feed

  • Question

  • We are running Windows 7 Enterprise & Office 2010.

    Some of our users (some of the time) get a 30 second pause when saving a file to their home folder which is located on a network drive. The home folder is available Offline and is Indexed for Windows Search.

    I can reproduce the issue by quickly modifying and saving (ctrl-s) a Word file. If I turn off Indexing on that Offline location, the problem disappears.

     

     

     

    Friday, December 3, 2010 12:04 AM

Answers

  • Yes, KB981711 alone resolves the issue.

     

    • Proposed as answer by HDI Thursday, February 3, 2011 9:54 PM
    • Marked as answer by Alan.Pater Wednesday, February 16, 2011 5:08 PM
    Thursday, February 3, 2011 9:54 PM

All replies

  • Run ProcessMonitor [1] in background and look what causes the delay.

    André

    [1] http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
         http://www.msteched.com/2010/NorthAmerica/WCL314

     


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, December 3, 2010 12:57 PM
  • I've run ProcessMonitor, set the filter to winword.exe, only File System Activity, result does not equal Success.

    I then reproduced the problem and received results ranging from "NAME NOT FOUND", "BUFFER OVERFLOW", "NO SUCH FILE", "NO MORE FILES", "PRIVILEDGE NOT HELD".

    But I am not expert enough to make sense of the results.

     

     

    Friday, December 3, 2010 9:29 PM
  • Here is an office 2007 example in this video:

    http://www.msteched.com/2010/Europe/WCL301

    At 24:00 minutes the office hang was discussed. Maybe this helps you to find the cause.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, December 4, 2010 1:21 AM
  • The issue occurs if your network device does not support Remote Differential Compression. Please follow the steps below to disable it.
    .
    1. Click Start – Control Panel – Programs – Trun Windows features on or off
    2. Uncheck “Remote Differential Compression” and click OK.
    3. Restart the computer and you should see an improved performance with copying files.

    If the issue persists, temporary disable antivirus and firewall then check the result again.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, December 6, 2010 8:04 AM
  • The issue occurs if your network device does not support Remote Differential Compression.

    We are not seeing an issue with slowing copying of files. The issue is that when Offline Files are Indexed , random saves are slow. Turning of Indexing on Offline files resolves the issue, but our users need to have these files indexed.

    Besides: http://blogs.technet.com/b/filecab/archive/2008/05/02/debunking-a-myth-about-remote-differential-compression.aspx

    Monday, December 6, 2010 5:39 PM
  • Have you tried to turn RDC off and check the result?

    Another thing you can try is disablint auto-tuning.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Monday, December 13, 2010 5:54 AM
    • Unmarked as answer by Alan.Pater Tuesday, December 14, 2010 7:31 PM
    Wednesday, December 8, 2010 3:04 AM
  • Hi,

    We are having the same kind of problem with a setup for a customer. We have a small server with MS Server 2008 R2 Foundation and some workstations with Win 7 Pro x64/Office 2010 Home & Business on a 1Gbit network. Opening files from server generaly works fine and is fast, but Word and Excel files are slow (20-40 sec)

    We have tried the following without any luck:

    Would realy appreciated more help on this topic and also an official fix from microsoft.

    ______
    SOLVED (we belive)

    Solution:
    Reactivated RDC, auto tuning and indexing

    Manualy disabled SMB 2.0 on Windows 7 client computers:

    in command prompt (as admin):

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    
    and
    
    sc config mrxsmb20 start= disabled

     restarted computer.

     

    • Proposed as answer by DK Tor Monday, December 13, 2010 12:04 PM
    Monday, December 13, 2010 11:37 AM
  • Legend! Cheers for that all working now, was very frustrating..
    Thursday, December 16, 2010 3:02 AM
  • Toggling SMB2 was the first thing we tried. It did not make any difference.

     

    The only thing that helped was turning off Indexing on Offline files. But we need Indexing to work.

    Tuesday, December 21, 2010 5:16 PM
  • We are now testing windows 7 SP1. Apparently KB981711 (included in SP1) resolves this issue.
    Tuesday, January 25, 2011 9:16 PM
  • Yes, KB981711 alone resolves the issue.

     

    • Proposed as answer by HDI Thursday, February 3, 2011 9:54 PM
    • Marked as answer by Alan.Pater Wednesday, February 16, 2011 5:08 PM
    Thursday, February 3, 2011 9:54 PM