none
Custom Task sequence- Interactive logon username RRS feed

  • Question

  • Hi,

    I was using registry to enable the function show last logon username.
    I was able to run manually on the window 7 pc.

    But when i use my task sequence to run it.
    command line i use as: reg.exe import "%SCRIPTROOT%\custom\Interativelogonname.reg"
    Nothing happen..

    My reg file as:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "dontdisplaylastusername"=dword:00000000

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


    Thursday, May 16, 2013 1:25 AM

All replies

  • Try

    regedit.exe /s "%SCRIPTROOT%\custom\Interativelogonname.reg"


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Thursday, May 16, 2013 1:37 AM
  • Hi frank,
    I will try it.
    /S mean?

    Kindly advise as i am not good in script and command.
    Thursday, May 16, 2013 1:53 AM
  • If you only need that one thing set, not sure I'd bother with a .REG file.  You can do the following as a Command step:

    reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DontDisplayLastName /t REG_DWORD /d 0 /f

    Note that 0 is the default value, so you probably only need to set it if something else set it to 1.  See the TechNet article: http://technet.microsoft.com/en-us/library/cc957392.aspx


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, May 16, 2013 2:11 AM
    Answerer
  • /S means silent with no interaction.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Thursday, May 16, 2013 2:22 AM
  • ok. thanks.
    Thursday, May 16, 2013 4:27 AM
  • Thanks for the new command.

    I can saw it was being disable.

    But once i succes deploy my window 7/

    DontDisplaylastname was become 1

    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DontDisplayLastName /t REG_DWORD /d 1 /f

    Any idea on it?

    Thursday, May 16, 2013 4:29 AM
  • Do you have "Apply Local GPO Package" enabled in your Task Sequence?  That enables the setting, if I recall.  Otherwise, it could be coming from regular Group Policy.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, May 16, 2013 4:48 AM
    Answerer
  • Hi.
    ApplyLocalGPOPackage was set disable.

    Even i set in cs.ini

    ApplyGPOPack=No

    But still the same...


    Friday, May 17, 2013 1:03 AM