Set Network Location in a domain not working


  • I am working with Server 2008 R2 / Windows 7 in a domain environment. Each computer has 2 physical NIC's. NIC 1 is connected to the domain, NIC 2 is connected to a test network that does not have access to the domain resources or the internet.The computers also have VMware Player installed. NIC 2 is configured with the VMware Bridge Protocol to allow VM's to access the test network.

        I'm having trouble getting our domain set up to allow Powershell remoting. I have tried configuring a GPO as instructed here:

    which does not work properly. When the GPO did not work, I tried using PSExec to run the powershell.exe "enable-psremoting -force" on the remote computers. What I found out is that the command / GPO do not work since the network locations on one of the NIC's is set to "Public". So, I configured a GPO under:

    Policies > Windows Settings > Security Settings > Network List Manager Policies

    and set the location type to "Private" for each Network Name, including "Identifying Networks" and "All Networks". After a gpupdate on a remote computer, the NIC 2 network is still public. To give a little more details, under 'View your active networks" there are 3 Networks. NIC 1: Domainname.local "Domain network"   NIC 2: Network 2 "Public"   VMNIC: Unidentified network "Work network".

    So, the GPO successfully set the VMNIC network location to Work, but had no effect on NIC 2. On the Network 2 (NIC 2) I can click on "public network" and change it to work. Then the Enable-PSRemoting works. However, I can not manually do this on hundreds of computers. I'm hoping someone has an idea of how to change the network location of NIC 2 on all computers in the domain. Thanks in advance.

    Friday, September 06, 2013 5:18 PM