Current Configuration Manager 2012 capture media proceeds through Sysprep error causing the capture of a non-sysprepped system RRS feed

  • General discussion

  • General: When the Configuration Manager 2012 capture media runs, it does quite a few things, including running sysprep. If sysprep ever encounters an error, the Configuration Manager capture media should not continue with its process of rebooting the system and running the locally copied boot image to begin capturing the system.

    Issue: When the Configuration Manager 2012 capture media runs, it will actually continue with its process even though sysprep logs errors. The capture process proceeds to reboot, run the locally copied boot image and begin capturing a non-sysprepped image. This ultimately causes all sorts of issues during deployment.

    Reproduce: An example to reproduce this issue is caused from Microsoft Security Essentials. During 2012, Microsoft Security Essentials was offered as an optional update. If Microsoft Security Essentials is accidently installed and later uninstalled, it leaves behind a remaining registry value. This value causes sysprep to fail.

    Sysprep Error

    Normally, most people would think this error is caused by no remaining rearms. However, for customers using KMS correctly, rearms are not an issue. When slmgr.vbs /dlv is run, the rearm count still has rearms left.

    While troubleshooting this error further, the C:\Windows\System32\sysprep\Panther\seterr.log file will show the following error:

    Error      [0x0f0085] SYSPRP LaunchDll:Could not load DLL c:\Program Files\Microsoft Security Client\MSESysprep.dll[gle=0x0000007e]

    This error is caused by a remaining registry value left over from the uninstall of Microsoft Security Essentials. The value name is:


    and its value is: c:\Program Files\Microsoft Security Client\MSESysprep.dll,DllSysprep_Cleanup

    In order to delete the registry value, modify permissions to inherit. Then delete the value.

    Afterward, sysprep will successfully run. Now that sysprep is running correctly, the Configuration Manager 2012 capture media will capture a sysprepped system.


    • Edited by jason-ms Thursday, May 31, 2012 6:17 PM
    Thursday, May 31, 2012 4:16 PM

All replies

  • The best way to submit something like this is via Microsoft CSS:

    Jason | | Twitter @JasonSandys

    Thursday, May 31, 2012 6:03 PM
  • The purpose of this post has nothing to do with filing a bug. Until the software is actually fixed, others need to know what is actually happening and how to work around it.


    • Edited by jason-ms Thursday, May 31, 2012 6:27 PM
    Thursday, May 31, 2012 6:09 PM
  • and thank you, you saved my behind tonnes of work
    Wednesday, July 4, 2012 9:04 AM
  • Thank you so much for your info. Your solution solved this issue. 
    Saturday, July 14, 2012 6:32 AM
  • Thanks for providing this information.  It solved my issue with sysprep failing due to remnants of Microsoft Security Essentials being left in the registry.
    Friday, July 20, 2012 6:59 PM
  • Thank you! Thank you! Thank you, thousand times!

    Been pulling my hair out on the sysprep error for days, messing with all the rearm fixes, to no avail.

    Your cure worked first time! I can now have my weekend!

    Friday, November 16, 2012 9:08 PM