locked
Outlook 2010 autodiscover settings combined with automatically detect proxy settings. Does not respect proxy exclusions, never finds cas server RRS feed

  • Question

  • Hello all,

    I currently have the following issue.

    We have upgraded to exchange 2010 in our organization and i'm about to migrate all users across, however we have the issue that we cannot set the out of office and setting up new profiles seems to not work unless we've turned all proxy settings off. I've pinpointed exactly where our issue lies as well. It is the following.

    We use a wpad file for our internet configuration for all clients. this works great, and all exclusions for internal urls are added and work well also. HOWEVER during the outlook 2010 autodiscover process the exclusions are flat out ignored. At NO OTHER TIME are these exclusions ignored, to confirm this, I configured a folder in outlook that points at an internal webserver and opens that page. It works. I can also resolve the urls of the cas.domain.corp and the specific server names.

    To further confirm that my wpad file configuration is OK, I download it to the c: drive. I then point internet explorer at that exact file and then Outlook autodiscover operates completely normally all functions work. I then point internet explorer back at 'automatically detect' or alternatively 'use an automatic configuration script' and the issue is back. Ive even confirmed using wireshark that when autodetect is used, outlook sends all internal server packets externally to our cloud proxy (which should be bypassed with the exclusion list).

    This process is maddening, because I went through about 5 hours of troubleshooting with Microsoft support, exchange support and they concluded that 'it's an IE problem you should call them'. This is preventing us from migrating our entire organization to exchange 2010, so if anyone could help me I'd be eternally greatful.

    versions

    outlook 2010 sp2

    exchange 2010 SP3

    IE 9 or 10 (both versions tested, both versions exhibit same problem)

    Wednesday, November 13, 2013 2:37 PM

Answers

  • I finally got an answer on this issue from Microsoft. The problem was the below

    -------------------------------------------------

    One of the most influencing differences between WinINET (which Internet Explorer uses) and WinHTTP (which Outlook obviously uses) is the missing conversion from upper-case characters to lower-case characters when it comes to the evaluation of a proxy-script (WPAD).

    Therefore the parameters which the script is feed should be converted to lower-case before evaluating them in the script.

    As I've seen in the provided scripts, you use the "url"-parameter in addition to the host-parameter, the following statements should be included in the WPAD.DAT:

    url=url.toLowerCase();

    host=host.toLowerCase();

    This side-effect is also mentioned in the following blog-post:

    http://blogs.technet.com/b/emeaie/archive/2013/11/04/optimizing-performance-with-automatic-proxyconfiguration-scripts-pac.aspx

    -------------------------------------

    This fixed my issue. Hope this helps someone else one day.

    • Proposed as answer by Angela Shi Monday, December 23, 2013 6:59 AM
    • Marked as answer by dogfish Monday, December 23, 2013 8:00 AM
    Wednesday, December 11, 2013 12:16 PM

All replies

  • Hi,

    According to your description, everything works well when you turn all proxy settings off. I think it’s a proxy problem rather than an Exchange problem. Thus, I recommend you ask for more professional help on our Windows server forum :

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserverNIS

    Thanks,

    Angela


    Angela Shi
    TechNet Community Support

    Thursday, November 14, 2013 9:10 AM
  • No this is not a proxy problem. The problem is specifically

    Outlook 2010 SP2 does NOT respect the proxy settings when performing the autodiscovery routine to discover settings from the CAS.

    The problem itself is Outlook, NOT the proxy settings. the proxy settings have been tested and verified over and over for years and the issue only exhibits during outlooks autodiscovery routine, at no other time. Outlook also respects the proxy exclusions at all other times including if I set the exact server that it cannot reach during autodiscovery as a home folder in the outlook folder view.

    Thursday, November 14, 2013 9:40 AM
  • Hi,

    For your concern, we can try to logon through OWA on your local machine and check if the issue still exists.

    Additionally, here is a similar thread:
    http://social.technet.microsoft.com/Forums/exchange/en-US/b52066a9-8e40-4563-95ff-70f281529388/proxy-exclusion-setting-reliability?forum=ieitpropriorver

    Hope it can help you.
    Thanks,
    Angela

     


    Angela Shi
    TechNet Community Support



    • Edited by Angela Shi Tuesday, November 26, 2013 3:09 AM
    Monday, November 18, 2013 1:46 AM
  • the link you posted seems that guy had Exactly the same problem we are having. Unfortuntately the issue was not answered in that thread. an administrator did advise that it should be posted in the exchange forums though so I think I've put my question in the right place.

    We still have the issue and I believe it to be a bug with microsoft outlook ignoring proxy exclusions when using 'automatically detect settings'. 

    that using the same configuration script, if you put it in the 'use automatic configuration script' field, the problem does NOT occur. but this doesn't help us, because we rely on the 'automatically detect' option to ensure clients that travel outside the network can still access internet without attempting to connect to an internal and unavailable proxy.  

    Monday, November 18, 2013 2:29 PM
  • I've now narrowed this problem down to using a pac file that contains 3 lines (one exclusion).

    the autodiscovery procedure from outlook 2010 is surely broken. really not happy that nobody including microsoft has heard of this problem I simply don't understand that our organisation can be the only company to run into it. I have an open support call with them directly and nobody will even address the actual situation, instead preferring to talk around it or 'try clearing the IE cache'.

    Extremely frustrated.

    Friday, November 22, 2013 1:05 PM
  • I'm not sure why my further description of the issue has been marked as an answer. The issue is not answered and it's in exactly the same state as it was. Problem is not resolved.
    Monday, November 25, 2013 8:05 AM
  • I finally got an answer on this issue from Microsoft. The problem was the below

    -------------------------------------------------

    One of the most influencing differences between WinINET (which Internet Explorer uses) and WinHTTP (which Outlook obviously uses) is the missing conversion from upper-case characters to lower-case characters when it comes to the evaluation of a proxy-script (WPAD).

    Therefore the parameters which the script is feed should be converted to lower-case before evaluating them in the script.

    As I've seen in the provided scripts, you use the "url"-parameter in addition to the host-parameter, the following statements should be included in the WPAD.DAT:

    url=url.toLowerCase();

    host=host.toLowerCase();

    This side-effect is also mentioned in the following blog-post:

    http://blogs.technet.com/b/emeaie/archive/2013/11/04/optimizing-performance-with-automatic-proxyconfiguration-scripts-pac.aspx

    -------------------------------------

    This fixed my issue. Hope this helps someone else one day.

    • Proposed as answer by Angela Shi Monday, December 23, 2013 6:59 AM
    • Marked as answer by dogfish Monday, December 23, 2013 8:00 AM
    Wednesday, December 11, 2013 12:16 PM