locked
Server 2012r2 Search Indexing breaks regularly RRS feed

  • Question

  • I've seen several threads about this issue with no satisfactory answer.  We have three Server 2012r2 fileservers with search indexing enabled.  Regularly (at least once a week), the index seems to become corrupted - users get search results that are out of date and can't be clicked on (file names are returned without locations, icons are all plain white, etc). We have two short-term fixes: 1) Shut down the search service, defrag the search file, and restart the search service and 2) rebuild the entire index.  

    #1 takes anywhere from 15 min to an hour - it was suggested as a fix to a different indexing issue (where the file would grow to enormous size) but also seems to fix this, occasionally.

    When #1 doesn't work, we do #2 which can take up to 12 hours.

    This happens on 3 distinct 2012r2 servers in 3 separate domains, so we know it's not an isolated issue.  Nothing in the event viewer about the search service crashing or otherwise failing, and when I check the service is up and running despite the results being corrupt.  When the corruption is occurring, sometimes the indexed locations show properly in the indexing options on the FS, sometimes they don't show at all.

    Any suggestions would be appreciated!

    Monday, March 28, 2016 9:34 PM

All replies

  • Hi CTDHelpdesk,

    Thanks for your post.

    I have also seen the problem before, and have to say that it is pretty weird. I'm afraid it is difficult to reproduce the issue and analyze. Since in my test, I have to say temporarily it works fine. And even in your scenairo, it doesn't broke immediately. It seems to be no regular, not exact what time, right? But it's often in your scenairo, right?

    As you said, it even doesn't show any error. I'm afraid that you might need to troubleshoot with the general steps to have a try.

    Run sfc /scannow to check if there is any corruption of system files.

    Disable the 3rd party application link AV software to have a check.

    If possible, reinstall Windows Search Service and recreate the index and try again.

    If it still doesn't work, you might try to reset Windows Search to Defaults and restart the computer to rebuild new index.

    https://blogs.technet.microsoft.com/fixit4me/2009/04/24/reset-windows-search-to-defaults/

    For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft Knowledge Base:

    https://technet.microsoft.com/en-us/library/cc758453(v=ws.10).aspx

    Thanks for your support and understanding.

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    • Edited by Mary Dong Tuesday, March 29, 2016 2:44 AM
    • Proposed as answer by Mary Dong Tuesday, April 5, 2016 9:19 AM
    • Marked as answer by Mary Dong Wednesday, April 6, 2016 9:18 AM
    • Unmarked as answer by CTDHelpdesk Wednesday, April 6, 2016 4:30 PM
    Tuesday, March 29, 2016 2:42 AM
  • The standard SFC /scannow reports no issues on any of the servers affected.  No third party AV on the machines.  I've rebuilt the index on multiple occasions, and I don't think reinstalling the search service will do anything as it's not an issue of it just occurring on one machine.

    I've reset windows search to default, but then I have to go back through and select the indexed locations - these are file servers and we need to select manually what's indexed and what isn't, as well as where the very large indices live.

    Still no resolution - at this point we'll try rebuilding when the next CU comes out.

    Wednesday, April 6, 2016 4:30 PM
  • Hi

    We have exactly the same problem (search result white icons, not clickable, not useable).

    The situation seems to be nearly the same: Server2012r2, custom indexing locations, changed index file location to a custom drive because of the index size.

    When indexing is complete it reports about 600.000 indexed items.

    We have not tried to defrag the file yet, but we always rebuild the index. It works afterwards, but that consumes much time.

    Additionally, it seems only to occur when the index service says indexing is complete. But it is hard to define that. Sometimes it works for weeks, sometimes we have to rebuild twice a day!

    Any solution for that?? 

    Friday, June 24, 2016 9:18 AM
  • We have the same problem with 2012 R2 RDS. Windows Search breaks constantly. We setup a scheduled task to run every morning at 1am to reindex everything everyday because of this.
    Monday, January 8, 2018 6:12 PM
  • scheduled task prepares only file index. Outlook index cannot start until user open outlook.
    Friday, May 10, 2019 8:32 PM