locked
Windows Server 2016 Preview 3 in Azure: Install ADFS RRS feed

  • Question

  • Hello,

    I am struggling trying to add a new features to my Azure VM with Windows Server 2016 Preview 3, particularly ADFS.

    The problem is installation media location - default location seems to be unavailable.

    So I downloaded ISO from MSDN but so far was unable to use it. I tried both specifying WIM location in wizard and the Power Shell command:

    Install-windowsfeature adfs-federation -IncludeManagementTools -Source wim:F:\sources\install.wim:4 returns

    error - see below.

    Please advise,

    Tomasz

    Install-windowsfeature : The request to add or remove features on the specified server failed.
    Installation of one or more roles, role services, or features failed. Error: 0x800f0922
    At line:1 char:1
    + Install-windowsfeature adfs-federation -IncludeManagementTools -Sourc ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
        Exception
        + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
       owsFeatureCommand


    • Moved by BrianEhMVP Friday, October 23, 2015 2:29 PM
    • Edited by Thomas D J Tuesday, October 27, 2015 9:35 AM
    Friday, October 23, 2015 1:46 PM

Answers

  • Hi Thomas D J,

    This error most times occur when some system module corruption, please try to download a new image and try again.

    More related information:

    Guidelines for Deploying Windows Server Active Directory on Azure Virtual Machines

    https://msdn.microsoft.com/en-us/library/azure/jj156090.aspx#BKMK_WhyADFS

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    • Marked as answer by Jessicu Thursday, November 12, 2015 2:09 PM
    Friday, October 30, 2015 7:33 AM

All replies

  • Hi Thomas D J,

    This error most times occur when some system module corruption, please try to download a new image and try again.

    More related information:

    Guidelines for Deploying Windows Server Active Directory on Azure Virtual Machines

    https://msdn.microsoft.com/en-us/library/azure/jj156090.aspx#BKMK_WhyADFS

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    • Marked as answer by Jessicu Thursday, November 12, 2015 2:09 PM
    Friday, October 30, 2015 7:33 AM
  • Hi Alex,

    it seems the problem has been corrected. I provisioned a new VM and Roles/Features management works fine - I was able to install ADFS.

    However, I suppose something still is not right. I joined the domain (DC on another VM via Virtual Network) and tried to set up ADFS - just a plain initial configuration with a new gMSA following this post by Vittorio Bertocci:
    http://www.cloudidentity.com/blog/2015/08/21/openid-connect-web-sign-on-with-adfs-in-windows-server-2016-tp3/

    No matter what, all the configured endpoints respond with http error 503 - service unavailable.

    Any clues? Thank you,

    Tomasz


    • Edited by Thomas D J Tuesday, November 3, 2015 1:31 PM
    Friday, October 30, 2015 11:59 AM