none
Hours per Day in PWA RRS feed

  • Question

  • Hello,

    So, I'm using Project Server 2013, and I have my standard enterprise calendar customized with a work day of 7 hours. When I create a new project in PWA, specifying a value of "1d" in the duration field for any task, would translate to "8" hours, and thus, the task would actually finish on the next day. How is it possible to tell PWA what is the correct "hours per day" to use.

    I know how  do this in Project Professional (File->Options->etc), but how to do the same for PWA?

    Appreciate your input on this.

    Thanks.

    Thursday, July 11, 2013 11:27 PM

Answers

  • Hi,

    you need to change "hours per day" in template you are using for this ETP. If you have no template assigned, you need to change hours per day setting in Enterprise Global. Settings of Enterprise Global are used, if you create a project in PWA without any template.

    I am not sure, but it may be, that you need to change hours per day for each project in client, you created before changing EGlobal. I have not tried that so far.

    Regards
    Barbara

    • Marked as answer by Samer_Meqdad Friday, July 12, 2013 2:46 PM
    Friday, July 12, 2013 6:48 AM
    Moderator

All replies

  • Hi,

    you need to change "hours per day" in template you are using for this ETP. If you have no template assigned, you need to change hours per day setting in Enterprise Global. Settings of Enterprise Global are used, if you create a project in PWA without any template.

    I am not sure, but it may be, that you need to change hours per day for each project in client, you created before changing EGlobal. I have not tried that so far.

    Regards
    Barbara

    • Marked as answer by Samer_Meqdad Friday, July 12, 2013 2:46 PM
    Friday, July 12, 2013 6:48 AM
    Moderator
  • Hello Barbara,

    My understanding is that the EGlobal defines the standard settings for Project Professional, and wouldn't have any effect on the Schedule WebPart in PWA.

    Friday, July 12, 2013 9:29 AM
  • Just try - I did before writing my response. It DOES affect projects created from PWA.

    Regards
    Barbara

    Friday, July 12, 2013 9:38 AM
    Moderator
  • Just to make sure I understood you correctly, when you say set the "hours per day" in the EGlobal. You're referring to setting the value through File->Options->Scheduling (as in the screen below)?

    I tried it, saved and checked in the EGlobal, created a new project on PWA, and when entering tasks on the new project plan on PWA, I'm still getting the same result.

    Regards,

    Samer 

    Friday, July 12, 2013 12:52 PM
  • Hi Samer,

    I see 8hrs/day and 40hrs/week in your screenshot.But you where initially talking about 7hrs/day (and presumable 35hrs/week). Did you creat screenshot before making the change?

    What I did:

    • Changed calendar Standard - Work weeks - 8-12, 13-16 (just for this quicke test)
    • Opened Enterprise Global and changed hours per day to seven and hours per week to 35. Saved the global.
    • Created a new project from PWA, added a tem member, created a task and assigned team member. I see a duration of one day, same start and finish date and 7 hours of work.

    What are we doing different?
    Barbara



    Friday, July 12, 2013 1:42 PM
    Moderator
  • True Barbara, the screenshot was made before making the change.

    My question is, on your plan, if you enter a value of 1d under the duration column for this task (I'm not seeing this on your screenshot), what is the value of Work/End Date, PWA is calculating? 

    I'm following your steps, but the problem I'm facing is that if I enter "1d", the Work will still be "8h".

    Thanks a lot for your help :)

    Friday, July 12, 2013 2:05 PM
  • It as as expected:

    Standard Calendar from server:

    Option settings in next post.

    Friday, July 12, 2013 2:19 PM
    Moderator
  • Data are consistent on my system. Did you create a new project after changing options in EGlobal?

    Regards
    Barbara

    Friday, July 12, 2013 2:20 PM
    Moderator
  • I'll repeat the steps again.

    And again, just to double check, you're creating the project from PWA (and not using Professional at all) for adding the tasks to the plan, right?

    Friday, July 12, 2013 2:38 PM
  • It's working now, just followed your steps again.  Thanks a million.

    Friday, July 12, 2013 2:46 PM