Windows XP RDP Audio Redirection disable RRS feed

  • Question

  • I have some Windows XP computers which requires audio input/output through a specialized card. When I use remote desktop to log into these systems, the audio driver gets replaced with the Microsoft RDP Audio Driver. This disables my product from working since it now has no audio driver. Below is a list of things I have tried to disable remote redirection of audio:

     Remote Desktop Client:

    Changed the "Remote computer sound" setting on Remote Desktop client to "Leave at remote computer".  This does work, however, I need to disable this on the server so this doesn't get accidentally changed.

    Group Policy:

    Changed the group policy setting, "Allow audio redirection" to "Disabled". I ran MMC.exe (Microsoft management Console), "Add/Remove Snap-in", Add..., "Group Policy Object Editor". Then to "Computer Configuration", "Administrative Templates", "Windows Components", "Terminal Services", "Client/Server data redirection", "Allow audio redirection" and set that to Disabled. This did not work. It did disable the audio from being heard on the remote PC, but the Microsoft RDP Audio Driver still replaced my original audio driver when "Bring to this computer" was selected in the remote desktop settings.

    Also is there a way to set the configuration on the default.rdp file for new user profiles? (i.e. when a new user logs in to the computer, a desired RDP client settings will be applied) 

    Thank You,

    Steven Siu

    Friday, June 10, 2011 4:08 PM