locked
Server 2012 R2 Error 800B0001 RRS feed

  • Question

  • We have a Server 2008 R2 Hyper-V environment running a Server 2008 R2 VM hosting WSUS. We have two new Exchange servers (both 2012 R2) where one is currently our primary Exchange server and the other is a DAG member for replication purposes.

    I have tried adding WSUS support for our Windows Server 2012 R2 machines, as both are not able to search for or install updates. Each are displaying, "Not Yet Reported" statuses in WSUS and failing with Windows Update error code of 800B0001. 

    Searching various forum posts, the general recommendation is to install WSUS-KB2720211-X64 and WSUS-KB2734608-X64 to add support for 2012 R2/8.1 in WSUS. Patch: WSUS-KB2720211-X64 is already installed, but the KB2734608 patch fails.

    Here are the steps I followed:

    1. Snapshot SGPY-Services02 for a fall-back point.
    2. Stoped AV suite.
    3. Stopped IIS and WSUS services with the following commands:
    iisreset /stop
    net stop wsusservice
    4. Disabled IIS and WSUS services:
    sc config wsusservice start= disabled
    sc config w3svc start= disabled
    5. Via elevated cmd, navigated to the install path and executed the KB2734608-x64.exe patch installation. (It fails to install at this step with error: "Windows Server Update Services 3.0 SP2 Setup failed.")

    Continuing after failure to test if WSUS/MMC became corrupt as others mentioned:
    6. Enabled IIS and WSUS services
    sc config wsusservice start= auto
    sc config w3svc start= auto
    7. Started IIS and WSUS services:
    iisreset
    net start wsusservice
    WSUS fails and throws error: "MMC cannot initialize the snap-in."

    On the Windows Server 2012 R2 hosts, I also tried cleaning up the SoftwareDistribution folders for Windows Update, thinking this may help. (Before and after installing the above mentioned patch.)
    1. Launched elevated cmd prompt.
    2. Executed the following;
    net stop wuauserv
    rd /q /s c:\Windows\SoftwareDistribution
    net start wuauserv

    No change... both Windows Server 2012 R2 VMs show WSUS status of: "Not Yet Reported".

    I then rolled back to snapshot and tested MMC/WSUS behavior. The WSUS-KB2720211-X64 patch is still currently installed, and WSUS-KB2734608-X64 has not been applied successfully.

    We need a resolution fairly soon, but any help you can provide is much appreciated. Thanks in advance,

    Monday, November 23, 2015 6:13 PM

Answers

  • Hi,

    To update your WSUS server to the latest version, please try to install the KB2938066 on your WSUS server.

    WSUS 3.0 (SP2):     Build 3.2.7600.226
    WSUS 3.0 (SP2) + KB2720211:     Build 3.2.7600.251
    WSUS 3.0 (SP2) + KB2734608:     Build 3.2.7600.256
    WSUS 3.0 (SP2) + KB2828185:     Build 3.2.7600.262
    WSUS 3.0 (SP2) + KB2938066:     Build 3.2.7600.274

    Note: After applying the KB2938066, please do not forget to clean up the SoftwareDistribution folders on all clients.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steven_Lee0510 Tuesday, December 8, 2015 2:45 PM
    • Marked as answer by Steven_Lee0510 Wednesday, December 9, 2015 12:17 PM
    Tuesday, November 24, 2015 9:04 AM