none
Problem after domain renaming RRS feed

  • Question

  • Dear all,

    After domain renaming, I just can access Sharepoint 2010 Central Administration and run Configuration Wizard.

    When I enter the project web application. It says access denied. I'm farm administrator.

    Help me please.

    Monday, June 11, 2012 4:42 AM

Answers

  • Hi there--

    PWA-Project Server users are stored in Project server database & I believe that the Farm admin & other users are having the old domain name so no PWA user can access the pwa site.
    Could you please verify the login name from database using the query:

    SELECT RES_NAME, WRES_ACCount 
    FROM MSP_RESOURCES

    Verify the WRES_ACCOUNT for the farm admin & see what exactly you are using while login in to PWA.

    Please look at the Brian's article:
    http://blogs.msdn.com/b/brismith/archive/2009/06/22/project-server-2007-migration-from-one-domain-to-another.aspx

    If you see the WRES_ACCOUNT is not matching. You may need to update the user as explained in article.

    Please let us know the result. We'll try to help.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:35 AM
    Tuesday, June 12, 2012 4:53 AM
  • Great!! so did you update the account of Farm admin using the SQL script?

    You can checkout all resources (using select all option on Grid header first column for Open Menu option) from PWA> Resourc center & open in MS project (Open button from ribbon). Once all the resources are open in MS project, you can save & wait for the Resource sync job in Manage queue of PWA to complete the action.

    Hope this helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82


    Tuesday, June 12, 2012 10:04 AM
  • If you mean that you have three PWA sites. Yes, You will need to open the resource using the MS project connecting from each PWA instance & save the resources.

    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:35 AM
    Tuesday, June 12, 2012 10:21 AM
  • Great!! Glad to hear that I was able to help.

    Please see Brian's excellent article:
    http://blogs.msdn.com/b/brismith/archive/2007/02/28/my-queue-is-stuck-how-to-manage-your-queue-service-in-project-server-2007.aspx
    In manage queue "Waiting to be processed" - means exactly what it says.  Once I get to the front of the queue then I am ready to go.  But there may be other active jobs ahead that will stop my job starting even if I am first in line.  The queue is clever enough that it will hold jobs back if their processing would interfere with other running jobs.  An example might be a publish job that will need to wait for a cube build to finish.

    Are you able to cancel the job & verify the force checkin job is also successful. You may again the same project& publish it.

    Please let us know the result, we'll try to help.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:56 AM
    Wednesday, June 13, 2012 8:45 AM

All replies

  • Hi there--

    Sounds like you have updated the domain but the user are not migrated to new domain that's why you are getting the access denied. I suggest you read this: http://support.microsoft.com/kb/896593/en-us & http://technet.microsoft.com/en-us/library/cc262141(office.12).aspx  it is published in 2007 but it works with in 2010, this command will help you migrate users as well as keeping there settings.

    e.g 
    stsadm.exe -o migrateuser -oldlogin DomainA\user1 -newlogin DomainB\user1 -ignoresidhistory

    Hope this helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Monday, June 11, 2012 5:21 AM
  • Hi,

    Either you do migration of the Users domain or you can move other domain in the trusted Zone of the domain in which CA is running.


    kirtesh

    Monday, June 11, 2012 11:12 AM
  • Hi there--

    Sounds like you have updated the domain but the user are not migrated to new domain that's why you are getting the access denied. I suggest you read this: http://support.microsoft.com/kb/896593/en-us & http://technet.microsoft.com/en-us/library/cc262141(office.12).aspx  it is published in 2007 but it works with in 2010, this command will help you migrate users as well as keeping there settings.

    e.g 
    stsadm.exe -o migrateuser -oldlogin DomainA\user1 -newlogin DomainB\user1 -ignoresidhistory

    Hope this helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare8

    Dear Amit,

    My Sharepoint server and other sites work well.

    Just project server PWA has problem after rename domain.

    It say "Access denied" even if with farm Administrator.

    I did the migration that you recommended, but there is no change.

    What should I do now?


    • Edited by DoLeVu Tuesday, June 12, 2012 4:52 AM
    Tuesday, June 12, 2012 4:38 AM
  • Hi there--

    PWA-Project Server users are stored in Project server database & I believe that the Farm admin & other users are having the old domain name so no PWA user can access the pwa site.
    Could you please verify the login name from database using the query:

    SELECT RES_NAME, WRES_ACCount 
    FROM MSP_RESOURCES

    Verify the WRES_ACCOUNT for the farm admin & see what exactly you are using while login in to PWA.

    Please look at the Brian's article:
    http://blogs.msdn.com/b/brismith/archive/2009/06/22/project-server-2007-migration-from-one-domain-to-another.aspx

    If you see the WRES_ACCOUNT is not matching. You may need to update the user as explained in article.

    Please let us know the result. We'll try to help.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:35 AM
    Tuesday, June 12, 2012 4:53 AM
  • Dear Amit,

    I've updated the RES_NAME from MSP_RESOURCES. And now I can login with Administrator account

    I can do almost everything with Administrator account: create new, assign resource, publish, checkin.... But I cannot edit the old project, I cannot publish it.

    And all other accounts when login, it says "Access denied"

    Tuesday, June 12, 2012 9:31 AM
  • Dear Amit,

    When I go to Manager Users in Server Settings and Click on the User, then don't change any thing, and then Save.
    The user can now login to Project server, and can do the work.

    I have about 300 users, how can I do it faster?
    Tuesday, June 12, 2012 9:40 AM
  • Great!! so did you update the account of Farm admin using the SQL script?

    You can checkout all resources (using select all option on Grid header first column for Open Menu option) from PWA> Resourc center & open in MS project (Open button from ribbon). Once all the resources are open in MS project, you can save & wait for the Resource sync job in Manage queue of PWA to complete the action.

    Hope this helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82


    Tuesday, June 12, 2012 10:04 AM
  • And another problem, I have 3 project site, 1 for work, 1 for test, 1 for training.

    Now I have to open each user one time, then save. And have to do it in all 3 project sites.

    Is there any better way to do it.

    Please help.

    Tuesday, June 12, 2012 10:09 AM
  • If you mean that you have three PWA sites. Yes, You will need to open the resource using the MS project connecting from each PWA instance & save the resources.

    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:35 AM
    Tuesday, June 12, 2012 10:21 AM
  • Thanks very much, Amit.

    Now all my Project server PWA work well.

    But I have one project is checked out, and I when I force check-in it, nothing happens. Just one project, others work well.

    The Job state is "Waiting To Be Processed"

    When I go to my queued job, it shows 0% completion.

    And I cannot run farm configuration wizard from Sharepoint Central Administration.

    When I check "Review job definition" from Monitoring, this show the Farm Configuration ... never run. I've waited 24 hours, but it doesn't run.


    • Edited by DoLeVu Wednesday, June 13, 2012 8:44 AM
    Wednesday, June 13, 2012 8:38 AM
  • Great!! so did you update the account of Farm admin using the SQL script?

    You can checkout all resources (using select all option on Grid header first column for Open Menu option) from PWA> Resourc center & open in MS project (Open button from ribbon). Once all the resources are open in MS project, you can save & wait for the Resource sync job in Manage queue of PWA to complete the action.

    Hope this helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82


    Yes, after update the resource name in database as you recommended, and update all table MSP_WEB_ADMIN*. I can use the Administrator account
    Wednesday, June 13, 2012 8:41 AM
  • Great!! Glad to hear that I was able to help.

    Please see Brian's excellent article:
    http://blogs.msdn.com/b/brismith/archive/2007/02/28/my-queue-is-stuck-how-to-manage-your-queue-service-in-project-server-2007.aspx
    In manage queue "Waiting to be processed" - means exactly what it says.  Once I get to the front of the queue then I am ready to go.  But there may be other active jobs ahead that will stop my job starting even if I am first in line.  The queue is clever enough that it will hold jobs back if their processing would interfere with other running jobs.  An example might be a publish job that will need to wait for a cube build to finish.

    Are you able to cancel the job & verify the force checkin job is also successful. You may again the same project& publish it.

    Please let us know the result, we'll try to help.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by DoLeVu Wednesday, June 13, 2012 8:56 AM
    Wednesday, June 13, 2012 8:45 AM
  • Thanks very much, Amit.

    I canceled it in Server setting --> Manage Queued jobs. Then force check-in it again successfully.

    And how about the farm configuration wizard? It doesn't run even after 24 hours.

    Wednesday, June 13, 2012 8:58 AM
  • Hi there--

    I am sorry that I couldn't see the next question "And I cannot run farm configuration wizard from Sharepoint Central Administration"
    What is the error in ULS logs? Please provide more details.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Wednesday, June 13, 2012 9:18 AM
  • Dear Amit,

    I used ULS viewer to capture real time ULS logs. But there's nothing.

    When I go to Monitoring --> Review job definition --> Farm Configuration Wizard --> Job Properties: Web appliaction: N/A, Last run time: N/A.

    I guess that the farm configuration wizard has never really run.

    Another information: my server backup and restore job doesn't run too. But I can use power shell script to run backup and restore job.

    How can I run farm  configuration wizard by power shell script?

    Thanks very much.


    • Edited by DoLeVu Wednesday, June 13, 2012 9:31 AM
    Wednesday, June 13, 2012 9:30 AM