locked
Roles/Features will not load, shows error RRS feed

  • Question

  • System Update Readiness Tool outputs the following, thanks:

    Checking System Update Readiness.
    Binary Version 6.0.6002.22285
    Package Version 7.0
    2010-04-15 13:33

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages
    (f)    CBS MUM Missing    0x00000002    servicing\Packages\Package_for_KB974455_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum       
    (f)    CBS MUM Missing    0x00000002    servicing\Packages\Package_for_KB974455_server~31bf3856ad364e35~amd64~~6.0.1.0.mum       
    (f)    CBS MUM Missing    0x00000002    servicing\Packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum       

    Checking Component Store
    (fix)    CSI SP File Not Yet Pre-Installed    CSI File Replaced    File: wsus31rmt.CHM From: C:\Windows\winsxs\amd64_server-help-chm.wsus31rmt.resources_31bf3856ad364e35_6.0.6001.18078_en-us_d95990c04786c134\wsus31rmt.CHM
    (f)    CSI SP File Not Yet Pre-Installed    0x00000000    wsus31rmt.CHM    amd64_server-help-chm.wsus31rmt.resources_31bf3856ad364e35_6.0.6002.18005_en-us_db88b6f04476fe31   
    (f)    CSI F Mark Missing    0x00000002    f!wsus31rmt.chm    amd64_server-help-chm.wsus31rmt.resources_31bf3856ad364e35_6.0.6002.18005_en-us_db88b6f04476fe31   
    (fix)    CSI F Mark Missing    CSI Registry Item Repaired    Wrote amd64_server-help-chm.wsus31rmt.resources_31bf3856ad364e35_6.0.6002.18005_en-us_db88b6f04476fe31\f!wsus31rmt.chm: wsus31rmt.CHM

    Summary:
    Seconds executed: 1816
     Found 5 errors
     Fixed 2 errors
      CSI F Mark Missing Total count: 1
      Fixed: CSI F Mark Missing.  Total count: 1
      CBS MUM Missing Total count: 3
      CSI SP File Not Yet Pre-Installed Total count: 1
      Fixed: CSI SP File Not Yet Pre-Installed.  Total count: 1

    Unavailable repair files:
        servicing\packages\Package_for_KB974455_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
        servicing\packages\Package_for_KB974455_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
        servicing\packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum
        servicing\packages\Package_for_KB974455_server_0~31bf3856ad364e35~amd64~~6.0.1.0.cat
        servicing\packages\Package_for_KB974455_server~31bf3856ad364e35~amd64~~6.0.1.0.cat
        servicing\packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.cat

    Thursday, April 15, 2010 1:34 PM

Answers

  • All seems fixed by doing the following instructions from:http://blog.nenoloje.com/2009/08/cannot-install-windows-server-2008.html

     

    Download KB974455

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0111d741-bda4-4a50-a12b-d3337ff4441d

     

    Extract files from the msu using the command "Expand -F", then using the update.mum/update.cab files and renaming them to the missing files reported by the system readiness tool, then moving them into the servicing/packages folder.

    • Proposed as answer by CBMFrank Tuesday, April 20, 2010 4:24 PM
    • Marked as answer by Chris5287s Tuesday, April 20, 2010 5:35 PM
    Tuesday, April 20, 2010 1:23 PM

All replies

  • Look at this thread:

    http://social.technet.microsoft.com/Forums/en-GB/winservermanager/thread/6d93f253-bdfe-44b5-b742-3f9e3b82f628

     


    Santhosh Sivarajan | MCTS, MCSE (W2K3/W2K/NT4), MCSA (W2K3/W2K/MSG), CCNA, Network+ Houston, TX http://blogs.sivarajan.com/ http://publications.sivarajan.com/ This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 15, 2010 2:08 PM
  • I've tried that but it says "There are no files available to download."
    Thursday, April 15, 2010 2:49 PM
  • I need this file too.  All the download links that have been posted previously are dead. 

     

    You can find the first four files from the Windows6.0-KB974455-x64.msu.

    servicing\packages\Package_for_KB974455_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

    servicing\packages\Package_for_KB974455_server~31bf3856ad364e35~amd64~~6.0.1.0.mum

    servicing\packages\Package_for_KB974455_server_0~31bf3856ad364e35~amd64~~6.0.1.0.cat
    servicing\packages\Package_for_KB974455_server~31bf3856ad364e35~amd64~~6.0.1.0.cat

     

    The last two below can't be found.

    servicing\packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum
       
    servicing\packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.cat

     

    It would be a really big help if someone can post this.  Thanks.

    Thursday, April 15, 2010 10:08 PM
  • Hi,

     

    I suggest downloading the fix.zip file from the following site, extract it and then copy the files to C:\Windows\servicing\Packages to replace the old files.

     

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=9cd9c69a-e721-402f-a813-8fb976c1c564

    Password: ]SK)DwDVs3qdr

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Friday, April 16, 2010 7:30 AM
  • Thanks for the files, System Readiness Tool is no longer complaining about those files, but Roles/Features is still not working. Event View shows this if this helps:

    Could not discover the state of the system. An unexpected exception was found:
    System.Runtime.InteropServices.COMException (0x800B0100): No signature was present in the subject. (Exception from HRESULT: 0x800B0100)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
       at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
       at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
       at Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection documents)
       at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

    In the mean time, is there any way of getting the server to allow me to install a certificate authority, as i've tried to do it by command line using server manager but that just errors out as well.

    Friday, April 16, 2010 10:08 AM
  • I tell a lie, it helps if I check the log file correctly! it still reporting a file missing, see below:

    Checking Packages
    (f)    CBS MUM Missing    0x00000002    servicing\Packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum

    Friday, April 16, 2010 3:23 PM
  • Yes same here...the fix.zip had all the files except that one.  Would really appreciate posting this for us.  Thank you.

     

    Friday, April 16, 2010 3:36 PM
  • Hi,

    Are you running Windows server 2008 SP2 or R2?

    Are you running IE 7 or IE 8?

    Tim Quan - MSFT

     

     

    Monday, April 19, 2010 3:46 AM
  • Its a Windows Server Standard 2008 with SP1 and IE8. I've tried updating to SP2 but it fails to install due to the System Readiness Tool failing.
    Monday, April 19, 2010 1:18 PM
  • Same for me.  W2008 SP1 (NOT R2) with IE8.  And like Cris5287, my SP2 fails to install also.  But it looks like if we get this last file, it should resolve this.
    Monday, April 19, 2010 2:33 PM
  • Hi,

     

    Thank you for the reply.

     

    I extracted the package but could not find the files you mentioned. Anyway, please download the zip file from the following site, extract it and then copy the files to C:\Windows\servicing\Packages to replace the old files.

     

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=e34c0dd8-fd59-4788-ba84-777250a840ca

    Password: ]vUgx-]HDP

     

    Hope it helps.

     

    Tim Quan - MSFT

    Tuesday, April 20, 2010 4:23 AM
  • Mr Quan,

     

    There is no file in that link.  It says There are no files available to download.

     

    Does this new zip file have the file Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum?

     

    Thanks

    CF

    Tuesday, April 20, 2010 5:39 AM
  • Hi,

     

    Please try again.

     

    This zip file does not include this file. However, a customer encountered the same issue before (missing this file). After he copied all the file in the zip file, his issue has been resolved. So I suggest having a try.

     

    Tim Quan - MSFT

     

    Tuesday, April 20, 2010 6:30 AM
  • Thanks for the zip, i've copied the files over to servicing/packages and will re-run the system readiness tool. Will let you know what the outcome is. I've tried server manager but this is still reporting the error. (Would I need to restart for it to recognise these files?)
    Tuesday, April 20, 2010 7:52 AM
  • Readiness Tool still fails with:

    Checking Packages
    (f)    CBS MUM Missing    0x00000002    servicing\Packages\Package_for_KB974455~31bf3856ad364e35~amd64~~6.0.1.0.mum   

    :(

    Tuesday, April 20, 2010 8:18 AM
  • After reading forums i've tried running "sfc /scannow" which dumps errors out to the CBS.log. The only error I can find in there that it hasn't repaired is:

    2010-04-20 09:23:22, Info                  CSI    00000122 [SR] Cannot repair member file [l:32{16}]"scwvariables.xml" of Microsoft-Windows-Security-Configuration-Wizard, Version = 6.0.6001.18000, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

    Is this any help?

    Tuesday, April 20, 2010 8:44 AM
  • All seems fixed by doing the following instructions from:http://blog.nenoloje.com/2009/08/cannot-install-windows-server-2008.html

     

    Download KB974455

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0111d741-bda4-4a50-a12b-d3337ff4441d

     

    Extract files from the msu using the command "Expand -F", then using the update.mum/update.cab files and renaming them to the missing files reported by the system readiness tool, then moving them into the servicing/packages folder.

    • Proposed as answer by CBMFrank Tuesday, April 20, 2010 4:24 PM
    • Marked as answer by Chris5287s Tuesday, April 20, 2010 5:35 PM
    Tuesday, April 20, 2010 1:23 PM
  • Thanks Chris.  That fixed it for me too.
    Tuesday, April 20, 2010 4:24 PM
  • Thanks to Tim Quan for his help!
    Tuesday, April 20, 2010 5:34 PM
  • Glad you resolved this issue
    Thursday, April 22, 2010 1:52 AM
  • Getting the same problem here but I cannot find the appropriate files as the kb is different

    KB2744842 amd 9.1.1.0.mum

    any help would be nice.

    Wednesday, December 18, 2013 11:14 PM