none
Setting the Windows Explorer default folder view in Windows 7 RRS feed

  • Question

  • Setting the Windows Explorer default folder view in Windows 7

    After being frustrated by this for years I think I might have fixed it. I installed a new version of Win 7 on my desktop, set the folder views like I like them and they stayed that way. I’ve rebooted about 15 times since and they are still like I set them!

    But my laptop which I use most keeps switching them back to how it wants it every time I reboot and sometimes just after a few hours…it resets them. You know how aggravating this is. So I looked online again like I’d done for years with no avail and one guy pointed to a location in the registry that he thought that this adjustment was located: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer.

    So I looked at this location on my laptop and on my newer version of windows on my desktop, which has minimal programs loaded on it. On my desktop there is a folder called “MenuOrder” in this “Explorer” folder which my laptop doesn’t have. And on my laptop there is a folder called “Folder Types” that my desktop doesn’t have.

    On my laptop, the one where the menus keep changing, there are 4 folders in this “Folder Types” folder. Each with a long name of just numbers and letters. So I set a restore point and have a backup of my hard drive, I exported the “Folder Types” folder to a location on my hard drive, after I took a screenshot (photo) of the registry. Then I deleted the “Folder Types” folder and rebooted.

    It took longer to reboot than usual. But when I opened up Windows Explorer it was just like I left it, just like I wanted it. I so rebooted a couple of more times and it would hang a bit and take longer than usual to boot back up, but my folders view was like I left them and like I wanted them. So I went back into the registry and created another “Folder Types” folder in there, an empty one, and it rebooted normally and my folder options now stay put just like I like them!

    To create the new folder in the “Explorer” folder in the registry, do just like you were creating a new folder in Windows Explorer. Right click on the “Explorer” folder and choose New > Key and name it “Folder Types”. On the right side in this new folder an entry will appear, I left it alone. Or if you have this folder already, delete the folders underneath it. You may want to do this one at a time and reboot and check after each one.

    I don’t know why the newer version of Win 7 doesn’t have the “Folder Types” folder at this location in the registry but does have a folder called “MenuOrder”. But clearing out the “Folder Types” folder seems to have solved this aggravating problem for me. I hope this helps you!
    Monday, January 16, 2017 7:35 PM

All replies

  • Hi MaxLiberte,

    Glad to hear that you have found a solution and thank you for sharing it here, it will be helpful to other community members who have same questions.

    Best regards,

    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 17, 2017 2:31 AM
    Moderator