none
Error: You do have permission to access this device RRS feed

  • Question

  • When I connect my iPhone, it is getting charged but when I try accessing the photos folder in explorer window, i am getting an error says "You do not have permission to access this device". I tried modifying the below settings to 3 or 4.
    • Hive : HKEY_LOCAL_MACHINE
    • Key path : SYSTEM\CurrentControlSet\Services\UsbStor

    But it doesn't helps. It is working good in other systems. do let me know your thoughts on this


    Saturday, January 4, 2014 7:45 PM

All replies

  • try to uninstall Mobile Device USB Driver frm device manger, scan the h/d changes for driver installation and thn check it again
    Saturday, January 4, 2014 8:30 PM
  • Hi,

    Download and install the latest version of iTunes from www.itunes.com/download.
    Uninstall Mobile Device USB Driver from device manger, and then connect iPhone to a USB port on your PC using the cable that came with the iPhone.

    Thanks!


    Andy Altmann
    TechNet Community Support

    Tuesday, January 7, 2014 5:38 AM
    Moderator
  • I tried uninstalling the usb drivers and when I connected the mobile, It reinstalled the drivers. eventhough it is not working
    Tuesday, January 7, 2014 5:50 AM
  • I had tried these methods,but no help!! thanks for ur reply
    Tuesday, January 7, 2014 5:50 AM
  • are you admin of the pc ? seems issue with the rights
    Wednesday, January 8, 2014 12:44 PM
  • On Windows 10, I had a similar situation. I was, previously, able to get the pictures from iPhone 4 using Windows explorer. Suddenly, I started getting the permissions error. All I did was: uninstall Apple iPhone device from device manager > Portable devices. Reconnect the iPhone and it worked.
    Monday, October 16, 2017 1:04 PM
  • Worked for me, thanks for great help :-)
    Friday, March 15, 2019 10:20 AM