locked
I have a "Filter Actions Web Part" that no longer works. RRS feed

  • Question

  • I have two filter parts each working and a filter actions web part that was working just yesterday when I added it. Today, the "Save as my defaults" on the filter actions web part is greyed out and I can't get it to work again. I even removed the web part added it again, and more. What might be the trick to get this deal working again?

     

    Thanks.

    • Moved by Mike Walsh FIN Monday, December 6, 2010 2:48 PM As far as I can see this is not a web part that comes with Excel Services (the Google hits did not mention Excel Services) (From:SharePoint - Excel Services (pre-SharePoint 2010))
    Monday, December 6, 2010 1:46 PM

Answers

  • Hi,

     

    ·         According to your description, the filter Web Part you use may need to be connected to another Web Part on the page. You can connect filter Web Parts that are either visible or invisible to the user. A visible filter Web Part may request input from the page viewer, such as selecting from a product list. An invisible filter Web Part, such as the Current User filter, automatically filters the data it is connected to base on the person who is logged on to the computer.
    When a filter is available to be connected to another Web Part on the page, the Connections menu is visible from the edit menu. The connection between the filter Web Part and another Web Part on the page can be initiated from either direction.

    ·          

    I wish you every success in your important work.

    Best regards,

    David Hu

    • Marked as answer by Peng Lei Thursday, December 16, 2010 8:38 AM
    Wednesday, December 8, 2010 2:10 AM

All replies

  • Hi,

     

    ·         According to your description, the filter Web Part you use may need to be connected to another Web Part on the page. You can connect filter Web Parts that are either visible or invisible to the user. A visible filter Web Part may request input from the page viewer, such as selecting from a product list. An invisible filter Web Part, such as the Current User filter, automatically filters the data it is connected to base on the person who is logged on to the computer.
    When a filter is available to be connected to another Web Part on the page, the Connections menu is visible from the edit menu. The connection between the filter Web Part and another Web Part on the page can be initiated from either direction.

    ·          

    I wish you every success in your important work.

    Best regards,

    David Hu

    • Marked as answer by Peng Lei Thursday, December 16, 2010 8:38 AM
    Wednesday, December 8, 2010 2:10 AM
  • Does anyone have an actual answer to this issue?  The response by Peng Lei isn't really a response to the OP's problem as it's not possible to connect the Apply Filter to other web parts on the page.  I'm seeing the exact same behavior as the OP.  The "Save as my defaults" check box no longer available.  The Apply button shows as expected, but there is no way to save the selection as a default.  No change in browser, OS, SharePoint SP level, etc.  It suddenly stopped working.  I've removed/re-added the web part with no luck.  I even tried re-creating the page.  Again, no luck.

    Thoughts?

    Tuesday, March 20, 2012 6:56 PM