External USB disk performance slow after installing SP3 RRS feed

  • Question

  • Ever since I installed Service Pack 3 RTM build, my external USB disk slowed down on access. I can't get more than 2 MB/s when copying files from my laptop to external disk

    When I boot into Ubuntu Linux, everything works fine, when copying same files, I get speeds up to 25 MB/s with no trouble at all.

    Anyone experienced something similar?

    Thanks for any help!

    Sunday, May 4, 2008 3:28 PM

All replies

  • Hi,

    Check in device manager for any yellow exclamation marks under usb.

    Also can try uninstalling all the usb hubs under device manager and restart the computer so that the usb drivers are installed automatically.

    Sunday, May 4, 2008 11:14 PM
  • I tested USB performance, under SP3 RTM, and everything works fine.

    What is the motherboard chipset?

    And did you do a clean SP3 install or update existing installation?
    Monday, May 5, 2008 7:58 AM
  • I did an upgrade from SP2 to SP3, I didn't have to do the clean install of Windows.

    I'm running Windows on a HP 6710s laptop with Intel GM965 chipset and Core 2 Duo.

    Will try the advice in first reply!

    Monday, May 5, 2008 3:02 PM
  • I too noticed the same exact thing on my Thinkpad T42.  I tried everything and can't figure it out!  Strangenst thing... Anyone else out there have any ideas?
    Wednesday, May 21, 2008 9:33 PM
  • No ideas, but the same thing is happening to me. I back up my laptop hard drive to an external USB hard drive using Casper. Before SP3 it took about 45 minutes. Now it takes 2.5 hours.


    Thursday, May 22, 2008 1:27 AM
  • Yeah, something has to be going on.  I tried reinstalling my USB drivers after removing the device.  I reinstalled the chipset drivers for my T42 from IBM too and have tried two drives.  Anyone has any ideas, please advise!  Thanks!

    The more I read, the more I'm finding issues, but no solution:

    Sunday, May 25, 2008 7:25 AM
  • exact same thing here on my T42...

    - uninstalled all of my usb devices in the device manager, but no luck
    - reinstalled chipset drivers, but no luck either

    does anyone have any other solutions?
    Saturday, June 21, 2008 11:20 AM
  • I am probably the only one watching this thread at this point... but only because I am DESPERATE for a solution.  We have T61's and T60's but I love my T42 (better quality anyway).  I've search high and low, and nothing... I think we may have got hosed since Lenovo took over.  Any support for the T's they had? 

    Anyway, still and issue for me.
    Wednesday, June 25, 2008 2:31 AM
  • You aren't the only one watching this thread. I still have the same problem.


    Wednesday, June 25, 2008 4:02 AM
  • yep me too, but next week I'm going to do a format and reinstall SP2...

    Wednesday, June 25, 2008 10:03 AM
  • Yea, I found some generic driver from Intel for 2.0 and installed those but still no improvement on performance... I don't understand how they managed to break this and how no one else has reported it but us!
    Thursday, June 26, 2008 1:44 AM
  • Q1: Can anyone with this problem establish whether the issue is that the USB devices are being recognised as USB1, rather than USB2, devices?


    Q2: In Device Manager, if you click to expand the tree under "Universal Serial Bus controllers", can you see at least one instance of "USB2 Enhanced Host Controller"?


    Q3: Can you say what manufacturer/model of USB chipset is in use (from Device Manager).


    Thursday, June 26, 2008 10:48 AM
  • A1: Mine is being recognized as USB2, but the speed is less than half of normal.


    A2: Yes, it's there. See below.


    A3:  Intel 82801DB/DBM 2.0 Enhanced Host Controller - 24CD


    Thursday, June 26, 2008 8:59 PM
  • Same responses for me.  I flashed my bios (needed to anyway, it was old) and updated all my drivers to the latest versions and still no go.
    Monday, June 30, 2008 7:48 AM
  • Those of you affected with this, paste this text below exactly as it is into a text file, then rename the extension from .txt to .vbs and click it. 


    (For some reason this was working for me, but now when I click it nothing happens. ??  I can run other vbs files, but I can't run this one anymore.  So it may not run on SP3, so keep that in mind....then it's of no use of course.  LOL).  Maybe it uses or calls an SP2 version of wscript.exe.


    Anyway, it's supposed to popup a message saying what the "MsgBox" areas below says.



    On Error Resume Next
    'The presence of the following key seems to indicate USB 2
    RegKey = "HKLM\SYSTEM\CurrentControlSet\Enum\USB\ROOT_HUB20"

    'Attempt to read the key
    CreateObject("WScript.Shell").RegRead(RegKey & "\")

    If Err Then
      'An error is always returned when there is no default value, so
      'check for specific error message returned for missing key
      If InStr(LCase(Err.Description), "invalid root") > 0 Then
        MsgBox "This computer does not seem to be USB 2 enabled."
        MsgBox "This computer appears to be USB 2 enabled."
      End If
    End If

    Monday, June 30, 2008 11:46 AM
  • It could be that SP3 doesn't like certain settings in the mobo's BIOS.  Look in your mobo's BIOS in the USB area and see if you have something mentioning "Legacy USB" enabled or disabled, and toggle that.


    Monday, June 30, 2008 11:49 AM
  • I’ve had this problem with my Vista from day one, tried 3 different internal USB drives same problem on all three; slow as heck! I've tried it all uninstalling reinstalling, etc... NO LUCK. Now I hear the problem is happening on XP with SP3, man this is definitely a Microsoft problem!

    Intel 82801DB/DBM 2.0 Enhanced Host Controller - 24CD
    Intel 82801DB/DBM USB Universal Host Controller - 24C2
    Intel 82801DB/DBM USB Universal Host Controller - 24C4
    Intel 82801DB/DBM USB Universal Host Controller - 24C7

    Wednesday, July 9, 2008 1:29 PM
  • The key "HKLM\SYSTEM\CurrentControlSet\Enum\USB\ROOT_HUB20" is present on my machine, still the same issue.  I just can't figure out what MS did in SP3 to cause this...  I've checked everything I can off the top of my head.
    Wednesday, July 9, 2008 9:41 PM
  • Any solution to this issue yet? I've the same problem; USB2.0 disappeared after installing SP3. I can't find USB2.0 host controllers in device manager anymore. I have re-installed chipset drivers and tried to update manually Intel 82801FB/FBM USB Host controller to USB2.0 Host controller; It didn't work though (device didn't start).

    In my laptop (Uniwill M30EI0) there is no USB-settings in bios, but all ports are USB2.0 compatible and worked well before installing SP3. My external hdd is sooo sloooooow now..

    Thursday, July 24, 2008 12:33 PM
  • Not that I know of.. I am still limping along with no 2.0 on my T42.  I've resorted to ditching my very nice lacie external disk for my more mundane network backups at home... not my first choice, but it'll get me by.  I can't believe there isn't more on this on the net.  I just note here to keep this thread alive!
    Thursday, July 31, 2008 1:35 AM
  • itdeptbg, have you tried this somewhat extreme measure?  In Device Manager, under "Universal Serial Bus controllers", delete every device listed, re-boot and allow them all to be re-discovered.


    Thursday, July 31, 2008 12:09 PM
  • Did that just now again (got my hopes up, but I think I did it before) and same thing... still slow as heck... what a bummer!
    Tuesday, August 12, 2008 9:15 PM
  • Do any of you know just what kinds of speeds you're getting?  Have you done any benchmarks or timed file transfers?  There's a lot of free benchmark programs available that will test the speed.  Or you can zip a large folder around 100MB (after compression), then copy that to the USB drive and time it. 


    USB 2.0 has a maximum theoretical transfer of 480mb/sec (megabits) which is 60MB/sec (megabytes).  But you won't get anywhere close to those speeds.  You're doing fantastic if you can get half that, and with actual files the speeds are usually around only 10-20MB/sec.  A compressed file test should be a little more than that.


    With these test results you can determine if you're just getting bad USB 2.0 speeds, or if it reverted back to USB 1.1.


    Wednesday, August 13, 2008 6:11 AM
  • I have a similar problem - after installing SP3 the USB devices are now only recognised as USB 1.1, not USB2. Trying to install the "USB2 Enhanced Host Controller" driver instead I get the error message 'Device could not start'. Could not find any options in BIOS and have tried uninstalling and restarting - makes no difference.
    Monday, August 25, 2008 2:38 PM
  • i'm having a similar problem, only more extreme.

    ever since i installed sp3 i can't install any new usb devices.  the old ones are ok, but the new ones are not recognized.

    any solutions would be greatly appreciated.


    Tuesday, August 26, 2008 2:30 PM
  •  martyj wrote:

    i'm having a similar problem, only more extreme.

    ever since i installed sp3 i can't install any new usb devices.  the old ones are ok, but the new ones are not recognized.

    any solutions would be greatly appreciated.


    Have you looked at all the suggestions in this thread?  I can't add anymore to what I and others have suggested.  You kind of have a "fix" yourself albeit a pain; remove SP3, let SP2 see the new USB devices then install SP3 again so it will see them. 


    I haven't tried adding any new USB devices since I installed SP3, so FAIK I may have that problem as well.  But I still have yet to have any USB or USB speed issues.  I reformatted, installed XP Pro slipstreamed w/SP2, then SP3 from the full download.

    Wednesday, August 27, 2008 12:08 PM
  • has anyone looked at write caching?

    I know windows Vista doesn't have write caching on for external usb devices as the default behavior, and XP SP3 may have set the same option.

    This article may help:

    Monday, September 8, 2008 9:23 PM
  • Great to see some post here, but still the same issue exist after attempting all of the suggested items.  Bummer.
    Wednesday, September 17, 2008 5:24 PM
  • I too have the USB2.0 problem following SP3.  Due to the AMD chip at first I could only boot to Safe Mode - that was fixed with downloading a file but I am still left with the USB2 problem.  I have spent 5 sessions of 2 hours each with Microsoft Tech support on this issue since 9/3.  We removed SP3, recreated the registry, reinstalled the USB2 drivers - all to no avail.  USB1 works fine.  MS now tell me to do a "non-destructive recovery."  Based on what I have been reading that is similar to wiping out the HD and starting over based on the experiences of others.  Has anyone found a fix for the USB2 snafu?

    Thanks - Tom

    Sunday, October 5, 2008 7:59 PM
  • This thread has been a lifesaver in that it provided an explanation for my disk I/O slowdown.  SP3 was installed on my system 2 days ago by the automatic system update service.  I thought my external WD drive was breaking down, bought and installed a new one, and when its speed also topped out at about 1 MB/sec, it suddenly occurred to me that maybe the service pack update was responsable.

    Crossing my fingers & following the instructions in a MS article (look for "uninstall SP3"), I've just used the add/remove program manager to remove SP3 and everything's back to normal now, disks zipping along at about 10 MB/sec as before.

    I've turned off the automatic system update service.  I'm amazed that MS validated SP3 for automatic updating while it has such an obviousand noxious defect.  I hope the eventual resolution of the problem gets posted here so that I can find out when it'll be safe to turn auto-updating back on.

    I can't participate in the technical discussion on this topic, but if it's any help to someone trying to fix the problem, I'm running an old DELL Optiplex GX270, with the disks (WD "My Book" devices) plugged into the PC's USB ports on the back.
    Monday, October 6, 2008 6:51 AM
  • Found a vierd "solution" to this problem... well it's not sustainable, but it works for a few moments at the time, maybe this will help Microsoft to find a solution to the problem:


    I have the problem on a T42 (IBM ThinkPad), with XP SP3, just as mentioned here in the thread. I have tried this with 3 diffrent USB drives, and it's the same everytime.


    I can consistently reproduce the following steps:


    Step 1: 
    Plug in a mouse in one of the USB ports on the side, and a USB drive, and confirm the drivespeed is in fact dead slow (<3Mb/s)... usually it gives a notification about "connecting Hi-speed devices to a non hi-speed USB hub" ...


    Step 2:
    In the Devicemanager, I see 4 USB hubs, one says its "enhanced" or "USB 2", the 3 others as normal USB hubs. Choose "View devices by connection" and confirm the mouse and the USB drive is attached to each a "slow" USB hub, the "enhanced" hubs still have no devices.


    Step 3:
    In the devicemanager, delete/uninstall all USB controllers


    Step 4:
    Click on the "Redetect devices" from the menu.


    Step 5:
    just as the USB devices are redetected, the USB drive is somehow appearing as connected to the one "enhanced controller"... (!) ... for a few moments untill the devicemanager does its next "detection" it now works at FULL speed (around 25 Mb/s)  ...


    For me the full speed usually lasts untill the operation of copying one single file is over.

    - After this, the USB drive is "redetected" and I recieve the "Hi-speed connection..." notification again - and the party is over....


    Hope this can contribute to solve the mystery.



    Tuesday, October 28, 2008 9:14 AM
  • Experiencing a similar issue with an Alienware system.

    Began experiencing issue with first SP3 patch installation (Clean SP2 with Production SP3 patch applied) and encounter issues after each monthly security update, ie a different external USB no longer recognized -- Periodic issues with delayed writes, issues complaining about the MFT.


    I even dropped in USB 2.0 controller to connect the devices directly to in case it was on-board USB issue.

    BIOS is OK, all drivers from manufacturer (Intel) are current.


    Experienced issues with external USB hard drives (first Maxtor, then WD, then Seagate, last was a new WD all being 120 GB to 500 GB in size). Last to be affected was one of the newest WD My Book series.


    The update I just ran for this month decided it did not like my printer (USB connected).  That thrilled me as it is an HP and it is so fun to cleanup those drivers.

    I am having a suspicion that is a repeat of the early XP issue that had issues with the HP and HP file sharing, Canon (camera) filesharing and nVidia drivers. 


    The last two drive issues corresponded to the last 2 monthly Microsoft security updates.

    On reboot the system actually failed to complete.

    Performed a soft boot and went into Safe Mode (disconnected external drive prior).

    No issues.  Connected the USB drives and they open fine in Safe Mode. 

    Rebooted again, this time the Normal OS loaded without issue, Connected the drive and all the folders were seen.


    In response to speed issues I have seen, did not check myself for actual transfer rate, but I can confirm that all of my USB hard drives and any attached flash drives are suffering decreased read/write rates.

    Attempted to format one of USB hard drives, left for half a day, never got beyond 10%.


    For me, I am guessing the issue is tied to a couple things:

    USB time elapsed that triggers drive spin-down

    Security feature that is either blocking or no longer dynamically handling USB resources the same as in the past.


    As time permits will test removing the USB device and then device drivers, reboot and see if the correct drivers are loaded.

    I find it hard to believe that 4 external USB devices with their own power source would all have the exact same issue.






    Thursday, November 13, 2008 2:11 PM
  • I have tried the following:

    unplugged all USB devices

    opened the device manager and proceeded to do the following:

    uninstalled USB Root Hub x 8

    uninstalled NEC PCI to USB Open Host Controller x2 (addon USB card)

    uninstalled Standard Enhanced PCI to USB Host Controller x 5


    restarted computer (no USB devices attached)

    logged on (no issues at this point)


    GUI loaded, startup apps loaded as normal.

    New Hardware detected

    USB detection began

    One important piece for me was that it found Intel(R) 82801EB USB2 Enhanced Host Controller.


    I connected the external drive that was giving me a problem.  I wanted to reformat this one.

    The device now correctly resolved to drive letter G (for me and my system)

    I am now formatting this drive, this is same drive I mention above as taking half day to format 10 %.  As I type, it is already at 15 % in the 10 minutes I am now up and running. (trying to document as soon as soon as I can identify changes)


    Procedure I followed provided by another poster, in my case it appears to have eased my USB issues fr now.

    I now have 5 Intel entries under USB Controllers in Device Manager.  I suspect the last security update must have added to this problem as I have more entries under Universal Serial Bus controllers than I uninstalled.


    So far, I can still print to HP printer without issue, nVidia drivers OK. 

    The updates did whack the Creative drivers but Creative has become a questionable software / hardware vendor anyway.


    Will update if any substantial changes take place.


    Thursday, November 13, 2008 11:41 PM
  • I'm still having the same issue.  I didn't uninstall SP3, though I probably should have months ago.  Looks like I should just get a NAS for my backups!
    Monday, December 1, 2008 10:58 PM
  • Thanks Dunkelzahn - oder soll ich danke sagen?

    Anyway: Absolutely right! This whole problem came up first after the last security patchday from Microsoft. I ran all kind of usb 2.0-features, external hdd, wlan-adapter, etc. - none of them had any driver problems after installing for my Xp Pro the famous SP3. But after the last patchday from one sec to another XP claims that I'm using high speed on a non-high-speed usb. That's of course is bull.... All other informations from XP stil confirming that usb 2.0 is available - so why it's not used anymore?
    Tuesday, December 2, 2008 9:50 AM
  • I am having the same issue appear after each monthly update.

    Last update decided Creative sound drivers should be overwritten.
    The problem is that the card has a firewire port on it and Microsoft has decided firewire and usb are potentially evil.
    Causes a conflict at boot time as system is agressively trying to lock down everything.

    I don't defend Creative as they have some seriously questionable code.  But a Microsoft update where hardware drivers are not selected should not change the functionality or create a hardware conflict where there was previously none. 

    Monday, December 15, 2008 2:41 PM
  • Okay, I see that there is still no solution for this issue then to downgrade to SP2.
    I have the issue with my Toshiba external disk which is seen as a USB 1 device while it used to work as a USB 2 device. First I thought the external harddisk had problems, so I flashed the firmware of it to a newer one, did not solved. Flashed the HP laptop firmware, still no go. Called Toshiba support, they had no solution for me. Then I started to Google, and found a lot of people with the same issue. Since this is SP3 related, where is the MS fix to solve it?

    Are there MS people reading this forum? Can you help out? Very much appreciated.
    Monday, December 29, 2008 12:03 AM
  • I don't think so Sabroso... I have been watching this thread since last MAY2008 and nothing has changed.  I wish they would do something about it!
    Thursday, February 26, 2009 8:51 AM
  •  If you are having trouble with recognition of USB devices, try this:

    - disable or uninstall all anti-virus or anti-malware applications;
    - open the "hidden" folder   C:\Windows\inf
    - delete all files matching: usb*.pnf
    - do NOT delete any *.inf files.
    - delete the file INFCACHE.1
    - in a command prompt window, type the command:  net stop cryptsvc
    - delete the folder C:\Windows\System32\Catroot2
    - in Device Manager, uninstall every USB component.
    - reboot Windows and allow hardware discovery to complete.
    Robin Walker
    Thursday, February 26, 2009 9:13 PM
  • Hi Robin, thank you for this advice, but it did not work me.
    After doing the steps my new 0.5T USB2 hdd is still saying:

    "This device can perform faster.
    This USB device can perform faster if you connect it to a Hi-Speed USB 2.0 port. For a list of available ports, click here."

    In ubutnu it is ok (full usb2 speed). I have to say that I have another usb2 hdd wich is only 160GB and I connect it in the same usb port
    and my ThinkPad T40p recognises it as usb 2.0. The new 0.5T hdd is
    samsung HM500LI, in Icy Box http://www.raidsonic.de/en/pages/products/external_cases.php?we_objectID=5032#awards
    it is still usb 1.0

    Do you have any other ideas? Thanks

    - disable or uninstall all anti-virus or anti-malware applications;
    - open the "hidden" folder   C:\Windows\inf
    - delete all files matching: usb*.pnf
    - do NOT delete any *.inf files.
    - delete the file INFCACHE.1
    - in a command prompt window, type the command:  net stop cryptsvc
    - delete the folder C:\Windows\System32\Catroot2
    - in Device Manager, uninstall every USB component.
    - reboot Windows and allow hardware discovery to complete.
    Wednesday, March 18, 2009 1:19 PM
  • Igor,

    You have quite an intriguing problem there.  Can you do some checks as follows:

    - when it says "For a list of available ports, click here.", and you click there, what is given in the list?
    - in Device Manager, can you list for us all the USB "host controller"s listed?
    - in the directory C:\WINDOWS\system32\drivers can you list the internal version numbers of all the files matching the pattern usb*.sys ?
    - after you receive "This device can perform faster" message, open a command prompt window and type the command

    sc query usbehci

    and copy down the response.

    If you take the 0.5TB external hard disk to another Windows SP3 PC, and plug it in, does it behave as a USB 1 or a USB 2 device?
    Robin Walker
    Wednesday, March 18, 2009 2:34 PM
  • an Asus32SLI-deluxe mob after installing XP sp3.

    I have carried out the procedures you outlined and here is the result of my enquiry via cmd:

    sc query usbehci
    Service_Name: usbehci
            Type            : 1 KERNEL_DEBUG
            State            : STOPPED
            WIN32_EXIT_CODE        : 1077     <0x435>
            SERVICE_EXIT_CODE    : 0 <0x0>
            CHECKPOINT        : 0x0
            WAIT_HINT        : 0x0

    Can you recommend anything else please.

    Is this not a case that sp3 has wiped out the sp1 feature to recognise USB2?

    If so can one slipstream sp1 into a sp3 image.

    Thank you,

    Friday, March 20, 2009 2:00 PM
  • CJJ, in your case, one problem, at least, is that the usbehci service (for USB 2) has not been started.  The questions are:
    1) why has this service not been started?
    2) what happens if we start it manually?

    To gather extra evidence for question 1, please open a Command Window and type the command:

    sc qc usbehci

    and copy the output back here.

    To try starting it manually and watch what happens, type the command:

    sc start usbehci

    Robin Walker
    Friday, March 20, 2009 3:15 PM
  • Dear Robin,

    Sorry for the delay, I tried updating the bios but had to reset it as I got the BSOD!

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Christopher>sc qc usbehci
    [SC] GetServiceConfig SUCCESS

    SERVICE_NAME: usbehci
            TYPE               : 1   KERNEL_DRIVER
            START_TYPE         : 3   DEMAND_START
            ERROR_CONTROL      : 1   NORMAL
            BINARY_PATH_NAME   : system32\DRIVERS\usbehci.sys
            LOAD_ORDER_GROUP   : Base
            TAG                : 15
            DISPLAY_NAME       : Microsoft USB 2.0 Enhanced Host Controller Miniport
            DEPENDENCIES       :
            SERVICE_START_NAME :

    C:\Documents and Settings\Christopher>

    If I run Driver Detective it does say that their is an unknown USB device which the driver update says needs an Intel Embedded ESB Version 1.0 Chipset Driver.

    Is this relevant.

    Thank you so much for your help it really is appreciated.


    Friday, March 20, 2009 6:52 PM
  • Dear Robin,

    This is the result of trying to manually start it.

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Christopher>sc start usbehci
    [SC] StartService FAILED 1058:

    The service cannot be started, either because it is disabled or because it has n
    o enabled devices associated with it.

    C:\Documents and Settings\Christopher>

    If I look in Device Manager their are 2 USB Controllers at the bottom of the list as follows:

    Human Interface Devices
    HID Non-User Input Data Filter
    HID-compliant device
    USB Human Interdface Device
    USB Human Interdface Device
    USB Human Interdface Device
    USB Human Interdface Device (This last one says [this device cannot start])

    Then further down.

    Universal Serial Bus Controllers
    Generic USB Hub
    Generic USB Hub
    Generic USB Hub
    Standard OpenHCD USB Host Controller
    USB Root Hub

    Universal Serial Bus Controllers
    PCI Class USB 2.0 Enhanced Host Controller

    Thank you once again.

    Friday, March 20, 2009 7:02 PM
  • I'm a bit suspicious of what Driver Detective is telling you about that Intel driver.

    Could you check to see whether
    is relevant to your problem?  It looks as if it is possible for the wrong drivers to get loaded in respect of this card.  They give a procedure for replacing the "PCI Class USB 2.0 Enhanced Host Controller" (wrong) with the "NEC PCI to USB Enhanced Host Controller" (right).

    Does this PC actually have a Belkin card for USB and Firewire?

    In Device Manager, open the Properties of "PCI Class USB 2.0 Enhanced Host Controller", and click tab "Details".  Copy down the "Device Instance id" and post it here - that should enable us to verify the identity of the card and check what special drivers it might need.

    Robin Walker
    Friday, March 20, 2009 7:40 PM
  • Dear Robin,

    "PCI Class USB 2.0 Enhanced Host Controller", and click tab "Details" as follows:


    Once again, thank you so much.

    I will look at the belkin issue in the meantime.


    Friday, March 20, 2009 10:00 PM
  • Christopher,  VEN_10DE&DEV_005B is an NVIDIA nForce4 USB 2.0 controller.  If you have not already done so, you should go to www.nvidia.com and download the latest chipset drivers for the nForce4 chipset, and install those.  These will probably do better than the default drivers that Windows found.
    Robin Walker
    Friday, March 20, 2009 11:26 PM
  • set on the NVIDIA website and after a couple of false starts managed to get it loaded.

    USB ports now no longer complain. Thank you!

    Just one matter, when I tried to update the BIOS with NVIDIA's matching driver my computer hung up at boot-time.

    I reset the BIOS by clearing the RTC Ram and did not load a fresh bios driver and all seems to be well. So I assume I can leave it like that?

    I ran a further sc query usbehci and this was the result.

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Christopher>sc query usbehci

    SERVICE_NAME: usbehci
            TYPE               : 1  KERNEL_DRIVER
            STATE              : 4  RUNNING
            WIN32_EXIT_CODE    : 0  (0x0)
            SERVICE_EXIT_CODE  : 0  (0x0)
            CHECKPOINT         : 0x0
            WAIT_HINT          : 0x0

    C:\Documents and Settings\Christopher>

    Just one final thing, I have installed a further 2GB of RAM making 4GB in total. Am I correct in assuming SP3 can support a total of 4GB including memory on the graphics card. The reason I ask is that my system reports that it is only using 3GB.

    Thank you so much. Although it took until 3.30 am this morning you have saved me literally days if not weeks of work.

    My kind regards,


    Saturday, March 21, 2009 1:55 PM
  • OK, so USB2 problem is fixed with the proper NVIDIA drivers.

    Not sure about the BIOS problem: if it now works, I assume it is now OK.  It is not unusual for it to be necessary to reset all BIOS settings after an update of the BIOS.

    It is a hardware limitation that you will only be able to use about 3GB of the 4GB installed system RAM.  All RAM on peripheral cards (such as the video card, especially) needs to be mapped into the address space below the 4GB boundary for 32-bit addressing, so that the peripheral memory can be addressed.  For each segment of peripheral memory mapped in, the same size of the 4GB system RAM will be mapped out and rendered unusable.  That's a restriction of the so-called x86 operating systems.

    If 3GB of RAM is seriously not enough for your applications, then you need to think about upgrading to an x64 version of Windows.  But I would recommend considering an entirely new PC for that, rather than attempting to upgrade a PC of the vintage you have here.
    Robin Walker
    Saturday, March 21, 2009 2:20 PM
  • Dear Robin,

    Thank you.

    Your advice, as always, is greatly appreciated.

    There is no doubt that once funds permit an update will be high on the agenda.

    In the meantime I am, as already expressed, most grateful for allowing my "old girls" grow old gracefully.

    Bye for now.


    Saturday, March 21, 2009 3:35 PM
  • No USB 2.0 after SP3 install.
    I can't use my USB 2.0 TV-tuner any more.

    Windows XP Home on MSI S260 Notebook.
    It was fine with XP SP2.
    Now I'm getting "This device will work faster..." on every USB port of my PC.
    If I click the pop-up to check available USB 2.0 ports -- there are no USB 2.0 ports available.
    More to come: in device manager there is no EHCI controller, only:
    Intel(R) 82801FB/FBM USB Universal Host Controller - 2658
    Intel(R) 82801FB/FBM USB Universal Host Controller - 2659
    Intel(R) 82801FB/FBM USB Universal Host Controller - 265A
    Intel(R) 82801FB/FBM USB Universal Host Controller - 265B

    I updated chipset drivers to the latest from intel website.
    I tried to remove all usb devices (and hidden also) and reboot -- no usb 2.0 found after reboot.

    usbehci service cannot start because of "device is not connected..."
    >sc start usbehci
    [SC] StartService FAILED 1058:

    Any help will be greatly apriciated!!!
    Friday, May 1, 2009 6:36 PM
  • Hi

    Need help with my usb problem

    I have a 1TB external hdd and its a usb 2.0 and i used to get amazing speed when i connected it to the the mac installed machine and my broher's XP system .. only with windows vista and windows 7 this seems to be a problem it gives just a trasnfer speed of 5 MB/s and then keeps on dropping down and then stays on 1.5 or 2

    on my Mac it used to trasnfer 1 gb file under a min same with the xp but not with vista or windows 7 ... i have tried with a small file and have tried with a big file the results turn out to be the same . have checked in device manager and my ext hdd shows its connected to a hi speed usb hub ... i have tried safe mode and in the safe mode the speeds are little better it gave a max of 10MB/s but not as good as the mac or the xp it is not reaching the 25 MB/s to 30 MB/s which it used to

    I work for Dell and its not only a problem with my system there are thousands of users who face the same problem

    Not only that i have tried multiple pen drive multiple ports ...... i have checked the bios and all the setting for the usb controller are fine the drivers are up to date how ever i noticed something...

    i did a clean install of vista did not conect to the internet therefore no updates downloaded and now i tried the usb transfer .... i got speeds upto 25MB/s to 30MB/s which is good enough as a usb 2.0 theoretically provides 60MB/s


    After downloading the updates from windows update the speeds took a hit now they do not go above 4 MB/s or 5MB/s so this is an issue with the updates some fix needs to be for this cause it is literally frustrating as to trasnfer a file of 1 gb it takes a long time.

    same problem with windows 7 RC but in its case the speeds suck from the time u install it...

    There are no softwares installed except an antivirus software so chances of some 3rd party programs causing the problem i dont think so.
    Friday, May 8, 2009 8:24 PM
  • I found a link with an answer that may work for you. I tried it for myself and now my external hard drive flies.
    Good Luck!
    Saturday, May 9, 2009 1:25 AM
  • I found a link with an answer that may work for you. I tried it for myself and now my external hard drive flies.
    Good Luck!

    Dude thanks for the Link

    However i do not have this problem the issue i have is the slow trasnfer speeds while transferring files....there is no booting issue i always have my ext hdd connected and it boots fine to windows however while transferring files it gives a slow transfer speed..

    windows vista gave proper speeds upto 25MB/s to 30MB/s before any updates were downloaded...... as soon as the updates got downlaoded it caused problems the speeds drastically reduced

    A lot of users r facing this issue but there is no fix for this........
    Saturday, May 9, 2009 6:47 AM
  • I have the same problem on several machine, I have not tried this solution but others seem to think it works.


    The fix in concern needs to have a registry key set. In case you had the KB originally installed before updating to SP3, the key would be automatically set.
    Please check the registry key value HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USB\EnSoftRetry


    If not present, please create a DWORD Registry Value as the same and set it to 1.

    I think your problem should get solved by this."


    I'll try this later today.


    • Proposed as answer by plbdad Sunday, June 14, 2009 11:31 PM
    Sunday, June 14, 2009 11:31 PM
  • I too. I installed Xp Sp3 Rc. From that time the problem started. Earlier there was nothing. So I again formatted my Pc, Installed a fresh copy of XP sp2. But the problem still appears. Can anybody help me?
    Tuesday, January 5, 2010 5:45 AM