none
Windows 10 GPO Unable To Map Drives

    Question

  • We recently upgraded our client PCs to Windows 10 and had sorted out a majority of the issues.  This week we found that several of our users no longer had their mapped drives appearing in explorer.  We push our drive mappings via GPO from our Windows 2012 R2 Server.

    When logged into one of the problem clients with an administrator account and run net use it comes up showing no drive mappings.  I am able to browse to the network locations using the UNC path.  I attempted to create the drive map manually using net use and get the following error, regardless of what drive letter I attempt. 

    net use Z: \\server\path
    System error 1920 has occurred.

    The file cannot be accessed by the system.

    On top of this, when I run GPRESULT I receive the following:

      The following GPOs were not applied because they were filtered out
        -------------------------------------------------------------------
            Network Drive Mapping
                Filtering:  Not Applied (Unknown Reason)

    So it appears I may have two issues 1) I cannot map network drives manually and 2) the GPO isn't being applied, unless #1 is causing #2.  The only way I could get the drive to map was to right click on the network location and map the drive through the Windows 10 GUI.

    After some web research I did try adding this reg key to the client with no success:

    "EnableLinkedConnections".

    Any suggestions?  We have not changed anything this past week in our network config.  Was this caused by a MS update?



    Tuesday, June 21, 2016 12:59 PM

Answers

  • > /net use Z: \\server\path/
     
    Check MS16-077 - NetBios across subnets
     
    > /        Network Drive Mapping/
    > /            Filtering:  Not Applied (Unknown Reason)/
     
    Check MS16-072 - user GPO enumeration in computer context
     
     
    • Marked as answer by MikeOrlando Wednesday, June 22, 2016 1:45 AM
    Tuesday, June 21, 2016 3:20 PM

All replies

  • I did also disable McAfee Security as a Service on the client to see if this was preventing the mapping.  No effect.

    Tuesday, June 21, 2016 1:42 PM
  • > /net use Z: \\server\path/
     
    Check MS16-077 - NetBios across subnets
     
    > /        Network Drive Mapping/
    > /            Filtering:  Not Applied (Unknown Reason)/
     
    Check MS16-072 - user GPO enumeration in computer context
     
     
    • Marked as answer by MikeOrlando Wednesday, June 22, 2016 1:45 AM
    Tuesday, June 21, 2016 3:20 PM
  • It appears that uninstalling recent Windows Update KB 316-3018 has allowed the drive mappings to return, will continue to investigate.
    Tuesday, June 21, 2016 5:09 PM
  • MS16-072 is the answer.  Our clients had downloaded KB3163018, which contains MS16-072 that changes how GPOs are applied:

    Changes the security context with which user group policies are retrieved. This by-design behavior change protects customers’ computers from a security vulnerability. Before MS16-072 is installed, user group policies were retrieved by using the user’s security context. After MS16-072 is installed, user group policies are retrieved by using the computer's security context.

    • Add the Authenticated Users group with Read Permissions on the Group Policy Object (GPO).
    • If you are using security filtering, add the Domain Computers group with read permission.

    • Edited by MikeOrlando Wednesday, June 22, 2016 1:50 AM
    • Proposed as answer by dexterenergen Monday, January 02, 2017 10:10 PM
    Wednesday, June 22, 2016 1:50 AM
  • I got most of my policies to be applied adding authenticated users with the read permission. Only one to go, but I am not sure there is anything pertinent in the local policies, plus since it isn't controlled by GPO so I'm not feeling like going to each client to change permission locally.

       The following GPOs were not applied because they were filtered out
        -------------------------------------------------------------------
            Local Group Policy
                Filtering:  Not Applied (Empty)

    Wednesday, June 22, 2016 2:10 AM
  • >     The following GPOs were not applied because they were filtered out
    >      -------------------------------------------------------------------
    >          Local Group Policy
    >              Filtering:  Not Applied (Empty)
     
    Nah, that's perfectly ok :)
     
    Wednesday, June 22, 2016 9:37 AM
  • This fixed it for me. Thanks a lot!
    Monday, January 02, 2017 10:10 PM