locked
Unable to clear 'Stored User Name and Password' cache as UI is blank RRS feed

  • Question

  • Hi all. This seems like such a basic issue to resolve, but I'm just not cracking it.

    The problem I have is that the username and password entry I want to remove, which is obviously cached and is used to re-authenticate with Office 2010 docs on a Sharepoint list, is not shown in the Stored User Names and Passwords box:

    Summary of issue: Standalone XPSP3 machines accessing webservers hosting Sharepoint. User logs in to Sharepoint, chooses to edit an Office doc\spreadsheet etc, prompted to re-authenticate. User re-enters Sharepoint credentials and ticks the box to remember password. User can edit and save doc back to Sharepoint list\library and then logs out of Sharepoint. If the user's Sharepoint password is now changed however, the client cached password is not updated and so when the user tries to edit an Office 2010 doc they receive an authentication error with no option to enter the new password. At this point there appears to be no way to delete the old\incorrect password from the client as it does not appear in the Manage Passwords > Stored User Names and Passwords box (as shown above).

    Workarounds:

    • delete the user's Windows profile (folks are never happy about this)
    • reg edit detailed in - http://support.microsoft.com/kb/229940 
      (does disable password caching entirely, but a. means you lose the single sign-on Office\MOSS integration and b. when reversed simply puts you back to square one, i.e the cached, wrong, password is re-instated)
    • enabling the 'Network access: Do not allow storage of credentials or .NET Passports for network authentication' policy via Computer Configuration > Windows Settings > Local Policies > Security Options (but with the same pitfalls a. and b. above)

    As mentioned, all I want to do is quickly and cleanly delete the Stored User Name and Password, i.e purge the cache.

    Thanks in advance, Jason


    Tuesday, August 7, 2012 9:18 AM

All replies

  • Any MS bods out there know where the cache is and\or how to delete it please? Seems like a bug to me, otherwise the cached credentials (which are most definitely still in use) would appear in the UI to be deleted by the user. Thanks again, Jason
    Thursday, August 9, 2012 7:35 AM
  • Can I bump?
    Thursday, August 16, 2012 2:20 PM
  • Hmm, it might be stored in the IE password cache? you can try this, lemme know if it works.

    http://kb.iu.edu/data/alcx.html

    Sunday, August 19, 2012 7:37 PM
  • Hi there. Thanks for the suggestion. Unfortunately, clearing the entire internet browsing history after the password reset (and a reboot just for good measure) makes no odds; the old cached credentials are still used. The credentials are obviously cached in the user's profile, but not in their internet history\temp internet files. Thanks again, Jason
    Monday, August 20, 2012 10:46 AM
  • Last bump (before Brooklyn)
    Monday, September 3, 2012 3:42 PM
  • Hello,

    Five months on so perhaps this is a little out of date, but I'll still respond as a reference to others in the same situation...

    We had this same problem at my place of work. I have no idea where the credentials are stored, and why they do not appear in the Stored User Names and Passwords box - in our case we use a Novell network login system, which may or may not be relevant - I've no idea if this occurs for all XP users or only for certain ones, but it certainly affected us.

    What I can tell you is how we fixed it on our computers.

    For Windows 7 computers (bear with me), it appears as though, on our setup at least, the user is prompted each time for password regardless of whether or not they tick "remember password" - the difference being that these boxes appear pre-filled if they have previously saved the password. Nevertheless, if one wishes to clear the cached passwords then one can do so through the Control Panel->User accounts->(Your user account)->Manage Credentials box. There should be an entry down the page for the sharepoint site, and expanding this will give an option to "Remove from vault".

    Annoyingly, as shown above, in XP the equivalent box appears blank on our setup. The solution I have found is in an application file, cmdkey.exe, which is shipped with Windows Server 2003/2008 and Windows 7, but strangely enough not with XP where we need it. If you try copying across the Windows 7 version, you'll probably find it doesn't work and throws an error message, but the Windows Server 2003 should work fine.

    So you'll need to either track down someone running Server 2003 and borrow the file; buy your own copy; I read someone suggesting it can be harvested from a Server 2003 SP2 image freely downloadable at Microsoft, albeit I couldn't work out how to do that myself; or, do as I did and track down a copy of that one individual application file on the internet - Google is your friend. You'll need to watch out as there is another app on the internet called cmdkey which is not the version supplied with Windows, but instead an additional application written by someone else, so take care. I did virus/malware scan it before using it on my machine - downloader beware!

    If all is well, running this file using the command prompt (Run->"cmd") as follows:

    cmdkey /list

    will give you a breakdown of the credentials saved on your computer. Running the following command;

    cmdkey /delete:{your sharepoint domain name as shown in the above list}

    will remove the offending entry, and force Office packages (Word/Excel, etc.) to reprompt you for login details in the following visit.

    Hope that helps!

    John

    Thursday, January 24, 2013 3:06 PM
  • Hello,

    Five months on so perhaps this is a little out of date, but I'll still respond as a reference to others in the same situation...

    We had this same problem at my place of work. I have no idea where the credentials are stored, and why they do not appear in the Stored User Names and Passwords box - in our case we use a Novell network login system, which may or may not be relevant - I've no idea if this occurs for all XP users or only for certain ones, but it certainly affected us.

    What I can tell you is how we fixed it on our computers.

    For Windows 7 computers (bear with me), it appears as though, on our setup at least, the user is prompted each time for password regardless of whether or not they tick "remember password" - the difference being that these boxes appear pre-filled if they have previously saved the password. Nevertheless, if one wishes to clear the cached passwords then one can do so through the Control Panel->User accounts->(Your user account)->Manage Credentials box. There should be an entry down the page for the sharepoint site, and expanding this will give an option to "Remove from vault".

    Annoyingly, as shown above, in XP the equivalent box appears blank on our setup. The solution I have found is in an application file, cmdkey.exe, which is shipped with Windows Server 2003/2008 and Windows 7, but strangely enough not with XP where we need it. If you try copying across the Windows 7 version, you'll probably find it doesn't work and throws an error message, but the Windows Server 2003 should work fine.

    So you'll need to either track down someone running Server 2003 and borrow the file; buy your own copy; I read someone suggesting it can be harvested from a Server 2003 SP2 image freely downloadable at Microsoft, albeit I couldn't work out how to do that myself; or, do as I did and track down a copy of that one individual application file on the internet - Google is your friend. You'll need to watch out as there is another app on the internet called cmdkey which is not the version supplied with Windows, but instead an additional application written by someone else, so take care. I did virus/malware scan it before using it on my machine - downloader beware!

    If all is well, running this file using the command prompt (Run->"cmd") as follows:

    cmdkey /list

    will give you a breakdown of the credentials saved on your computer. Running the following command;

    cmdkey /delete:{your sharepoint domain name as shown in the above list}

    will remove the offending entry, and force Office packages (Word/Excel, etc.) to reprompt you for login details in the following visit.

    Hope that helps!

    John

    Hi John,

    Many thanks on the cmdkey /delete suggestion! This problem
    with cached credentials was bothering me for some time and deleting the
    unwanted (in my case SP setup account) solved the issue!

    <o:p>Gerard</o:p>


    Monday, May 19, 2014 7:30 AM