locked
Site Database Server Removal - Post CM DB migration RRS feed

  • Question

  • Hi Everyone,

    I am looking for some assistance, I have performed a successful DB migration from a remote SQL 2012 instance to an OnBox SQL 2012 instance using a site backup and site recovery.

    Unfortunately, since I have performed this action CM 2012 refuses to allow me to delete the Site System Server or Server Roles from the remote Site Database Server.

    I have been looking into the PS cmd "Remove-CMSiteSystemServer" and performed a -whatif on the command to check the results and I am seeing the following:

    • Remove-CMSiteSystemServer seems to ignore the -SiteSystemServerName parameter
    • Remove-CMSiteSystemServer only seems to act upon the -SiteCode

    So, what I am seeing is that if a run this command it will likely remove the entire Site based only on the -SiteCode, which I clearly do not wish to happen.

    Any advice on achieving this site system removal using preinst.exe / console / powershell commands?

    Cheers
    Rich

    Monday, July 6, 2015 2:29 AM

All replies

  • What happens when you try to remove it through the console? Do you have the required permissions on the remote server?

    John Marcum | Microsoft MVP - Enterprise Client Management
    My blog: System Center Admin | Twitter: @SCCM_Marcum | Linkedin: John Marcum

    Monday, July 6, 2015 8:37 PM
  • Thank for the reply.

    All options to remove in the console are grayed out. I have full Enterprise Admin and full Admin over the Server object.

    I have since shut down the remote Site Database Server to see if a replication failure will prompt CM to update.

    Tuesday, July 7, 2015 11:45 PM
  • Hi,

    Is there any other issue with this site server after DB migration?

    Please check hman.log and sitecomp.log.

    Best Regards,

    Joyce


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 8, 2015 6:50 AM
  • Errors from the hman.log (Domain and Username *replaced*):

    ERROR: AddAIUsersToAIToolsDBRole, Failed to add user [*DOMAIN*\*USER*] to SMSDBROLE_AITOOL role	SMS_HIERARCHY_MANAGER	9/07/2015 6:12:37 AM	5492 (0x1574)
    ERROR: Query < if EXISTS(select * from sys.database_principals where [name] = N'smsdbrole_AITool' and [type] = N'R') ~ BEGIN ~ IF NOT EXISTS(SELECT * FROM sys.server_principals where sid = SUSER_SID(N'*DOMAIN*\*USER*')) ~    CREATE LOGIN [*DOMAIN*\*USER*] FROM WINDOWS ~	 ~ IF NOT EXISTS(SELECT * FROM sys.database_principals where sid =SUSER_SID(N'OPERATIONS\oiacobn')) ~    CREATE USER [*DOMAIN*\*USER*] FROM LOGIN [*DOMAIN*\*USER*] ~ ~ IF NOT EXISTS (SELECT * FROM sys.database_role_members  ~	    where member_principal_id = USER_ID(N'OPERATIONS\oiacobn') and ~		      role_principal_id =USER_ID(N'smsdbrole_AITool')) ~    exec sp_addrolemember N'smsdbrole_AITool', N'*DOMAIN*\*USER*'  ~ END    ~>	SMS_HIERARCHY_MANAGER	9/07/2015 6:12:37 AM	5492 (0x1574)
    ERROR: HandleAIPermissions : Failed to add AI user added to the role smsdbrole_AITool.	SMS_HIERARCHY_MANAGER	9/07/2015 6:12:37 AM	5492 (0x1574)

    This is due to the user account being disabled.

    Sitecomp.log:

    Failed to make a network connection to \\*SQLServer.domain*\ADMIN$ (0x35).	SMS_SITE_COMPONENT_MANAGER	9/07/2015 11:22:22 AM	8060 (0x1F7C)
    

    and

    Cannot getcopy HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\MCS registry key on server *SQLServer.domain*  The operating system reported error 6: The system cannot find the file specified.	SMS_SITE_COMPONENT_MANAGER	9/07/2015 11:21:58 AM	4672 (0x1240)
    
    ERROR: failed to access server "\\*SQLServer.domain*", probably because the machine is down, the network is down, or the Site System Installation Account is misconfigured.  CSiteSystemInstallationAccount::Connect() returned 0x80070035: The operation completed successfully.	SMS_SITE_COMPONENT_MANAGER	9/07/2015 11:22:22 AM	8060 (0x1F7C)
    Server reinstallation failed and will be retried in the next polling cycle.	SMS_SITE_COMPONENT_MANAGER	9/07/2015 11:22:22 AM	8060 (0x1F7C)
    

    As mentioned previously, the remote SQL Server is currently offline.

    Thanks

    Thursday, July 9, 2015 1:43 AM